Welcome to the North American Subaru Impreza Owners Club Wednesday August 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-03-2008, 07:20 PM   #1
WhiteH2O
NASIOC Supporter
 
Member#: 452
Join Date: Oct 1999
Chapter/Region: NWIC
Location: Gig Harbor, WA
Vehicle:
'06 GX470

Default Keyless entry system going crazy...

My car has been tweeking out lately. It will refuse to start and make a strange clicking sound (parking and guage lights flashing to the clicking). This happened for the third time today, and I found where the clicking is coming from, from the "keyless entry system" box under the dash. Locking and unlocking the car seems to "reset" the problem, although it normaly takes about 5 minutes or so for it to work.

So the question is: how do I fix this?

I have had thoughts of getting an alarm, will an alarm replace this box? Better yet, is the box really the problem, or just a symptom of a bigger problem?

This is on a '98 Legacy with a swap ('02 WRX harness), but the origional keyless system. Problems have just started happening, so I don't really think the problem is with the swap. My guess is that the keyless entry system just went crazy. What do you think?
* Registered users of the site do not see these ads.
WhiteH2O is offline   Reply With Quote
Old 04-03-2008, 08:23 PM   #2
thedaddyb
Scooby Specialist
 
Member#: 64374
Join Date: Jun 2004
Chapter/Region: MAIC
Location: Baltimore, MD
Vehicle:
07 WRX SWP *SOLD
03 2.5ts BRP long gone

Default

well in 98, the keyless modules were a dealer aftermarket part manufactured by code alarm for subaru.

If it has it's alarm feature turned on and connected, it will activate a starter kill relay which physically cuts the starter wire preventing the car from starting. It sounds like the alarm itself is being triggered. Hence the flashing parking lights. It is usually accompanied by a honking horn or siren but that might not be connected anymore.

Look up a search on the wiring diagrams for those puppies and you should be able to remove it yourself. All you will need is some wire cutters and electrical tape. Just make sure you only cut one wire at a time and then tape it up to avoid blowing fuses and other damage.

If you aren't too comfortable doing it yourself and plan on getting an aftermarket alarm installed. Most shops only charge a nominal fee to remove the existing system.
thedaddyb is offline   Reply With Quote
Old 04-04-2008, 03:11 AM   #3
WhiteH2O
NASIOC Supporter
 
Member#: 452
Join Date: Oct 1999
Chapter/Region: NWIC
Location: Gig Harbor, WA
Vehicle:
'06 GX470

Default

Hmm...

I don't think the car had an alarm feature on it (unless the box does, but the remote only has lock/unlock). The box just says keyless entry, and I don't really want to loose my keyless entry feature. I was buying the alarm going off theory for a while, but the keychain remote won't change what it is doing. Trying to lock or unlock it will just attempt to do just that, lock or unlock the car, but it doesn't work (you can hear it trying, though).

Are other people thinking that the box died? Does that sound like the most probable theory?
WhiteH2O is offline   Reply With Quote
Old 04-04-2008, 02:19 PM   #4
thedaddyb
Scooby Specialist
 
Member#: 64374
Join Date: Jun 2004
Chapter/Region: MAIC
Location: Baltimore, MD
Vehicle:
07 WRX SWP *SOLD
03 2.5ts BRP long gone

Default

the company I work for does the factory Ford alarms and remote starts.

They are also made by code alarm. (and actually the new subaru remote start modules are identical to the ones we install in fords. Just a different sticker)

Anyways, most of them use a master brain module that is used by all of their systems. For instance, the brain module is identical on the keyless units and the units that also offer alarm features. The only difference being what remotes are included and programming. So it is possible that somehow your keyless module had security features turned on which could be causing the problem.

If you aren't too concerned with an alarm system, a new keyless system can be had very cheaply. Figure units start at less than $50 from reputable brands.
thedaddyb is offline   Reply With Quote
Old 04-04-2008, 04:05 PM   #5
WhiteH2O
NASIOC Supporter
 
Member#: 452
Join Date: Oct 1999
Chapter/Region: NWIC
Location: Gig Harbor, WA
Vehicle:
'06 GX470

Default

Very informative, that answered a lot of questions, thanks for the reply.

I have been thinking about an alarm for a little while now, maybe this is my chance to get one. Or, maybe I will go the cheap route and just get a new keyless system.
WhiteH2O is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyless entry system problem!!! Leonardo Car Audio, Video & Security 4 03-17-2003 12:53 PM
How easy would it be to remove the keyless entry system? Corn-Picker Car Audio, Video & Security 1 08-15-2002 06:19 PM
FS: Keyless entry system Jgrahn555 Forester Forum 0 05-09-2001 08:38 PM
Keyless Entry System BOB YOUNG Car Audio, Video & Security 1 12-28-2000 12:56 AM
Factory keyless entry system jman2222 Car Audio, Video & Security 4 11-14-2000 05:09 PM


All times are GMT -4. The time now is 11:04 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.