Welcome to the North American Subaru Impreza Owners Club Sunday September 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Southern California Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Southern California Impreza Club Forum -- SCIC > SCIC Private Classifieds

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-08-2008, 03:01 AM   #1
crashtest sonny
Scooby Specialist
Member Sales Rating: (25)
 
Member#: 78675
Join Date: Jan 2005
Location: huntington beach, CA
Vehicle:
2002 white bugeye
04 kawasaki 636

Default WTB: center clock pod and clock

my clock for some reason isnt work. anyone have a clock and pod they want to get rid of? im locate in huntington beach. thanks.
* Registered users of the site do not see these ads.
crashtest sonny is offline   Reply With Quote
Old 04-08-2008, 03:18 AM   #2
lb05wrx
Scooby Newbie
Member Sales Rating: (4)
 
Member#: 172704
Join Date: Feb 2008
Chapter/Region: SCIC
Location: Long Beach
Vehicle:
2005 Impreza WRX

Default

Hate to go trivial but did you check the connection and the fuse?
lb05wrx is offline   Reply With Quote
Old 04-08-2008, 10:15 AM   #3
crashtest sonny
Scooby Specialist
Member Sales Rating: (25)
 
Member#: 78675
Join Date: Jan 2005
Location: huntington beach, CA
Vehicle:
2002 white bugeye
04 kawasaki 636

Default

i have check both... when it was in the process of dying.. the clock would turn on once in a while..and now its completely dead. before it would just take a couple of hits on top and it'll turn on, now it doesnt. fuse is not blown. connector is connected properly.
crashtest sonny is offline   Reply With Quote
Old 04-08-2008, 11:21 AM   #4
lb05wrx
Scooby Newbie
Member Sales Rating: (4)
 
Member#: 172704
Join Date: Feb 2008
Chapter/Region: SCIC
Location: Long Beach
Vehicle:
2005 Impreza WRX

Default

That's strange, never heard of that.
lb05wrx is offline   Reply With Quote
Old 04-08-2008, 01:23 PM   #5
wrbwrx86
Scooby Specialist
Member Sales Rating: (2)
 
Member#: 105361
Join Date: Jan 2006
Chapter/Region: BAIC
Location: sf bay area
Vehicle:
2004 FXT
JBP

Default

connector? did you actually check the soldering? haha mine is dead too but i haven't checked.

Last edited by wrbwrx86; 04-08-2008 at 01:45 PM.
wrbwrx86 is offline   Reply With Quote
Old 04-08-2008, 01:42 PM   #6
ankyle62
Scooby Newbie
Member Sales Rating: (6)
 
Member#: 104298
Join Date: Jan 2006
Chapter/Region: SCIC
Location: SanDiego
Vehicle:
2002 wrx wagon
black/dirt covered

Default

mine does the same thing, it works sometimes or is really dim or just doesnt work at all.
ankyle62 is offline   Reply With Quote
Old 04-09-2008, 12:42 PM   #7
crashtest sonny
Scooby Specialist
Member Sales Rating: (25)
 
Member#: 78675
Join Date: Jan 2005
Location: huntington beach, CA
Vehicle:
2002 white bugeye
04 kawasaki 636

Default

bump

anyone experience this also?
crashtest sonny is offline   Reply With Quote
Old 04-09-2008, 02:36 PM   #8
Monku Monku
Scooby Newbie
Member Sales Rating: (0)
 
Member#: 82307
Join Date: Mar 2005
Location: Culver City, CA
Vehicle:
02 wagon
WRB

Default

Quote:
Originally Posted by crashtest sonny View Post

anyone experience this also?
Mine died months ago.
Monku Monku is offline   Reply With Quote
Old 04-11-2008, 03:11 AM   #9
crashtest sonny
Scooby Specialist
Member Sales Rating: (25)
 
Member#: 78675
Join Date: Jan 2005
Location: huntington beach, CA
Vehicle:
2002 white bugeye
04 kawasaki 636

Default

bumppppp
crashtest sonny is offline   Reply With Quote
Old 04-11-2008, 12:33 PM   #10
mythattak
Scooby Specialist
Member Sales Rating: (5)
 
Member#: 162036
Join Date: Oct 2007
Chapter/Region: SCIC
Location: Fullerton OC
Vehicle:
06 WRX
OBP

Default

i got one sitting in my closet that i wasnt really looking to sell, but if i get the wire for the airbag light from u and the price is right ya never know...
mythattak is offline   Reply With Quote
Old 04-11-2008, 12:36 PM   #11
crashtest sonny
Scooby Specialist
Member Sales Rating: (25)
 
Member#: 78675
Join Date: Jan 2005
Location: huntington beach, CA
Vehicle:
2002 white bugeye
04 kawasaki 636

Default

i dont think i have the airbag light on mine...
crashtest sonny is offline   Reply With Quote
Old 04-11-2008, 12:37 PM   #12
mythattak
Scooby Specialist
Member Sales Rating: (5)
 
Member#: 162036
Join Date: Oct 2007
Chapter/Region: SCIC
Location: Fullerton OC
Vehicle:
06 WRX
OBP

Default

hmm... is it the same one that fits the 06?
mythattak is offline   Reply With Quote
Old 04-14-2008, 11:20 AM   #13
crashtest sonny
Scooby Specialist
Member Sales Rating: (25)
 
Member#: 78675
Join Date: Jan 2005
Location: huntington beach, CA
Vehicle:
2002 white bugeye
04 kawasaki 636

Default

im not sure if its the same as 06, for the 02 its just the light, no airbag light.

bump
crashtest sonny is offline   Reply With Quote
Old 04-14-2008, 02:53 PM   #14
monkeytronZ
Scooby Specialist
Member Sales Rating: (9)
 
Member#: 7255
Join Date: Jun 2001
Default

Quote:
Originally Posted by crashtest sonny View Post
i have check both... when it was in the process of dying.. the clock would turn on once in a while..and now its completely dead. before it would just take a couple of hits on top and it'll turn on, now it doesnt. fuse is not blown. connector is connected properly.
exactly the same story here. 02 wrx. i have a trusty sundial on my roof though, so its all good.
monkeytronZ is offline   Reply With Quote
Old 04-14-2008, 06:12 PM   #15
crashtest sonny
Scooby Specialist
Member Sales Rating: (25)
 
Member#: 78675
Join Date: Jan 2005
Location: huntington beach, CA
Vehicle:
2002 white bugeye
04 kawasaki 636

Default

bump it
crashtest sonny is offline   Reply With Quote
Old 04-14-2008, 06:32 PM   #16
novacivic
Scooby Specialist
Member Sales Rating: (9)
 
Member#: 117980
Join Date: Jun 2006
Chapter/Region: NESIC
Location: Rochester, NH
Vehicle:
2005 sti
wr blue

Default

i have one pm me an offer
novacivic is online now   Reply With Quote
Old 04-14-2008, 06:56 PM   #17
crashtest sonny
Scooby Specialist
Member Sales Rating: (25)
 
Member#: 78675
Join Date: Jan 2005
Location: huntington beach, CA
Vehicle:
2002 white bugeye
04 kawasaki 636

Default

pm sent.

bump
crashtest sonny is offline   Reply With Quote
Old 04-15-2008, 10:31 AM   #18
crashtest sonny
Scooby Specialist
Member Sales Rating: (25)
 
Member#: 78675
Join Date: Jan 2005
Location: huntington beach, CA
Vehicle:
2002 white bugeye
04 kawasaki 636

Default

bbummpp
crashtest sonny is offline   Reply With Quote
Old 04-16-2008, 03:54 AM   #19
crashtest sonny
Scooby Specialist
Member Sales Rating: (25)
 
Member#: 78675
Join Date: Jan 2005
Location: huntington beach, CA
Vehicle:
2002 white bugeye
04 kawasaki 636

Default

upppp
crashtest sonny is offline   Reply With Quote
Old 04-16-2008, 01:47 PM   #20
fdrx7
Scooby Specialist
Member Sales Rating: (63)
 
Member#: 158797
Join Date: Sep 2007
Location: Los Angeles, Ca
Default

I have one off an 02. How about $40
fdrx7 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Stock WRX Clock Pod and A-Pillar Gauge Pod niemand_1 Interior/Dressup/Audio & Security 3 03-01-2010 05:02 PM
Prosport EGT, BOOST, OIL P, OIL T, Water T, clock pod and A-pillar pod lemon19mmm Interior/Dressup/Audio & Security 19 01-31-2010 08:46 AM
FS CA: 2002 WRX Stock Clock Pod and Clock Great Condition! ViperWRX Interior/Dressup/Audio & Security 1 10-06-2009 02:12 PM
WTB: MBC, Gauges (Boost) And Clock Pod PSM_02_WRX MAIC Private Classifieds 3 06-19-2009 12:09 AM
WTB:'03 24mm Front and Rear Swaybars, stock clock pod, and exhaust manifold BigClunke Private 'Wanted' Classifieds 3 04-04-2006 01:58 AM


All times are GMT -4. The time now is 04:31 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.