Welcome to the North American Subaru Impreza Owners Club Thursday July 2, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-09-2008, 11:28 AM   #1
skubydew16
Scooby Specialist
 
Member#: 121161
Join Date: Jul 2006
Chapter/Region: SCIC
Location: Redlands, California
Vehicle:
2006 Subie STI
Obsidian Black Pearl

Default HELP!!!!rear diff. temp light with wide open throttle!

hey guys. I was wondering if you can help me out..1st of all, a list of my mods:
hks downpipe, hks cat back, stage 2 tune..thats about it...

whenever i all in the throttle I start seeing my rear diff temp light faintly blinking. Sometimes it gets darker and more solid like its gonna stay on but then as soon as i let off the throttle and drive less aggressive it goes off! I was just wondering if anyone has this same problem? what should i do and what is causing this? any help would be greatly appreciated.

Thanks.
* Registered users of the site do not see these ads.
skubydew16 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-10-2008, 01:47 AM   #2
skubydew16
Scooby Specialist
 
Member#: 121161
Join Date: Jul 2006
Chapter/Region: SCIC
Location: Redlands, California
Vehicle:
2006 Subie STI
Obsidian Black Pearl

Default

bump!!
skubydew16 is offline   Reply With Quote
Old 04-10-2008, 02:42 AM   #3
JamesWilson
Former Vendor
 
Member#: 124833
Join Date: Sep 2006
Chapter/Region: TXIC
Location: Houston, TX
Vehicle:
2000 Legacy Wagon
Mystic Mountain Blueberry

Default

If you have access to an IR temperature gun, you can check what your temp is off of the back cover immediately after a hard pull versus just steady easy driving. Your temps are probably higher under heavy load (hence the light illumination), but you can get a general idea if you are truly running hotter than normal. What is the temperature spec for the light to come on?

Might be a good time just to check the diff oil level to ensure that you have enough in there (mystery leaks, underfilled from the factory/last change). Or you can just spend the couple of bucks for the Subaru 90 LSD oil and do a change.

Just my $0.02 since noone has posted
JamesWilson is offline   Reply With Quote
Old 04-10-2008, 02:18 PM   #4
skubydew16
Scooby Specialist
 
Member#: 121161
Join Date: Jul 2006
Chapter/Region: SCIC
Location: Redlands, California
Vehicle:
2006 Subie STI
Obsidian Black Pearl

Default

i appreciate all the advice!!!
skubydew16 is offline   Reply With Quote
Old 04-10-2008, 02:20 PM   #5
skubydew16
Scooby Specialist
 
Member#: 121161
Join Date: Jul 2006
Chapter/Region: SCIC
Location: Redlands, California
Vehicle:
2006 Subie STI
Obsidian Black Pearl

Default

has anybody else ever had an issue of this kind?
skubydew16 is offline   Reply With Quote
Old 04-10-2008, 03:02 PM   #6
udelslayer
Scooby Specialist
 
Member#: 117214
Join Date: Jun 2006
Chapter/Region: South East
Location: Youngsville, NC
Vehicle:
2003 WRX Wag'n Wagon
You can have.

Default

intermittent light?

I'd check the level first.
udelslayer is offline   Reply With Quote
Old 04-10-2008, 03:54 PM   #7
bulwnkl
Scooby Specialist
 
Member#: 41070
Join Date: Aug 2003
Location: Arizona
Vehicle:
2005 Black Tiger
(Black Turbo Baja)

Default

Agreed. Check oil level and verify temp w/thermometer (IR thermo as suggested is easiest). If temp is truly high (must compare to spec in manual) and oil level is OK, suggest pull a sample and send to Dyson Analysis ($60).
bulwnkl is offline   Reply With Quote
Old 04-10-2008, 04:56 PM   #8
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

check the connector at the rear diff plug for corrosion and fit.
munkis is offline   Reply With Quote
Old 04-12-2008, 10:32 PM   #9
skubydew16
Scooby Specialist
 
Member#: 121161
Join Date: Jul 2006
Chapter/Region: SCIC
Location: Redlands, California
Vehicle:
2006 Subie STI
Obsidian Black Pearl

Default

Quote:
Originally Posted by munkis View Post
check the connector at the rear diff plug for corrosion and fit.
Nice thanks!!!
skubydew16 is offline   Reply With Quote
Old 03-19-2010, 08:31 PM   #10
soon2beboostin
Scooby Newbie
 
Member#: 184186
Join Date: Jul 2008
Chapter/Region: Tri-State
Location: NNJ
Vehicle:
2005 sti
silver

Default

i also have this right now. i clean it then it goes away but keeps comming back on
soon2beboostin is offline   Reply With Quote
Old 03-19-2010, 08:46 PM   #11
tramix
Scooby Newbie
 
Member#: 148317
Join Date: May 2007
Chapter/Region: Tri-State
Location: NNJ
Vehicle:
1998 Subaru Impreza
Brilliant Red

Default

change the terminal.
tramix is offline   Reply With Quote
Old 03-21-2010, 06:10 PM   #12
soon2beboostin
Scooby Newbie
 
Member#: 184186
Join Date: Jul 2008
Chapter/Region: Tri-State
Location: NNJ
Vehicle:
2005 sti
silver

Default

terminal as in the metal ground piece?
soon2beboostin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!!!!rear diff. temp light with wide open throttle! skubydew16 Southern California Impreza Club Forum -- SCIC 8 04-10-2008 02:56 PM
Help! Rear Diff. Temp. Light manDown Service & Maintenance 2 05-25-2007 02:56 AM
rear diff temp light boostedsti06 Newbies & FAQs 9 10-18-2006 04:28 PM
Rear diff temp light and CEL Ryan Smith Transmission (AT/MT) & Driveline 1 01-22-2006 09:51 PM
V8 Cluster Rear Diff Temp light... ScreaminFast Electrical & Lighting 2 08-08-2005 03:50 AM


All times are GMT -4. The time now is 06:43 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.