Welcome to the North American Subaru Impreza Owners Club Friday September 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-09-2008, 06:37 PM   #1
illusin
Scooby Newbie
 
Member#: 80140
Join Date: Jan 2005
Vehicle:
2002 impreza wrx
sedona red

Default car just dies while driving, still have blitz gauges illuminated

Ok basically a lil while ago while driving from california to new york, my speedometer stopped working along with odometer. found out my speed sensor was bad and had to be replaced, i ordered the part and got it yesterday.

Also on top of that I would drive down the road and my car would all of a suddon just shut off, no lights no nothing with the exception of my Blitz gauges which stayed on. I replaced the speed sensor and i still have no speedometer or odometer showing, and my car is still in limp mode.

Guys got any ideas why it would do this ??
* Registered users of the site do not see these ads.
illusin is offline   Reply With Quote
Old 04-09-2008, 10:20 PM   #2
illusin
Scooby Newbie
 
Member#: 80140
Join Date: Jan 2005
Vehicle:
2002 impreza wrx
sedona red

Default

bump to the top again
illusin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
got an issue with my car dying while driving, killing battery eg33GC Electrical & Lighting 4 09-18-2009 09:25 PM
Car died while driving and wont stay running now, need your help!! nbiesold Service & Maintenance 1 03-24-2009 09:34 PM
Car dies while driving, answers? andrewjohnson Service & Maintenance 2 01-11-2008 05:38 PM
VF-34: Car died while driving, Please Help! Snow Drift Factory 2.0L Turbo Powertrain 40 10-06-2005 09:36 AM
Car died while driving now I have a loss in power. Any Suggestions?? skyredrex Factory 2.0L Turbo Powertrain 7 12-28-2003 05:01 PM


All times are GMT -4. The time now is 04:51 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.