Welcome to the North American Subaru Impreza Owners Club Saturday November 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-13-2008, 08:11 PM   #1
weldrwomn
Scooby Newbie
 
Member#: 167368
Join Date: Dec 2007
Location: Ohio
Vehicle:
2005 Impreza Outback
Blue

Default Engine revving?

Is it normal for the engine to rev to approx 2000rpms then back down to about 1000 - 1500 when coming to a stop (i.e. stop light, stop sign, etc)?

It is a 2005 Subaru Impreza Outback Sport SE with a 5 speed trans. (non-turbo)
* Registered users of the site do not see these ads.
weldrwomn is offline   Reply With Quote
Old 05-13-2008, 09:29 PM   #2
rexman2002
Scooby Specialist
 
Member#: 140244
Join Date: Feb 2007
Chapter/Region: MWSOC
Location: Chicago
Vehicle:
02 bugeye
"stare ale jare"

Default

No. Btw your car idles at 750rpms, but not 100% sure since you have a non-turbo. It should only idle at 1.5k-2K at startup and slowly go down.
rexman2002 is offline   Reply With Quote
Old 05-14-2008, 01:52 AM   #3
Ukashi82
Scooby Newbie
 
Member#: 174502
Join Date: Mar 2008
Chapter/Region: MWSOC
Location: Des Plaines, Il
Vehicle:
2007 07 STi
WR BLUE Mica

Default

I have the same "problem" on my STi. During driving when i'm going to stop the car and I engage clutch engine rpm drops to 750 and then jumps to 1000 or so. it occurs from time to time. I used to have 06 wrx and that did the same. I think it's normal.
Ukashi82 is offline   Reply With Quote
Old 05-14-2008, 07:44 PM   #4
Jaylyons1
Scooby Specialist
 
Member#: 113884
Join Date: May 2006
Chapter/Region: MAIC
Location: Baltimore, MD
Vehicle:
2013 BRZ
Black

Default

Does this on my STi. The tuners I have spoke with tell me its normal. They plugged up just to make sure and everything runs good.
Jaylyons1 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine revving in neutral, no throttle mikejmccar General Community 7 11-30-2005 11:00 PM
minardi engine revving twinkle twinkle little star? SCRAPPYDO Motorsports 5 10-07-2005 02:15 AM
Engine revving by itself Rippa Service & Maintenance 14 05-11-2004 05:03 PM
Help with strange engine revving, anyone? Robmat South East Region Forum 4 06-09-2003 12:02 AM
CEL and engine revving on its own in the middle of a shift. AcceleratedConcepts Warranty Issues & SOA Problems 6 10-07-2002 11:43 PM


All times are GMT -4. The time now is 06:26 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.