Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-15-2008, 02:41 PM   #1
soulbazz
Scooby Specialist
 
Member#: 95916
Join Date: Sep 2005
Chapter/Region: NESIC
Location: Rhode Island
Vehicle:
2004 Impreza WRX
1998 Legacy GT Wagon

Default Are Piaa 520 (fogs) plug and play with factory wiring?

So i'm looking to get either the rally innovations fog conversion or jdm fog surrounds. I already have a set of Piaa 520's and was wondering, once I get the surrounds and brackets sorted out, can I just plug the 520's up to the factory fog wires? I believe the piaa's are 85 watts, which i assume is more than the factory fogs, will that make a difference?

Thanks for the help
* Registered users of the site do not see these ads.
soulbazz is online now   Reply With Quote
Old 04-16-2008, 01:23 PM   #2
soulbazz
Scooby Specialist
 
Member#: 95916
Join Date: Sep 2005
Chapter/Region: NESIC
Location: Rhode Island
Vehicle:
2004 Impreza WRX
1998 Legacy GT Wagon

Default

bump for help
soulbazz is online now   Reply With Quote
Old 04-16-2008, 04:01 PM   #3
jdubya301
Scooby Specialist
 
Member#: 139076
Join Date: Jan 2007
Chapter/Region: MAIC
Location: Scranton PA
Vehicle:
2002 stg2 wagon
03 suzuki sv650s

Default

85 watts is a little too much for the factory wiring to handle. i would use a relay and a wiring harness with at least 14g wiring.

also you may want to think about running the lights with your highbeams, depending on the beam pattern. i am not familiar with the light output of the piaa 520s, but if they are a driving beam i would strongly reccommend you wire them up to turn on with the higbeam switch.

i can help you with wiring, just give me a shout.
jdubya301 is offline   Reply With Quote
Old 04-16-2008, 04:16 PM   #4
soulbazz
Scooby Specialist
 
Member#: 95916
Join Date: Sep 2005
Chapter/Region: NESIC
Location: Rhode Island
Vehicle:
2004 Impreza WRX
1998 Legacy GT Wagon

Default

Quote:
Originally Posted by jdubya301 View Post
85 watts is a little too much for the factory wiring to handle. i would use a relay and a wiring harness with at least 14g wiring.

also you may want to think about running the lights with your highbeams, depending on the beam pattern. i am not familiar with the light output of the piaa 520s, but if they are a driving beam i would strongly reccommend you wire them up to turn on with the higbeam switch.

i can help you with wiring, just give me a shout.
Thanks for the help!

They are fog pattern, so I planned on wiring them up the same way as the factory fogs and using the factory button

I should get the housing sorted out in the next couple weeks
soulbazz is online now   Reply With Quote
Old 04-16-2008, 06:23 PM   #5
jdubya301
Scooby Specialist
 
Member#: 139076
Join Date: Jan 2007
Chapter/Region: MAIC
Location: Scranton PA
Vehicle:
2002 stg2 wagon
03 suzuki sv650s

Default

Quote:
Originally Posted by soulbazz View Post
Thanks for the help!

They are fog pattern, so I planned on wiring them up the same way as the factory fogs and using the factory button

I should get the housing sorted out in the next couple weeks
just make sure you use a high quality bosche relay when you do the wiring work.

dont use the crappy autozone or knock off relays.. they are very susceptible to shorts and fires.
jdubya301 is offline   Reply With Quote
Old 02-11-2009, 03:08 PM   #6
soulbazz
Scooby Specialist
 
Member#: 95916
Join Date: Sep 2005
Chapter/Region: NESIC
Location: Rhode Island
Vehicle:
2004 Impreza WRX
1998 Legacy GT Wagon

Default

This is an old thread, but I had a new question, so instead of starting a new thread I'll continue here...

I mounted up the Piaa 520's with no problem and they have been working great for the last 6 months or so. The kit came with a Piaa wiring harness, relay, and switch which I used to install them.

After stringing the wires behind the fender and back into the cabin I followed the Piaa instructions and spliced (i'm not sure if that is the right word) the factory fog light wire together with the Piaa wires using a supplied connector clip thingy Piaa supplied to get power.


So the Piaa's now work the same way the factory fogs did (they turn off when the high beams are on) and they are on their own switch (supplied by Piaa)...if I push the original factory fog button, the button lights up but nothing happens. The piaas will go on only when using the piaa switch

sooo... thats the background now for my question...

could I reconnect the factory fogs, all of the original wiring is still there, and use both the factory fogs and piaas at the same time? Will doing this cause a short somewhere? Is this dangerous?

sorry for the long post I just thought I should explain what I have going on before asking my question, Thanks in advance for any responses

Last edited by soulbazz; 02-11-2009 at 03:49 PM.
soulbazz is online now   Reply With Quote
Old 02-12-2009, 04:22 PM   #7
dwmoss_68
Scooby Specialist
 
Member#: 6030
Join Date: Apr 2001
Chapter/Region: Tri-State
Location: Northeastern PA , USA
Vehicle:
04 Gold FXT
07 WRB FXT Sport

Default

I'm guessing that since the stock systems use a "switched" ground setup, the piaa wiring diagram is based on a "switched" positive.

I'm not sure what you desired finished setup is, but...
I believe you could modify the wiring on the piaa's to work with the factory switch.
Unfortunately you would need one of the electrical gurus help you with that one.

dm
dwmoss_68 is offline   Reply With Quote
Old 02-12-2009, 07:47 PM   #8
soulbazz
Scooby Specialist
 
Member#: 95916
Join Date: Sep 2005
Chapter/Region: NESIC
Location: Rhode Island
Vehicle:
2004 Impreza WRX
1998 Legacy GT Wagon

Default

Thanks for the response.

I currently have the PIAAs working on their own switch, which is fine, I don't want to change that.

I would like to add additional fog lights, possibly the stock fogs mounted in a different location or another set. The stock fogs wiring is still in the car.

I was wondering if I could merely hook the stock fogs back up to their original wires and run them same as they came from the factory, or whether or not this would cause a short in the system somewhere?

I do not think this should be a problem because the PIAAs are on their own seperate wiring harness which is connected directly to the battery. So the two sets of lights should therefore operate completely independant of one another.

I realized after my initial post that the only place the stock wires and PIAA wires are connected is for their respective switches. This was merely to tap into power for the PIAA supplied switch.

Please correct me if anything is said is wrong or if my understanding is flawed. That's why I wanted to ask others opinions, as a check to see if I screwed up.
soulbazz is online now   Reply With Quote
Old 04-09-2012, 08:42 PM   #9
seto19
Scooby Specialist
 
Member#: 223207
Join Date: Sep 2009
Chapter/Region: NESIC
Location: Canton, MA
Vehicle:
04 STi
WRB

Default

Old thread bump.

If I have the factory wiring harness and switch is it possible to just plug and play the PIAA 520 fog lights or do I have to use the harness/switch they provide?
seto19 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Want you upgrade your 1.8 or 2.2 Impreza to a 2.5? Plug and play with this computer!! rallyespec 1993 - 2001 Impreza Specific Parts 19 08-31-2009 07:35 PM
Want you upgrade your 1.8 or 2.2 Impreza to a 2.5? Plug and play with this computer!! rallyespec Engine/Power/Exhaust 4 07-26-2009 08:57 PM
04 sti steering wheel plug and play with 03 wrx? BuggeyEYED Interior & Exterior Modification 1 11-11-2007 11:48 AM
STi headlamps plug and play with WRX? litlechina Electrical & Lighting 4 11-18-2005 05:27 AM
STI and WRX plug and play harness with GP Moto Unichips are in! Dynamispeed Engine/Power/Exhaust 25 03-15-2004 07:44 PM


All times are GMT -4. The time now is 10:33 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.