Welcome to the North American Subaru Impreza Owners Club Sunday April 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-17-2008, 08:51 PM   #1
guy_in_red_wrx
Scooby Newbie
 
Member#: 169355
Join Date: Jan 2008
Default Car idles at 1k-1500 rpm.

Hey guys.
I left for work this morning for work. when i got home from runing some errands i notice that my car idles at 1k , when slight push the gas peddle the gauge went up and drop to 1500 , when let go of the peddle for 2-7 sec the guage went back down to 1k.
Usually idles at 500.
There are no mods as far as a simple cai, just plain stock , but only a catback exhaust that seems to vibrate against the heat sheilds.

anyone have any ideas where to check?.
* Registered users of the site do not see these ads.
guy_in_red_wrx is offline   Reply With Quote
Old 04-17-2008, 09:32 PM   #2
rexman2002
Scooby Specialist
 
Member#: 140244
Join Date: Feb 2007
Chapter/Region: MWSOC
Location: Chicago
Vehicle:
02 bugeye
"stare ale jare"

Default

What year, how many miles on your car? Have you ever cleaned the IACV since you owned the car. If you never cleaned it, and you have a good amount of miles on the car, it wouldn't be a bad idea to clean it, it might actually help. I never experienced any idle issues, but since I have 133k miles on my car, I cleaned it anyway. Btw, your car idles at ~750 rpms.

Link for cleaning the IACV

http://forums.nasioc.com/forums/showthread.php?t=781242
rexman2002 is offline   Reply With Quote
Old 04-17-2008, 10:24 PM   #3
mostasz
Scooby Specialist
 
Member#: 170512
Join Date: Jan 2008
Chapter/Region: MAIC
Location: Subaru Stars...Williamsburg/VA
Vehicle:
2012 WRX
Ice Silver

Default

mostasz is offline   Reply With Quote
Old 04-20-2008, 07:42 PM   #4
guy_in_red_wrx
Scooby Newbie
 
Member#: 169355
Join Date: Jan 2008
Default

the car is bout 75k
guy_in_red_wrx is offline   Reply With Quote
Old 04-20-2008, 07:46 PM   #5
guy_in_red_wrx
Scooby Newbie
 
Member#: 169355
Join Date: Jan 2008
Default

i have not cleaned my iacv sinced i own this car, still is not normal to idle that high.

Today the idle climbed up to 2k rpm.

now im really concerned.
guy_in_red_wrx is offline   Reply With Quote
Old 04-20-2008, 08:31 PM   #6
bdpAKAknox
Scooby Newbie
 
Member#: 121248
Join Date: Jul 2006
Chapter/Region: SCIC
Location: cp_gullywash
Vehicle:
2005 STI

Default

Have the stock airbox to put back on?
just to rule out the cai.
bdpAKAknox is offline   Reply With Quote
Old 04-21-2008, 12:53 AM   #7
Unabomber
Big Ron
Moderator
 
Member#: 18062
Join Date: Apr 2002
Chapter/Region: MAIC
Location: I can save you a ton of cash
Vehicle:
on car parts so PM
me b4 j00 buy

Default

Quote:
Originally Posted by guy_in_red_wrx View Post
i have not cleaned my iacv sinced i own this car, still is not normal to idle that high.

Today the idle climbed up to 2k rpm.

now im really concerned.
Well clean the damn thing. Clean it and report back as until then, you will just get 900 posts of clean your IACV.
Unabomber is offline   Reply With Quote
Old 04-21-2008, 06:32 AM   #8
fastwrx25
Scooby Guru
 
Member#: 126441
Join Date: Sep 2006
Chapter/Region: SCIC
Location: TPE
Vehicle:
03 bugeye

Default

CLEAN the IACV

this happened to me and its easy to fix.
fastwrx25 is offline   Reply With Quote
Old 04-21-2008, 12:59 PM   #9
timmah
Scooby Specialist
 
Member#: 54203
Join Date: Feb 2004
Chapter/Region: NESIC
Location: Albany, NY
Vehicle:
2011 WRX

Default

also clean the MAF, i had this issue and cleaning the MAf resolved it
timmah is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP! Car idles at rough and @ 500rpm TRSaitz_WRX Factory 2.0L Turbo Powertrain 11 02-25-2008 09:06 PM
What RPM did your last car idle at? ZeppelinPie792 Normally Aspirated Powertrain 15 12-07-2007 12:58 PM
HELP!! Just changed plugs and car surges at high boost/RPMs??? Clzay Factory 2.0L Turbo Powertrain 16 08-09-2007 05:50 PM
Car is rough at around 1500 rpm AzNStiImpreza Factory 2.0L Turbo Powertrain 11 08-13-2005 12:41 AM
What RPM does your car idle at? sbsnyder Normally Aspirated Powertrain 13 05-29-2001 12:50 AM


All times are GMT -4. The time now is 12:07 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.