Welcome to the North American Subaru Impreza Owners Club Tuesday July 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-28-2011, 10:35 PM   #1
Tryptofan
Scooby Newbie
 
Member#: 216924
Join Date: Jul 2009
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
2009 WRX STi
White

Default Loosening a stubborn V-band clamp

I know that loosening a stubborn bolt is a common topic, but this is something that has me stumped. I have a P&L tial 44mm wastegate with a stuck component preventing the wastegate from opening, leading to huge boost creep. I'm trying to get it off, but even with the aid of a (quite powerful) drill, I'm having no luck getting the V-band clamp to loosen. Is there a trick to removing these? I'm worried about stripping the hex slot, and I can't really get around with a socket on the other side, as there isn't enough room.

Any suggestions? I've PB-blastered the crap out of it already.
* Registered users of the site do not see these ads.
Tryptofan is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2 4" stainless v-band clamps BuggeyEYED Engine/Power/Exhaust 9 04-11-2012 12:26 PM
FS: VA: Shortblocks, Exhaust, Turbo's&Parts, S/S V-Band Clamps, etc. matt84 Engine/Power/Exhaust 19 10-12-2008 09:19 PM
HELP: need a tial 44mm v-band clamp chibich Mid Atlantic Impreza Club -- MAIC 0 06-07-2007 10:51 PM
V-Band clamps where to order? mattjk Factory 2.0L Turbo Powertrain 2 01-30-2003 03:05 AM
how to loosen a stubborn bolt? pdlindor Brakes, Steering & Suspension 18 12-17-2001 03:46 PM


All times are GMT -4. The time now is 03:49 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.