Welcome to the North American Subaru Impreza Owners Club Friday September 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-15-2001, 04:12 PM   #1
rallysquirrel
Scooby Specialist
 
Member#: 7006
Join Date: May 2001
Chapter/Region: NESIC
Location: Clifton Park, NY
Vehicle:
2007 SpecB

Default BRAKE light ON

I've now got a BRAKE light that usually comes on in the morning. Usually disappears when I use my car during the day. I've got a manual. I just spoke to a coworker who's got an automatic and she's been having the same problem during the last week? How weird? She's got no mods, so that makes me feel better.

Brake fluid is good, so I dunno.

Any Ideas

Jan Skrlj (Squirrel)
* Registered users of the site do not see these ads.
rallysquirrel is online now   Reply With Quote
Old 10-15-2001, 07:02 PM   #2
SubyTechMaster
Scooby Specialist
 
Member#: 4423
Join Date: Feb 2001
Location: Placerville, CA USA
Vehicle:
'04 08 Tribeca, SVX
Gold, Maroon

Default

Try removing the top of the Brake Fluid resevoir. Inside the cap there is a rubber diaphram, make sure the diaphram is collapsed inside the cap. If this is distended it can trigger the "Brake" light for low fluid.

If this is OK, make sure the handbrake is fully released
SubyTechMaster is offline   Reply With Quote
Old 10-15-2001, 07:35 PM   #3
gavin
Scooby Specialist
 
Member#: 3198
Join Date: Dec 2000
Location: Portland, OR USA
Vehicle:
2005 GT LTD Wagon
Garnet Red

Default

Also make sure that the fluid level is well above the min line. If it's boderline, it can trip the warning light when the fluid is cold. That would explain why it goes away, with use. I had mine drive me nuts, for about a week.
gavin is offline   Reply With Quote
Old 10-15-2001, 10:39 PM   #4
BLZ2DWL:
Scooby Newbie
 
Member#: 9919
Join Date: Sep 2001
Location: Blacksburg, VA
Vehicle:
1995 Legacy

Default float could be stuck

check that the float inside the resevoir is moving freely. Mine got stuck to the inside of the resevoir and wouldn't float up. When the float is up, the light is off, when fluid is low the float comes down and triggers the light. Good luck...

Brennan
BLZ2DWL: is offline   Reply With Quote
Old 10-15-2001, 11:27 PM   #5
francophile
Scooby Newbie
 
Member#: 8666
Join Date: Jul 2001
Location: Pennsylvania
Vehicle:
2005 STi
Crystal Gray

Default Antilock?

Dunno about the 97's but there seem to be a LOT of things that will turn on the brake warning light in my 00. One of them is the anti-lock system. It has a hydraulic pump and until the pressure is high enough the brake light is on - so is the antilock light. My last car was a Peugeot and it had antilocks too; the only way I knew that had enough pressure built up was by the brake warning light, and in winter that car used to take a few extra seconds to build pressure. It could be that on a Subie that's a few years old the same thing is happening.

Good luck,
-wdb
francophile is offline   Reply With Quote
Old 10-16-2001, 10:32 PM   #6
Prostho
Scooby Newbie
 
Member#: 3388
Join Date: Dec 2000
Location: Richmond, B.C, Canada
Vehicle:
1992 E34
Mauritius Blue

Default

I had same problem with my 94 Legacy Turbo...... in the mornings only the brake light would come on and won't go off even after handbrake is released... once the car is warmed up.. say around 15 minutes of driving. If i shut off the car and start it again.. it will go off. If i just keep driving it will stay on the whole time. My brake fluids were fine but pads are low....... and it doesn't seem to happen in warmer days.... Some have suggested that my handbrake cable has to be relubed and there was moisture in it, so it won't fully release, however i don't think that was the case for mine becoz even if i left my handbrake off for the whole nite, the brake light came back on once i reversed out of my driveway and hit the brakes.

after brake flush and new pads, it still happend on the next morning. but then after that it never happend again..! weird, but if it really worries u, brake flush will probalby work. worked for me.
Prostho is offline   Reply With Quote
Old 04-18-2008, 09:15 AM   #7
legacy1907
Scooby Specialist
 
Member#: 94024
Join Date: Aug 2005
Chapter/Region: South East
Location: Raleigh, NC
Vehicle:
05 WRX CGM
95 YJ Flat black

Default

alright bumping an old thread here....but my brake light stays on when its cold outside....problem is Im putting a turbo timer on and its going to mess w/ it im sure (since technically it could be put down and the car seems to think its still up) any ideas on how to solve this problem?
legacy1907 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake light on on the dash but brakes are good? Mikey52 Legacy Forum 8 01-19-2009 01:02 PM
no power steering? brake light on? battery light on? love2puck14 Factory 2.0L Turbo Powertrain 1 03-02-2008 09:12 PM
brake light on uder heavy braking? prometheum Brakes, Steering & Suspension 0 06-15-2007 06:19 AM
Question: brake light on, clock light out, daytime running light out PhoKingWRX Electrical & Lighting 2 05-22-2005 07:29 AM
e-brake light on when installing JDM lights WRX_NC Engine Management & Tuning 3 09-22-2004 10:05 AM


All times are GMT -4. The time now is 09:47 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.