Welcome to the North American Subaru Impreza Owners Club Sunday July 13, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-20-2008, 08:24 AM   #1
SubbyOBS
Scooby Newbie
 
Member#: 124035
Join Date: Aug 2006
Vehicle:
99 LOB and RS

Default A/C Compressor problem?

I recently turned on the A/C in my 97 IMP OBS because the hot weather and pollen. The first few times, the A/C compressor went okay without any squeezing or problem.

Today, when I turned the A/C on again, there was a squeezing sound comes out from the A/C compressor. Whenever, the compressor tried to kick on, it blew cool air (~40-50 F checked with infra-red at the vent). But whenever the squeezing sound comes, the air is not that cold at all (~60/70) or I should say just regular air blowing through.

I checked the belt tension and worth outs, it looks okay. I checked the R134 on the L-pressure port (while the a/c running) it is at the green region.

May be it is time for me to replace the A/C Compressor? If so, any instructions that I should take care of before take out the bolts and etc? The engine is 2.2L and it charge with R134.
* Registered users of the site do not see these ads.
SubbyOBS is offline   Reply With Quote
Old 04-20-2008, 08:55 AM   #2
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

There is no way to properly diagnose your situation from what you have posted. Unless you have the skills/knowledge and tools for AC testing and repair, this is a job best left to a shop. You don't want to just throw expensive parts at it.
Mulder is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Air Compressor Problems wtf vf22-wrx Off-Topic 27 03-22-2008 10:21 PM
Still Have AC Compressor Problem jikhead Service & Maintenance 9 09-24-2007 09:56 AM
AC compressor problems maciek Normally Aspirated Powertrain 3 10-15-2003 02:08 AM
Compressor Surge Problems? RshaoKh Factory 2.0L Turbo Powertrain 0 02-16-2003 01:32 PM
Compressor stall problem I think. Also, is there a such thing a wastegate slap? knuckles Factory 2.0L Turbo Powertrain 10 11-19-2002 07:28 PM


All times are GMT -4. The time now is 02:17 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.