Welcome to the North American Subaru Impreza Owners Club Sunday July 13, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-19-2008, 03:01 PM   #1
Venividivichi
Scooby Newbie
 
Member#: 176793
Join Date: Apr 2008
Chapter/Region: Tri-State
Vehicle:
2009 pontiac G8
black

Default Defi Boost gauge install

ok i put in my gauge today on my 2004 wrx (automatic dont kno if it matters but figured i'd let u know) and it never gets above 10 i installed it on the surge tank like the instructions said because the vacuum line it came with was to small to mount to BOV is this the wrong location or is my car just not getting proper boost its all stock and has close to 80k miles on it alright thanks for any input
* Registered users of the site do not see these ads.
Venividivichi is offline   Reply With Quote
Old 04-20-2008, 02:55 PM   #2
WRBLueGD2
Scooby Newbie
 
Member#: 139108
Join Date: Jan 2007
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2004 WRX
Blue

Default

Periods?
WRBLueGD2 is offline   Reply With Quote
Old 04-21-2008, 12:20 AM   #3
Venividivichi
Scooby Newbie
 
Member#: 176793
Join Date: Apr 2008
Chapter/Region: Tri-State
Vehicle:
2009 pontiac G8
black

Default

yeah i really gotta breathe when i type
Venividivichi is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
defi boost gauge install mardigras Interior & Exterior Modification 2 07-09-2008 12:57 AM
Questions: Defi boost gauge install 03'WRXtreme Interior & Exterior Modification 4 05-08-2008 02:34 PM
defi boost gauges install jlam86 Electrical & Lighting 1 12-13-2006 06:02 AM
Defi Boost Gauge installed-Low Readings? GT2RS Electrical & Lighting 6 02-06-2004 10:07 PM
DEFI boost gauge install help? elsanto Factory 2.0L Turbo Powertrain 2 10-07-2003 07:29 PM


All times are GMT -4. The time now is 02:39 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.