Welcome to the North American Subaru Impreza Owners Club Tuesday November 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-21-2008, 03:29 PM   #1
beaterwrx
Scooby Newbie
 
Member#: 174391
Join Date: Mar 2008
Location: summit county, co
Vehicle:
02 wrx
black

Default Windshield Wiper Issue

About a week ago im driving and it had just snowed, i wasnt going to use my wipers because i've ruined my previous cars wipers doing this. While i was turning my hand clipped the wipers and the wipers shuddered to life and one wiper caught into the other wiper! I turned the wipers off immediately but now the passenger side wiper just sits there. The drivers side still works fine, the Passenger side arm is limp, i can move it freely. What do you guys think the problem is and what do i need to get to fix it? I'm hoping its like my sisters VW....they have a failsafe and the wiper sort of pops out of gear to prevent major problems and then you just pop it back.
* Registered users of the site do not see these ads.
beaterwrx is offline   Reply With Quote
Old 04-22-2008, 10:40 AM   #2
Rodwrx23
Scooby Specialist
 
Member#: 170948
Join Date: Feb 2008
Chapter/Region: South East
Location: Pembroke Pines, FL
Default

Might want to check your linkage. The ball might have popped out of the bushing. I doubt that the motor went bad on just that one side.
Rodwrx23 is offline   Reply With Quote
Old 04-23-2008, 07:47 PM   #3
joebush44
Scooby Newbie
 
Member#: 163483
Join Date: Nov 2007
Location: SE Minnesota
Vehicle:
2007 STi
OBP

Default

Yeah, either the linkage is off or...there should be a nut that tightens down the wiper arm itself that is grooved. If the nut is loose the arm will slide up a little not letting the grooves to do their job. Id check to see if the arm is loose.
joebush44 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Windshield Wiper Arms ( wipers arm ) FD777 Car Care & Detailing 16 12-21-2007 04:28 PM
Windshield Wipers tora Vancouver Impreza Club Forum -- VIC 14 04-20-2001 02:52 AM
('93-'01) Where can i find a faster Windshield Wiper motor??? Fast like the WRC cars! SRI Performance Impreza Forum 1 04-11-2001 12:19 PM
Windshield wiper wing thinga-ma-jig Patrick Olsen New England Impreza Club Forum -- NESIC 7 03-12-2001 02:07 PM
Rear windshield wiper Wrx31 North West Impreza Club Forum -- NWIC 7 03-08-2000 08:29 AM


All times are GMT -4. The time now is 08:21 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.