Welcome to the North American Subaru Impreza Owners Club Monday September 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-23-2008, 08:29 PM   #1
jojofett
Scooby Newbie
 
Member#: 108166
Join Date: Feb 2006
Chapter/Region: MWSOC
Location: Chicagoland Area
Exclamation HELP! 3 indicator lights go off at same time!

Hi guys. I just bought an 05' STi. Just a few weeks into the car, 3 lights go off at the same time. The 'Battery', 'Brake', and the 'Rear diff. temp' light goes off. It's not all the time, but it seems like a loose connection somewhere. When I'm driving and hit the slightest bump they turn on and then maybe will turn off 1 - 15 minutes depending on how I'm driving. Sometimes when I start the car, they wont turn off for a bit.

Does anyone have any idea of whats going on? Like I said, it seems like a loose connection somewhere. Please help! Thanks in advance.
* Registered users of the site do not see these ads.
jojofett is offline   Reply With Quote
Old 04-23-2008, 11:20 PM   #2
Cougar4
Scooby Specialist
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

These lights are probably in the alternator field circuit. The alternator is most likely having trouble and you may need to replace it.
Cougar4 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
3 window switches stopped working at same time! austinp02 Electrical & Lighting 2 12-05-2008 10:55 PM
Abs Light Comes On And Off At Certain Times dmoney1770 Service & Maintenance 1 10-28-2008 05:14 PM
I have 5 lights on at same time?! EdHilario Electrical & Lighting 3 02-18-2008 06:57 PM
little RPM jump while letting off gas and engaging clutch at same time?? gerbs Factory 2.0L Turbo Powertrain 12 11-02-2003 03:21 AM
Someone confirm/deny method for switching driving lights/high beams on at same time wingtipz Electrical & Lighting 10 01-24-2003 12:38 PM


All times are GMT -4. The time now is 12:45 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.