Welcome to the North American Subaru Impreza Owners Club Wednesday May 6, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > General Community

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-24-2008, 11:05 AM   #1
subie_nation
Scooby Newbie
 
Member#: 159479
Join Date: Sep 2007
Chapter/Region: BAIC
Location: south bay area
Vehicle:
2005 dom3'd Sti
2006 zx10r

Angry Not getting the power out of my stage 2! b.s.

So a couple months back i retuned my car and added an Aps tmic, titek dp & up. I already had the cobb ap and perrin catback. the dyno said i was puttin down 265awhp and 295awtq. Not bad right?! well the second i drove it home i never felt a difference and ive driven in many stage2's. the other day i just wanted to compare my numbers to another dyno ( yes i know not all dynos are the same but still not a huge difference off). my car put down a outstanding 230awhp and 230awtq. can you say wtf. These are the numbers that i truly feel. Im not gonna say where i got my car tuned at but if you live in the bay area take a guess. both dynos were mustang dynos and the place i got my car tuned at is known for their amazing tuner and low rating dyno. whats the issue with my ride.

The second place i got my car dynod at said it was like there was no tune on the car wat so ever. so basically ive delt wit this for the last couple of months because i had nothing to compare to. My buddy just got the same car as mine 05 sti. tuned it himself with a general stage one map off cobbs site. we ran our cars. he pulled on me! how does this work! i spend all this money in parts and tuning and run like a stock sti.
* Registered users of the site do not see these ads.
subie_nation is offline   Reply With Quote
Old 04-24-2008, 11:41 AM   #2
07SWPSTi
Scooby Newbie
 
Member#: 158960
Join Date: Sep 2007
Chapter/Region: South East
Location: Bentonville, AR
Vehicle:
07 Impreza STi

Default

I had a similar problem when I drove to chicago to get my car tuned. Like you I was very disappointed when I went to my local track to run it. I ran slower times than most of my friends whom I used to beat on the track with the Cobb OTS Stage 2 map. However When I change my headers about three weeks ago I discovered that I had three major exhaust leaks on my car. So now I don't blame the tuner for my mistake. I should have checked and double checked everything before getting tuned. I can feel the difference between the old header and the new one. But I called my tuner to re-schedule for another tune so that I get the most out of it until I do a turbo swap in the future.

What I am saying is check everything make sure there are no leaks or anything. if not then I'd suggest you find a better tuner even if you have to drive 9 hours like I did. It will be worth it. I was not gonna settle for the crappy tune's my friends got from the local tuner.
07SWPSTi is offline   Reply With Quote
Old 04-24-2008, 03:21 PM   #3
2superblus
Scooby Specialist
 
Member#: 33526
Join Date: Mar 2003
Chapter/Region: MWSOC
Location: Brookfield, Wi
Vehicle:
2013 WRB W/Gold BRZ
08 STI WRB w/Gold, 02 WRX

Default

http://forums.nasioc.com/forums/show....php?t=1495279

See my thread look at your dyno sheet and check out the curve. You could post up your mods and dyno sheet so we can offer thoughts with insight
2superblus is offline   Reply With Quote
Old 04-24-2008, 03:24 PM   #4
juanmedina
Scooby Guru
 
Member#: 133146
Join Date: Nov 2006
Location: SC
Vehicle:
07 FPgreen 7.37@95
WRX VF39+E85 12.0, 121mph

Default

That sucks

juanmedina is online now   Reply With Quote
Old 04-24-2008, 06:17 PM   #5
subie_nation
Scooby Newbie
 
Member#: 159479
Join Date: Sep 2007
Chapter/Region: BAIC
Location: south bay area
Vehicle:
2005 dom3'd Sti
2006 zx10r

Default

i had the shop install my exhaust and everything else along with the tune. so if there are leaks like the 3 majors ones you had its on them. it feels like theres some power there but not that distinct hard stage2 pulling feelin. and you can tell there no way in hell my cars puttin down 295awtq. its almost like the car isnt running a map at all....... so say this isnt the tuners fault and theres some internal **** wrong just due to the boost bein raised. Should i uninstall the cobb ap completely before i take it to the dealer? one guy at the dealer said he'd still warrenty the car even with exhaust so i dont have to worry bout that.
subie_nation is offline   Reply With Quote
Old 04-24-2008, 08:41 PM   #6
Superglue WRX
Scooby Specialist
 
Member#: 106275
Join Date: Jan 2006
Chapter/Region: BAIC
Location: San Jose, CA
Vehicle:
New Chevy SUV
Government Motors White

Default

Do you have the AP to check what map you're currently running?

Weird stuff. Maybe take it over to LIC or EQ Tuning if you get a chance. I'm sure Ed or Noah can help you out.
Superglue WRX is offline   Reply With Quote
Old 04-25-2008, 10:57 AM   #7
subie_nation
Scooby Newbie
 
Member#: 159479
Join Date: Sep 2007
Chapter/Region: BAIC
Location: south bay area
Vehicle:
2005 dom3'd Sti
2006 zx10r

Default

yeah i made sure that the custom tune was the base map on my ap and not just the current realtime map. LIC and EQtuning you say? do they tune with ap or like ecutek/ open source. where they at?
subie_nation is offline   Reply With Quote
Old 04-25-2008, 11:10 AM   #8
stickygerbils
Scooby Newbie
 
Member#: 131292
Join Date: Nov 2006
Chapter/Region: South East
Location: Columbus, GA
Vehicle:
2008 MINI Cooper S
Chili Red/White

Default

Sounds like a leak to me.

Checked your turbo/exhaust?
stickygerbils is offline   Reply With Quote
Old 04-25-2008, 11:12 AM   #9
subz
*** Banned ***
 
Member#: 133379
Join Date: Nov 2006
Location: allentown PA
Vehicle:
2004 legacy gt
silver

Default

uppipe leak? i drove my friends stage 2 and it describes ur symptons
subz is offline   Reply With Quote
Old 04-25-2008, 11:39 AM   #10
07SWPSTi
Scooby Newbie
 
Member#: 158960
Join Date: Sep 2007
Chapter/Region: South East
Location: Bentonville, AR
Vehicle:
07 Impreza STi

Default

Quote:
Originally Posted by subie_nation View Post
i had the shop install my exhaust and everything else along with the tune. so if there are leaks like the 3 majors ones you had its on them. it feels like theres some power there but not that distinct hard stage2 pulling feelin. and you can tell there no way in hell my cars puttin down 295awtq. its almost like the car isnt running a map at all....... so say this isnt the tuners fault and theres some internal **** wrong just due to the boost bein raised. Should i uninstall the cobb ap completely before i take it to the dealer? one guy at the dealer said he'd still warrenty the car even with exhaust so i dont have to worry bout that.
yes thats exactly how mine felt. Again I suggest that you check for leaks.
07SWPSTi is offline   Reply With Quote
Old 04-25-2008, 12:22 PM   #11
Superglue WRX
Scooby Specialist
 
Member#: 106275
Join Date: Jan 2006
Chapter/Region: BAIC
Location: San Jose, CA
Vehicle:
New Chevy SUV
Government Motors White

Default

Quote:
Originally Posted by subie_nation View Post
yeah i made sure that the custom tune was the base map on my ap and not just the current realtime map. LIC and EQtuning you say? do they tune with ap or like ecutek/ open source. where they at?
http://www.eqtuning.com/ is in Davis and yes they tune with the AP

http://www.licmotorsports.com/main.htm is in Navato and also tune with AP
Superglue WRX is offline   Reply With Quote
Old 04-25-2008, 04:18 PM   #12
smurfwrx
Scooby Guru
 
Member#: 151928
Join Date: Jun 2007
Chapter/Region: South East
Location: Columbia, SC
Vehicle:
09 Triumph S3

Default

have you figured this out yet?
smurfwrx is offline   Reply With Quote
Old 04-25-2008, 07:11 PM   #13
subie_nation
Scooby Newbie
 
Member#: 159479
Join Date: Sep 2007
Chapter/Region: BAIC
Location: south bay area
Vehicle:
2005 dom3'd Sti
2006 zx10r

Default

i wouldnt be shocked if it was the up pipe because i had to take i back to the shop a day after they install the uppipe ( due to a rattle noise). Just to find out they didnt install the uppipe correctly. Im going up to the shop on saturday so imma have them go over the entire thing.

I know the cobb ap isnt spot on but it says im hittin 18.4 psi. would this still be the case if there was a leak in any part of the exhaust/ uppipe?
subie_nation is offline   Reply With Quote
Old 04-25-2008, 07:23 PM   #14
MrMakesitRain
Scooby Newbie
 
Member#: 168333
Join Date: Jan 2008
Chapter/Region: BAIC
Location: Hayward
Vehicle:
2006 STi
CGM

Default

is it GST? because i'm planning on getting wrx tuned there. PM me where you got it tuned please. i would appreciate it.
MrMakesitRain is offline   Reply With Quote
Old 04-25-2008, 07:31 PM   #15
subie_nation
Scooby Newbie
 
Member#: 159479
Join Date: Sep 2007
Chapter/Region: BAIC
Location: south bay area
Vehicle:
2005 dom3'd Sti
2006 zx10r

Default

Quote:
Originally Posted by MrMakesitRain View Post
is it GST? because i'm planning on getting wrx tuned there. PM me where you got it tuned please. i would appreciate it.
PM'ed
subie_nation is offline   Reply With Quote
Old 04-27-2008, 05:20 PM   #16
subie_nation
Scooby Newbie
 
Member#: 159479
Join Date: Sep 2007
Chapter/Region: BAIC
Location: south bay area
Vehicle:
2005 dom3'd Sti
2006 zx10r

Default

ok so i went to the shop yesterday and we think the problem has been solved. the dyno showed the car losing 2psi and running rich. The only thing the seems to be obvious is the s*** rubber hose that connects the tmic to the trottle body. the one that aps sent with their tmic. so were gonna try replace that with a silicone hose and better clamps. i go back tuesday to put it back on the dyno after the hose is replaced. god i hope thats all!
subie_nation is offline   Reply With Quote
Old 04-27-2008, 09:38 PM   #17
Superglue WRX
Scooby Specialist
 
Member#: 106275
Join Date: Jan 2006
Chapter/Region: BAIC
Location: San Jose, CA
Vehicle:
New Chevy SUV
Government Motors White

Default

Good luck. Glad to see "the shop" located the problem.
Superglue WRX is offline   Reply With Quote
Old 04-28-2008, 10:38 AM   #18
subie_nation
Scooby Newbie
 
Member#: 159479
Join Date: Sep 2007
Chapter/Region: BAIC
Location: south bay area
Vehicle:
2005 dom3'd Sti
2006 zx10r

Default

I dont understand y aps couldnt send 2 silicone hoses. the hose to the turbo is silicone.y wouldnt they both be? just to save a buck or two in production. its ****
subie_nation is offline   Reply With Quote
Old 04-28-2008, 12:04 PM   #19
JDM555
Scooby Specialist
 
Member#: 151449
Join Date: Jun 2007
Chapter/Region: BAIC
Location: San Jose, CA
Vehicle:
2007 Nissan 350Z
Carbon Silver

Default

Good you found out the problem. I would of imagined a leak somewhere because that is what happened to me. I had a fatty leak in my Manifold to UP gasket. I replaced it, and the power difference was unbelievable.
JDM555 is offline   Reply With Quote
Old 04-28-2008, 02:18 PM   #20
pooster.online
Scooby Newbie
 
Member#: 120461
Join Date: Jul 2006
Chapter/Region: BAIC
Location: Bay Area/ L.A
Vehicle:
2004 WRX STi JBP

Default

is there anyway to tell there is a leak besides the loss of power?
pooster.online is offline   Reply With Quote
Old 04-28-2008, 04:49 PM   #21
JDM555
Scooby Specialist
 
Member#: 151449
Join Date: Jun 2007
Chapter/Region: BAIC
Location: San Jose, CA
Vehicle:
2007 Nissan 350Z
Carbon Silver

Default

Basically turn the car on and search with your hand when it's cold. Around the gasket, go around and feel for any air leaking through. Or you can try the smoke technique where you light a match, then blow it out and if the smoke is getting pushed away, you know there is a leak. I don't think that's a very consistent technique, so I stick with the hand, and you have to feel around.
JDM555 is offline   Reply With Quote
Old 04-30-2008, 03:14 AM   #22
MrMakesitRain
Scooby Newbie
 
Member#: 168333
Join Date: Jan 2008
Chapter/Region: BAIC
Location: Hayward
Vehicle:
2006 STi
CGM

Default

any updates?
MrMakesitRain is offline   Reply With Quote
Old 04-30-2008, 03:30 AM   #23
Farnk
Scooby Specialist
 
Member#: 91093
Join Date: Jul 2005
Chapter/Region: TXIC
Location: Houston, Tx
Vehicle:
2002 Wrx

Default

Quote:
Originally Posted by subie_nation View Post
I know the cobb ap isnt spot on but it says im hittin 18.4 psi. would this still be the case if there was a leak in any part of the exhaust/ uppipe?
Unless its different for STi's I think thats the max the AP will read. So you might be running more boost.
Farnk is offline   Reply With Quote
Old 04-30-2008, 08:08 PM   #24
subie_nation
Scooby Newbie
 
Member#: 159479
Join Date: Sep 2007
Chapter/Region: BAIC
Location: south bay area
Vehicle:
2005 dom3'd Sti
2006 zx10r

Default

both hoses from the tmic were leakin bad. got them both replace with good silicone hoses and t bolt clamps. **** aint leakin now! bump for GST! truly a great shop and good guys!
subie_nation is offline   Reply With Quote
Old 04-30-2008, 09:21 PM   #25
MrMakesitRain
Scooby Newbie
 
Member#: 168333
Join Date: Jan 2008
Chapter/Region: BAIC
Location: Hayward
Vehicle:
2006 STi
CGM

Default

sweet. youve reaffirmed my confidence with GST. i need to get my wagon tuned now.
MrMakesitRain is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How Do I Get the Best Out of My 12" Sub??? wrxgeneration Car Audio, Video & Security 10 12-10-2008 01:06 PM
how can i get more power out of my stock outback impreza jbone2 Newbies & FAQs 4 03-03-2007 11:26 PM
Get the smell out of my nose! awdity Off-Topic 19 08-07-2005 08:00 PM
So I finally got the power out of my car that I wanted (thanks FIS) ruiner Texas Impreza Club Forum -- TXIC 35 03-19-2005 02:02 AM
How can I get the oil out of my pavement? Stroke Off-Topic 9 10-19-2003 04:10 PM


All times are GMT -4. The time now is 06:17 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.