Welcome to the North American Subaru Impreza Owners Club Saturday January 31, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-24-2008, 06:51 PM   #1
TJRCS
Scooby Specialist
 
Member#: 59199
Join Date: Apr 2004
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
2008 STI
DGM

Default Fuel leak only when fuel tank is full

Somewhat weird...

Whenever I fill up gas full tank, I can smell gasoline and see very small fuel dripping on the fuel tank. When the fuel tank goes below around 3/4 full mark, the smell and leak go away. Since I found this pattern, I usually fill it up to 3/4 full now. This prevents any leak problem.


I changed fuel pump gasket, but this won't solve the problem nor make any better. I used 3 cans Torco right before this happened (I used 1/2 can per full tank).

Possibly problems with evap system??
* Registered users of the site do not see these ads.

Last edited by TJRCS; 04-24-2008 at 06:56 PM.
TJRCS is offline   Reply With Quote
Old 04-24-2008, 08:39 PM   #2
EJ20_lee
Scooby Specialist
 
Member#: 106799
Join Date: Feb 2006
Chapter/Region: MWSOC
Vehicle:
2004 built 257 tomei
powered ^.^

Default

check your tank! see if theres hole or nothing!
have to fix it leaking fume to atmosphere is no good...lol
just go to any local shop and they are gonna check with fume sniffer!
EJ20_lee is offline   Reply With Quote
Old 04-28-2008, 01:50 AM   #3
TJRCS
Scooby Specialist
 
Member#: 59199
Join Date: Apr 2004
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
2008 STI
DGM

Default

any other suggestion?? dealer is asking $140 for just diagnosis
TJRCS is offline   Reply With Quote
Old 04-28-2008, 06:05 AM   #4
mopartodd
Scooby Newbie
 
Member#: 164929
Join Date: Nov 2007
Chapter/Region: South East
Location: Garner, NC
Vehicle:
2014 Impreza Premium
Jasmine Green Metalic

Default

Perhaps where the filler neck goes into the tank....sending unit, or fuel return lines.

Just a thought. Good luck.
mopartodd is offline   Reply With Quote
Old 04-28-2008, 10:35 AM   #5
cMags
Scooby Specialist
 
Member#: 88668
Join Date: Jun 2005
Chapter/Region: NESIC
Location: Lowell, MA
Vehicle:
'05 Outback Sport
5MT - Regal Blue / Grey

Outback Sport

It might be the filler neck - my brother had one rot out on him so it would leak over a half tank. You might be able to smell fuel under the car while filling up - maybe have a buddy pump while you look under by the filler see if it gets wet w/ fuel (too difficult to smell for it at the pump).
cMags is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Knock only when A/C is on? pbomers Open Source Reflashes 13 08-06-2010 07:22 PM
p0440 only when tank is 1/2 full or less cjfike Normally Aspirated Powertrain 10 04-30-2009 08:48 PM
Coolant leak, only when warmed up. ZoomnWRX Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 9 03-02-2007 03:21 PM
Hitt some sort of Fuel Cut only when taking a hard bend??? mrtrex Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 25 07-19-2005 01:16 PM
Losing reception in radio signals, but only when the engine is on? JjSwee Car Audio, Video & Security 3 01-06-2005 12:49 PM


All times are GMT -4. The time now is 12:34 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.