Welcome to the North American Subaru Impreza Owners Club Wednesday October 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-26-2008, 05:06 AM   #1
shinta-wrx-
Scooby Newbie
 
Member#: 11935
Join Date: Nov 2001
Location: Canada, British Columbia, Rich
Vehicle:
2002 WRX/C63
blue/white

Default high pitched whine coming from the turbo

Hi all,

I against my better judgment brought in my wrx a few years back to Midas when a check engine light came on randomly. When they initially tested it they said they couldn't find anything wrong and simply reset the ecu, of course within a day the CEL came back on. Apparently the problem was the temperature sensor, which they replaced.

When I got my car back everything seemed fine until I revved past 3000 rpm. Whenever the turbo activates a high pitched mechanical whine emanates from the engine bay. The sound is similar to a supercharger and is quite loud when you're outside the car. When driving the car hard, I don't notice any power loss, or anything that seems imminently destructive. Just a high pitched jet turbine like noise.

Has anyone had a similar experience? What could be wrong?
* Registered users of the site do not see these ads.
shinta-wrx- is offline   Reply With Quote
Old 04-26-2008, 10:56 PM   #2
rexyrex
Scooby Newbie
 
Member#: 169205
Join Date: Jan 2008
Default

that "whine" you're talking about is the turbo spooling faster. its a good sound
rexyrex is offline   Reply With Quote
Old 04-27-2008, 12:57 AM   #3
bmxpunk
Scooby Specialist
 
Member#: 89599
Join Date: Jun 2005
Chapter/Region: RMIC
Location: middle of nowhere, wyoming
Vehicle:
1995 almost 22B:)
red

Default

I would check a couple of things. Check to make sure that where the intercooler Y-pipe mounts to the turbo, that it is mounted correctly andthe clamp tight. Also check for little cracks here that could be leaking boost. I had this exact situation with a customers car once. THe hose was rolled and not on the turbo properly. fixed that only to find the intercooler y-pipe split.

Also check where you tubo inlet mounts on the front of your turbo, for similar incorrect mounting and cuts in the material.
bmxpunk is offline   Reply With Quote
Old 04-27-2008, 03:46 AM   #4
shinta-wrx-
Scooby Newbie
 
Member#: 11935
Join Date: Nov 2001
Location: Canada, British Columbia, Rich
Vehicle:
2002 WRX/C63
blue/white

Default

thanks bmxpunk I'll take a look at that.


rexyrex, If it were merely the 'turbo spooling' faster I wouldn't mind, but it is an ungodly high pitched mechanical whine. Unless during the first 4 years I owned the car the turbo never spooled up when I went WOT. I know when the turbo is fully spooled there is a mechanical whir, but whenever I hit 3000 rpm these days its like having a constant blow off valve sound but higher pitched and constantly increasing until I hit the redline.
shinta-wrx- is offline   Reply With Quote
Old 04-27-2008, 09:49 AM   #5
Subie Gal
GC84Ever
Super Moderator
 
Member#: 301
Join Date: Sep 1999
Chapter/Region: NWIC
Location: WA
Vehicle:
1970 FF-1 & '70 Van
02 WRX/01 RS

Default

Subie Gal is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
High Pitched Noise Coming From Engine Bay suds85 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 3 07-10-2009 05:31 PM
fluttering sound coming from the turbo ownnij Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 11 04-30-2008 06:34 PM
High pitched whining sound from my cable modem nt5k Off-Topic 14 01-21-2008 12:24 PM
High-Pitched Whine Coming from 4EAT Tranny...Minor Slippage...HELP!! JohnnyWas Transmission (AT/MT) & Driveline 8 04-17-2007 02:31 PM
High pitch sound coming from brake/suspension area txl146 Brakes, Steering & Suspension 4 05-08-2005 08:44 PM


All times are GMT -4. The time now is 03:37 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.