Welcome to the North American Subaru Impreza Owners Club Wednesday August 24, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 07-05-2007, 06:34 PM   #1
pmaryan
Scooby Newbie
 
Member#: 113686
Join Date: Apr 2006
Default 1996 Legacy Sedan Hesitation

I'll be starting from a stop and around 2500 or so it kicks low and then all of a sudden it kicks back in and its like a shot of NOS went into the engine, and it picks up acceleration. Seems to be worse with the A/C on.


I seem to be having hesitation on my 96 Legacy Sedan. 2.2 AWD. 110,000.

Plugs were just replaced with vpower plugs.
Wires were replaced at 75K.


I asked a buddy and they mentioned something about grounding wires, but the faq post for it is a big lengthy and confusing as to what works best, and if it even works.

Another thought was the front o2 sensor, but I'm not made of money, so I'd like to seek an opinion before I drop 100 bucks on a part that I don't need.
* Registered users of the site do not see these ads.
pmaryan is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-05-2007, 08:40 PM   #2
StuBeck
Scooby Guru
 
Member#: 19546
Join Date: Jun 2002
Chapter/Region: Tri-State
Location: Rochester, NY
Vehicle:
2009 Honda Fit

Default

I think it sounds like the O2 sensor, but try cleaning up the grounds first...since its free and all.
StuBeck is offline   Reply With Quote
Old 07-06-2007, 01:42 AM   #3
pmaryan
Scooby Newbie
 
Member#: 113686
Join Date: Apr 2006
Default

Bueller?
pmaryan is offline   Reply With Quote
Old 04-26-2008, 07:10 PM   #4
pmaryan
Scooby Newbie
 
Member#: 113686
Join Date: Apr 2006
Default

bump, I still have this happening once and awhile....
pmaryan is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1996 Legacy GT Sedan *Bay Area* blitzedcivic510 Private Vehicle 'For Sale' Classifieds 7 01-17-2008 10:01 PM
FS: 1996 Legacy LSI SEDAN Secret Sam Private Vehicle 'For Sale' Classifieds 3 01-27-2006 11:52 PM
FS 1996 Legacy Sedan LSI Secret Sam Private Vehicle 'For Sale' Classifieds 0 12-30-2005 12:45 AM
Thinking of a 1996 Legacy LSI... any comments?...suggestions? SportRacer Legacy Forum 2 05-07-2001 06:11 AM
1996 Legacy 2.5 GT Wagon AT TURBO? JasonK Legacy Forum 5 03-03-2001 12:56 AM

All times are GMT -4. The time now is 01:52 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.