Welcome to the North American Subaru Impreza Owners Club Wednesday January 28, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-27-2008, 09:32 PM   #1
stevedainee
Scooby Newbie
 
Member#: 173982
Join Date: Mar 2008
Chapter/Region: MAIC
Location: va. beach/ va
Vehicle:
2002 wrx
world rally blue

Default wtf coolant issue

alright here goes....i just replace my rad.; top rad hose; a/c belt and tension...car runs great but i noticed coolant was still needing to be replaced every couple of days...found i was gettin a leak in bottom hose rite where it attachs to engine....so im driving home and about a block from the house stop a a light hear something pop...my temp gauge spikes but quickly drops back down to normal...get home and i can see water on the front bumper rite in the middle....it's dark flashlight has no batteries get under car with lighter and whole under front bumper is wet but i dont see any hoses that arent connected and cant really trace where problems coming from any suggetsions...
* Registered users of the site do not see these ads.
stevedainee is offline   Reply With Quote
Old 04-27-2008, 10:16 PM   #2
mikeythejew
Scooby Specialist
 
Member#: 141672
Join Date: Feb 2007
Vehicle:
07' wrx
Mothballed until winter

Default

I would pressure test the cooling system and look for leaks. You used to be able to borrow a pressure tester from autozone which you still may be able to do. If your coolant is low, sometimes you need to add some coolant to help find the leak. You can use water if needed. There are other things but this is the first step I would take. You may see the leak plain as day during daylight hours.

You need to stop smoking btw.
mikeythejew is offline   Reply With Quote
Old 04-28-2008, 07:26 PM   #3
stevedainee
Scooby Newbie
 
Member#: 173982
Join Date: Mar 2008
Chapter/Region: MAIC
Location: va. beach/ va
Vehicle:
2002 wrx
world rally blue

Default

thanks for the feedback i have no idea whuts up i couldn't check it out today had to go to work and...but i took it round the block few times last night everything was normal....weird thing is my lower radiator hose was leakin..but now its not...idk????
stevedainee is offline   Reply With Quote
Old 04-30-2008, 08:04 PM   #4
stevedainee
Scooby Newbie
 
Member#: 173982
Join Date: Mar 2008
Chapter/Region: MAIC
Location: va. beach/ va
Vehicle:
2002 wrx
world rally blue

Default

found problem...new radiator sux and broke in less than a month...the company said they'll come and replace for free just need to pick up the broke one...so hopefully this ones last more than a f--n month....
stevedainee is offline   Reply With Quote
Old 05-21-2008, 08:14 PM   #5
schurmo
Scooby Newbie
 
Member#: 176758
Join Date: Apr 2008
Default

Weird, my went bad after 8 months. Are these replacement radiators that bad?

Schurmo
schurmo is offline   Reply With Quote
Old 05-22-2008, 11:07 AM   #6
drivin blind
Scooby Specialist
 
Member#: 73043
Join Date: Oct 2004
Chapter/Region: MWSOC
Location: Carson City, Michigan
Vehicle:
2011 STI/2010 370Z
Black/Black Cherry

Default

Quote:
Originally Posted by mikeythejew View Post
I would pressure test the cooling system and look for leaks. You used to be able to borrow a pressure tester from autozone which you still may be able to do. If your coolant is low, sometimes you need to add some coolant to help find the leak. You can use water if needed. There are other things but this is the first step I would take. You may see the leak plain as day during daylight hours.

You need to stop smoking btw.
He doesn't smoke. He's an arsonist! RP
drivin blind is offline   Reply With Quote
Old 05-26-2008, 07:32 PM   #7
Reddstars
Scooby Newbie
 
Member#: 75804
Join Date: Nov 2004
Chapter/Region: TXIC
Location: Pasadena and DeerPark, Tx!!!!
Vehicle:
2002 WRX sedan
Bukakke White wingless!

Default

Quote:
Originally Posted by stevedainee View Post
found problem...new radiator sux and broke in less than a month...the company said they'll come and replace for free just need to pick up the broke one...so hopefully this ones last more than a f--n month....
Just wondering what brand of rad did u buy? I just recently got a new one and had it for less than 2 months and looks like it has a hole or something right in the middle of the rad. Just wondering if it is the same brand?

Matt
Reddstars is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Coolant issue 1stwrx_inGuam South East Region Forum 8 08-07-2007 11:46 PM
coolant issues rs_two_five Normally Aspirated Powertrain 3 02-16-2007 07:16 PM
Forester coolant issue. Help! BigMikeLV Normally Aspirated Powertrain 6 09-04-2006 10:03 PM
Help: coolant issue?! USF97J4x4 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 15 06-23-2006 12:53 PM
Coolant issues rhockstra Service & Maintenance 8 12-11-2004 06:55 PM


All times are GMT -4. The time now is 08:33 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.