Welcome to the North American Subaru Impreza Owners Club Tuesday September 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > General Community

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 05-06-2008, 08:59 PM   #1
08SubieWRX
Scooby Newbie
 
Member#: 178758
Join Date: Apr 2008
Chapter/Region: MWSOC
Location: Youngstown, OH
Vehicle:
08 WRX Blu@19psi
08 STI Blk/ 09 WRX Slvr

Default HA got it all put on lets just say dang that s*** be nice


This is it all jacked up and ready to go.



THis is when the intercooler was all taken out.

It is so LOUD now it is insane. There is only one thing it is really not faster but it feels a little slower. Its ok tho i am getting it tuned by Tim Bailey on thursday at Buschur Racing. Then she will be nice and fast.

Any one have any suggestions why they think it is slow?? I was think cause the engine is not used to it and doesnt understand it. I reset the ECU today after i put it on. So it might just need to learn it agian....we will see
* Registered users of the site do not see these ads.

Last edited by 08SubieWRX; 05-06-2008 at 09:01 PM. Reason: sry pic didnt worl
08SubieWRX is offline  
Old 05-06-2008, 09:01 PM   #2
08SubieWRX
Scooby Newbie
 
Member#: 178758
Join Date: Apr 2008
Chapter/Region: MWSOC
Location: Youngstown, OH
Vehicle:
08 WRX Blu@19psi
08 STI Blk/ 09 WRX Slvr

Default

ha sry u can see the little rican man that helped lol
08SubieWRX is offline  
Old 05-06-2008, 09:11 PM   #3
redrex2002
Scooby Specialist
 
Member#: 118915
Join Date: Jun 2006
Chapter/Region: Tri-State
Location: Rochester, NY
Vehicle:
2002 wrx
srp

Default

so did you install a bigger intercooler??? all it looks like is you took it off and if you did just leave it off to not run one i dont understand?????
redrex2002 is offline  
Old 05-06-2008, 09:17 PM   #4
08SubieWRX
Scooby Newbie
 
Member#: 178758
Join Date: Apr 2008
Chapter/Region: MWSOC
Location: Youngstown, OH
Vehicle:
08 WRX Blu@19psi
08 STI Blk/ 09 WRX Slvr

Default

No i put it back on
08SubieWRX is offline  
Old 05-06-2008, 09:25 PM   #5
dillsky
Scooby Specialist
 
Member#: 109485
Join Date: Mar 2006
Chapter/Region: MAIC
Location: York, PA
Vehicle:
06 Blue TR
FP18g'd

Default

good thread.....
dillsky is offline  
Old 05-06-2008, 09:25 PM   #6
redrex2002
Scooby Specialist
 
Member#: 118915
Join Date: Jun 2006
Chapter/Region: Tri-State
Location: Rochester, NY
Vehicle:
2002 wrx
srp

Default

then what did you do?
redrex2002 is offline  
Old 05-06-2008, 09:37 PM   #7
08SubieWRX
Scooby Newbie
 
Member#: 178758
Join Date: Apr 2008
Chapter/Region: MWSOC
Location: Youngstown, OH
Vehicle:
08 WRX Blu@19psi
08 STI Blk/ 09 WRX Slvr

Default

I sry about that it was in the other thread. I but a full invidia tbe exhaust on. I will make a movie tommaro and post it up along with some good pics.
08SubieWRX is offline  
Old 05-06-2008, 09:37 PM   #8
Mavrik
Scooby Guru
 
Member#: 90347
Join Date: Jul 2005
Chapter/Region: AKIC
Location: Anchorage AK
Vehicle:
2013 BRZ & Imp 2.5RS
Yamaha FZ8

Default

bigger turbo?
Mavrik is offline  
Old 05-06-2008, 09:38 PM   #9
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

Please don't keep starting new threads.
Mulder is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Just saying hey, glad to be on the site. Mike Province Newbies & FAQs 10 05-16-2008 03:29 PM
Just one.... I got my springs put on. 03boxer4 Member's Car Gallery 20 05-04-2007 03:38 PM
okay people, channukah is over. just say "merry christmas" and be done with it.. alacrity024 Off-Topic 22 12-15-2004 03:54 PM
I did it! I put on my headers all by myself! rhdude Mid Atlantic Impreza Club -- MAIC 9 03-08-2002 10:55 PM
Lets see if I got it all covered... (Breaking in an engine) ba_feitl Newbies & FAQs 5 02-02-2001 12:58 AM


All times are GMT -4. The time now is 01:17 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.