Welcome to the North American Subaru Impreza Owners Club Thursday November 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-06-2008, 03:39 PM   #1
2wickedWRX
Scooby Specialist
 
Member#: 151211
Join Date: Jun 2007
Chapter/Region: TXIC
Location: Austin, Texas
Vehicle:
2007 RWD STI
WR blue

Default smoking turbo Help Please

so i swapped in a new vf43 the other week and i just started it today. i primed it and then when i started the car i saw a little bit of smoke start to form by the turbo. What is this? Could it be coolant i spilt on the uppipe or is there something else wrong
* Registered users of the site do not see these ads.
2wickedWRX is offline   Reply With Quote
Old 05-06-2008, 03:43 PM   #2
wrxblk02
Scooby Newbie
 
Member#: 115303
Join Date: May 2006
Chapter/Region: SWIC
Location: AZ
Vehicle:
2012 WRX
WRB

Default

that same thing happened after my vf43 install but i'm pretty sure it was just coolant it went away after a little bit
wrxblk02 is offline   Reply With Quote
Old 05-06-2008, 04:18 PM   #3
B-Mac
Scooby Newbie
 
Member#: 128579
Join Date: Oct 2006
Chapter/Region: South East
Location: Wilmington, NC
Vehicle:
2006 STI

Default

Any PB Blaster or anything that you sprayed on the bolts is probably burning off as well.
B-Mac is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Turbo help please! pictureboy Subaru Conversions 6 01-04-2006 04:36 PM
Smoking Problems. Help Please ShaggyGT Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 10 10-12-2005 08:13 PM
Smoked ballast? Help please 04RCSTI Electrical & Lighting 6 10-05-2005 04:47 PM
20G turbo help please (wet bearing housing) damn_4eat Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 12 03-24-2004 10:45 AM
Turbo help please! thepas Technical Forum Archive 5 08-12-2000 06:35 PM


All times are GMT -4. The time now is 12:37 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.