Welcome to the North American Subaru Impreza Owners Club Wednesday July 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-17-2008, 10:52 AM   #1
RS 1986
Scooby Newbie
 
Member#: 157272
Join Date: Aug 2007
Vehicle:
2013 wrx and 04rs
Silver

Default rear end screechys when I reverse

I am not sure where to post this as I do not know what the problem actually is. For about a month now when I go in reverse my car makes a screechy noise. It sounds like it is coming from the driver side back end. It will do it for say 2 seconds than stop for 2 than do it for 2 and so on. It does not do it at all when I go forward. It does this about 90% of the time I reverse. I do not think that it could be my brakes because the pads were replaced about 7,000 miles ago. The car is a 2004 2.5rs, manual with a little more than 40,000 on it. Does anyone have any idea what the problem could be? Later this week when I have time I plan on getting it looked at but until then I would like to have an idea of what is wrong.
* Registered users of the site do not see these ads.
RS 1986 is offline   Reply With Quote
Old 05-17-2008, 03:27 PM   #2
mikeythejew
Scooby Specialist
 
Member#: 141672
Join Date: Feb 2007
Vehicle:
07' wrx
Mothballed until winter

Default

I assume your front pads were replaced. On average in comparison to most cars, your rear pads with your mileage should have many miles left on them. Their is a brake forum here btw.

You say screechy as sounding like it's metal to metal. It's hard to say what it is without being their.

Best case scenario is brake dust causing the noise. If thats the case, using chlorinated brake cleaner should do the trick.
mikeythejew is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear end noise when wet? genny_1 Newbies & FAQs 7 12-03-2009 01:05 AM
Rear End Clunking When I Let Off Gas cn4m Factory 2.0L Turbo Powertrain 8 08-25-2009 12:42 AM
Rear end Tweaks when accelerating BoOsT-FeIn Brakes, Steering & Suspension 0 06-07-2009 09:32 PM
Rear end clunk when shifting quickly. bdpAKAknox Transmission (AT/MT) & Driveline 3 07-23-2007 12:49 PM
odd noise from rear end in reverse tmeh Transmission (AT/MT) & Driveline 13 01-05-2005 11:25 PM


All times are GMT -4. The time now is 05:32 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.