Welcome to the North American Subaru Impreza Owners Club Tuesday July 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-02-2008, 12:56 PM   #1
defiancecp
Scooby Newbie
 
Member#: 168859
Join Date: Jan 2008
Default '03 wrx - a/c compressor shutoff by...?

So my '03 WRX has GREAT A/C - when it works. However, it intermittently stops working, seemingly at random. Looking at it on gauges, when it works, the pressures are fine around 175 high, 40 or so low. When it kicks off, the pressures do just what you'd expect, equalize low & high at around 95 psi. When it kicks off, it might come right back on in a minute, or it might stay off indefinitely. Looking at it with it "stuck" off, I can confirm that there's nothing wrong with pressures, the evaporator isn't frozen up (air flows fine... as long as you like 85+ degree air in your face), no voltage at the compressor. Manually running a 12v wire to the compressor makes the a/c work wonderfully (normal pressures, good temps, etc). I'm checking the relay as well, but I believe it is fine ( I can trip it 100% of the time by putting 12v across the coils). So, it is my belief that the 12v supply to the compressor is being broken somewhere between the switch and the compressor. I know that different vehicles have different break points; some have temperature sensors on the evaporator, some have low and/or high pressure sensors in the lines, some have combinantions of any or all of the above. Does anyone know which the '03 WRX would have, and where it (they) are located? If anyone knows of a schematic of the a/c system somewhere, that would be extremely helpful. Also if anyone disagrees with my conclusions, please feel free to point out where I'm going wrong.

Thanks!
* Registered users of the site do not see these ads.
defiancecp is offline   Reply With Quote
Old 07-02-2008, 04:58 PM   #2
crampfan
Scooby Specialist
 
Member#: 74321
Join Date: Nov 2004
Chapter/Region: MWSOC
Location: clarksville AR
Vehicle:
2004 wrx wag
black UTEC stg 4

Default

the pressure switch is the likely problem. if you need a diagram PM me your fax # and I will get you one.
crampfan is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WTB - 2002 WRX A/C Compressor / A/C Compressor Clutch wetwilly1169 Private 'Wanted' Classifieds 0 06-16-2007 02:17 PM
FS: 18"Gold Prodrive P1's by OZ Racing & Actual WRC front bumper for '02-'03 WRX/STi mrrallysti Wheels/Tires 10 12-11-2006 11:12 PM
FS: 18"Gold Prodrive P1's by OZ Racing & Actual WRC front bumper for '02-'03 WRX/STi mrrallysti SCIC Private Classifieds 17 12-11-2006 11:09 PM
HELP!! Trade '03 WRX up to '03 Evo??? JM530 General Community 39 11-13-2004 05:54 PM
A/C Compressor Shutoff Big_Hitter Texas Impreza Club Forum -- TXIC 11 05-04-2002 12:39 AM


All times are GMT -4. The time now is 01:47 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.