Welcome to the North American Subaru Impreza Owners Club Saturday November 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-20-2008, 08:49 PM   #1
wrxnova1
Scooby Specialist
 
Member#: 112854
Join Date: Apr 2006
Chapter/Region: MAIC
Location: VA
Vehicle:
2004 STi
WRB

Default What would the Airbag light, no clock, and no radio all have in common?

I'm assuming I blew a fuse but checked the Airbag fuses (in fuse box near steering wheel) and both are fine. It occured after I removed an aftermarket boost gauge I had installed and failed to disconnect the battery prior to uninstall being a dumb ass . Any suggestions?

EDIT :

I did not go through the clock pod as I only had 1 gauge and it was mounted on my steering column.
I have a 07 wrx.
I wired everything with fuse taps directly into my fuse box (located next to steering wheel)
I do have 1 loose white wire that I believe was run to the back of my stereo and will be checking that tommorow
* Registered users of the site do not see these ads.

Last edited by wrxnova1; 05-20-2008 at 09:29 PM.
wrxnova1 is offline   Reply With Quote
Old 05-20-2008, 10:42 PM   #2
Pick9811
Scooby Newbie
 
Member#: 175050
Join Date: Mar 2008
Chapter/Region: MWSOC
Location: Omaha, NE
Vehicle:
2006 Impreza WRX STi
White

Arrow

I am still very new to the Subaru so I can't speak with any certainty... but I had a similar problem with my Dodge Ram truck (the vehicle before my Subie), and I think the fuse that blew was actually under the hood. I would check all your fuse panels (I would actually pull the fuses to check them) before tearing the car apart looking for the problem. Of course, someone else that has a ton of Subaru specific knowledge can probably draw you a map of the entire electrical system and tell you exactly what the possibilities are.

Have fun,
Pick
Pick9811 is offline   Reply With Quote
Old 05-21-2008, 02:23 PM   #3
ThreeEleven
Scooby Specialist
 
Member#: 157894
Join Date: Aug 2007
Chapter/Region: MWSOC
Location: Saint Peters, MO
Vehicle:
2007 WRB WRX
EJ257

Default

if it is a fuse...it would be the one under the hood. When I had my gauges put it...my airbag light was on and my blinkers didn't work. A fuse was blown..
ThreeEleven is offline   Reply With Quote
Old 05-21-2008, 05:22 PM   #4
wrxnova1
Scooby Specialist
 
Member#: 112854
Join Date: Apr 2006
Chapter/Region: MAIC
Location: VA
Vehicle:
2004 STi
WRB

Default

Problem solved :

After using fuse taps the regular fuse wasnt going in far enough into the board SO I bent the tabs in different directions and it works.

The saying "throwin a hot dog down a hallway" applies here.
wrxnova1 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Do the 06-07 imprezza, wrx, and outback hatch all have the same trunk? hookedontronics Interior & Exterior Modification 5 10-13-2009 03:05 PM
What do a dolphin and a young boy have in common? Neek Off-Topic 4 06-11-2007 01:21 PM
What does Guy Pierce (Memento) and an ugly girl have in common? somebody else Off-Topic 9 08-13-2006 09:03 PM
airbag light is on and no cruise control wreckedWRX Service & Maintenance 3 01-24-2005 10:26 PM
What do the MRT cat and Chernobyl have in common? Julian Normally Aspirated Powertrain 2 09-23-2002 06:09 PM


All times are GMT -4. The time now is 09:22 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.