Welcome to the North American Subaru Impreza Owners Club Saturday February 28, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-27-2008, 09:23 PM   #1
justinh595
Scooby Newbie
 
Member#: 144052
Join Date: Mar 2007
Default Turn signals won't work! help

Hey this is the second day the turn signals/hazard lights will not work. i've only had time to check the fuse and it came up ok. anyone with some info on this it would be greatly appreciated. thanks guys. wont work in the cluster or outside the car if that helps u understand the situation.
* Registered users of the site do not see these ads.
justinh595 is offline   Reply With Quote
Old 05-28-2008, 03:24 AM   #2
tonecold
Scooby Newbie
 
Member#: 37476
Join Date: May 2003
Chapter/Region: BAIC
Location: Milpitas, CA
Vehicle:
MY02 WRX Stage 2
PSM (215whp/223wtq)

Default

I had a similar problem this past wkend.
Except only my turn signals wouldn't work.

After some searching on NASIOC, I discovered I needed the Hazard to be plugged in.

Once I did that, my turn signals functioned again.

I didn't have the hazard plugged in initially, because I am waiting for the Red Hazard to come in the mail.
tonecold is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP PLEASE!! turn signals wont work csmith335 Electrical & Lighting 6 06-10-2010 12:36 PM
Front turn signal won't work AlboWRX Electrical & Lighting 2 03-10-2010 11:17 AM
help! turning signals don't work d0gsoup Electrical & Lighting 4 05-01-2007 02:35 PM
2006 STI turn signals stop working! WTF? HELP PLEASE.... smac Electrical & Lighting 7 09-20-2006 11:34 AM
help...turn signal dont work disaster999 Newbies & FAQs 16 01-13-2006 07:30 PM


All times are GMT -4. The time now is 08:15 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.