Welcome to the North American Subaru Impreza Owners Club Friday July 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-29-2008, 01:52 PM   #1
kakarotoni
Scooby Specialist
 
Member#: 156240
Join Date: Aug 2007
Chapter/Region: Tri-State
Location: New york
Vehicle:
02 WRX
06 Impreza

Default Apexi Turbo Timer Problem, Broken?

I have an apexi turbo timer in my 02 wrx. I've had the WRX for a year and the turbo timer was working great until a month ago. There are times where when I start my car that the turbo time would not activate or light up. And times where it would activate and light up. I have notice it flickering and shutting off. And I notice when I start my car up it does not come on, but when I turn it off, it happens to come on out of no where?

My battery is running between 13-14 volts. Not sure if this will effect the turbo timer and cause it to malfunction. I don't think its a loose wire but its a possibility, I've never seen any turbo timers do this. I am also running a police radar from my cig lighter but I unplugged that to see if it was interfering with the turbo timer and it didn't change a thing.

If anyone has any ideas or suggestions please lemme know. And please dont suggest to buy another turbo timer, theres no reason why it should be broken.
* Registered users of the site do not see these ads.
kakarotoni is offline   Reply With Quote
Old 05-29-2008, 07:15 PM   #2
mikeis300
Scooby Newbie
 
Member#: 149526
Join Date: May 2007
Chapter/Region: NWIC
Location: portland metro area
Vehicle:
2002 aps dr65 hybrid
9.1x1 built block/heads

Default

check your leads, make sure the wires are soldered and secured properly. flickering means there is a loose connection
mikeis300 is offline   Reply With Quote
Old 05-31-2008, 12:38 AM   #3
NewShockerGuy
Scooby Specialist
 
Member#: 40736
Join Date: Jul 2003
Chapter/Region: MAIC
Location: Pittsburgh, PA / FairFax, VA
Vehicle:
2005 WRX STI
Aspen White

Arrow

Mine did the same thing... ended up being the BLACK box that comes with the turbo timer... Needless to say I just bought a new one for $70...

But yes I know what your talking about and mine did the same thing...

-Nigel
NewShockerGuy is offline   Reply With Quote
Old 05-31-2008, 03:11 AM   #4
SoCalBullet
Scooby Newbie
 
Member#: 100729
Join Date: Nov 2005
Chapter/Region: SCIC
Location: So Cal
Vehicle:
2007 STI
SWP

Default

I would first start with checking the ground. You may not have a good ground and that will definitely cause intermittent problems. Be sure you have a good ground connection and then check the +12V line for constant power.
SoCalBullet is offline   Reply With Quote
Old 05-01-2010, 06:46 PM   #5
kevster02wrx
Scooby Newbie
 
Member#: 245664
Join Date: May 2010
Location: kamloops, bc , Canada
Vehicle:
2002 Subaru WRX
Silver

Unhappy apexi turbo timer

hey, i also got an 02 wrx with an apexi turbo timer, and i was just wondering wether or not someone has experienced my problem. Sometimes my timer starts counting down right after i started it. and its been doing it alot more lately and its starting to become a reall pain in the ass. any ideas why it might start counting down everytime i start the car? also, my battery is getting drained, which i may think is from the black box the timer is connected too. i figure the relay in the box may be the issue. any ideas?
kevster02wrx is offline   Reply With Quote
Old 05-04-2010, 12:39 AM   #6
kakarotoni
Scooby Specialist
 
Member#: 156240
Join Date: Aug 2007
Chapter/Region: Tri-State
Location: New york
Vehicle:
02 WRX
06 Impreza

Default

^^^ Well I had similar problems like that but really right now the whole apexi turbo timer just comes on and shuts off when it pleases, there really isn't anything that can trigger it that I've noted. It's just pure random.
kakarotoni is offline   Reply With Quote
Old 05-27-2010, 02:33 PM   #7
240sxsexy
Scooby Newbie
 
Member#: 222487
Join Date: Sep 2009
Default

Mine randomly doesnt count down all the way when I turn the engine off... Whats strange though is if I turn the key to power the radio/ect (but dont start the engine) and then turn it off the turbo timer will count all the way down pefore killing power.

I checked to see if mine was a fake and its 100% legit.
240sxsexy is offline   Reply With Quote
Old 06-08-2010, 02:13 PM   #8
NewShockerGuy
Scooby Specialist
 
Member#: 40736
Join Date: Jul 2003
Chapter/Region: MAIC
Location: Pittsburgh, PA / FairFax, VA
Vehicle:
2005 WRX STI
Aspen White

Default

It's probably the black box...
My friend had the same issue and just like mine it was the black box or components inside.. I took it apwart and noticed that some of the PCB board was darker than usual and after flipping the underside out saw burnt traces...

-Nigel
NewShockerGuy is offline   Reply With Quote
Old 06-13-2010, 08:28 PM   #9
240sxsexy
Scooby Newbie
 
Member#: 222487
Join Date: Sep 2009
Default

I'll check it out. Thanks.
240sxsexy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
RS C/F guage pod, apexi RSM, Apexi turbo timer, and Expired sabelt harness scobaru Interior/Dressup/Audio & Security 8 06-23-2008 10:38 PM
FS: Apexi AVCR + Apexi Turbo Timer (2x) SlammedREX Engine/Power/Exhaust 16 09-17-2007 01:38 PM
RS C/F guage pod, apexi RSM, Apexi turbo timer, and Expired sabelt harness scobaru MWSOC Private Classifieds 10 04-13-2007 03:50 PM
Apexi Grounding Kit and Apexi Turbo Timer Flybert Engine/Power/Exhaust 0 09-24-2006 08:28 PM
Autometer Gauges, Apexi AVCR, Apexi Turbo Timer, a-pillar, etc.. zroom tsuchiya Private 'For Sale' Classifieds 37 04-06-2006 11:23 PM


All times are GMT -4. The time now is 12:41 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.