Welcome to the North American Subaru Impreza Owners Club Thursday October 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-31-2008, 09:28 AM   #1
PJAWRX03
Scooby Specialist
 
Member#: 47426
Join Date: Nov 2003
Location: Viera, FL
Vehicle:
2003 Impreza WRX
Black

Default HID kit

Hey guys I recently put an hid kit into my 2003 bugeye. Everything has been working great until the other day. My driver side headlight flicker and then turned back on. The next day I turned my headlights on and nothing, no light at all. My DRLs are disabled and my I am grounded to the battery.

Any help would be great?

Thanks
* Registered users of the site do not see these ads.
PJAWRX03 is offline   Reply With Quote
Old 05-31-2008, 10:14 AM   #2
StupidFastWagon
Scooby Specialist
 
Member#: 157526
Join Date: Aug 2007
Vehicle:
2014 335i xDrive
M Sport

Default

Which kit do you have and what is grounded to your battery?
StupidFastWagon is offline   Reply With Quote
Old 05-31-2008, 03:45 PM   #3
jdubya301
Scooby Specialist
 
Member#: 139076
Join Date: Jan 2007
Chapter/Region: MAIC
Location: Scranton PA
Vehicle:
2002 stg2 wagon
03 suzuki sv650s

Default

you need to use a relay harness. this issue come up very frequently if you were to search.
jdubya301 is offline   Reply With Quote
Old 05-31-2008, 10:03 PM   #4
PJAWRX03
Scooby Specialist
 
Member#: 47426
Join Date: Nov 2003
Location: Viera, FL
Vehicle:
2003 Impreza WRX
Black

Default

Ok I have a relay harness thanks did not need to search
I have it grounded to the battery oh and I have a apexcone from lightwerkz.com

Last edited by PJAWRX03; 05-31-2008 at 10:09 PM.
PJAWRX03 is offline   Reply With Quote
Old 06-01-2008, 06:34 PM   #5
PA-Outback2000
Scooby Specialist
 
Member#: 161832
Join Date: Oct 2007
Chapter/Region: Tri-State
Location: PA
Vehicle:
2000 Outback Limited
Black

Default

how long had u had the HID's in before they acted funny? i have the same kit and have had them in since november w/o issues and didn't use the relay harness.
PA-Outback2000 is offline   Reply With Quote
Old 06-01-2008, 09:16 PM   #6
jdubya301
Scooby Specialist
 
Member#: 139076
Join Date: Jan 2007
Chapter/Region: MAIC
Location: Scranton PA
Vehicle:
2002 stg2 wagon
03 suzuki sv650s

Default

Quote:
Originally Posted by PA-Outback2000 View Post
how long had u had the HID's in before they acted funny? i have the same kit and have had them in since november w/o issues and didn't use the relay harness.

consider yourself lucky you havent done any damage to anything. seriously.
jdubya301 is offline   Reply With Quote
Old 06-01-2008, 11:20 PM   #7
PJAWRX03
Scooby Specialist
 
Member#: 47426
Join Date: Nov 2003
Location: Viera, FL
Vehicle:
2003 Impreza WRX
Black

Default

I have had them since Jan 2008
PJAWRX03 is offline   Reply With Quote
Old 06-02-2008, 09:24 PM   #8
PJAWRX03
Scooby Specialist
 
Member#: 47426
Join Date: Nov 2003
Location: Viera, FL
Vehicle:
2003 Impreza WRX
Black

Default

it was my relay thanks for the help
PJAWRX03 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
In stock! Kaixen HID Kits - highest quality HID kits for NASIOC members. autodoodad.com Exterior/Styling 428 01-27-2009 07:01 AM
GB: Kaixen HID KITS, High quality HID kits with solid reputation autodoodad.com Vendor 'Group Buy' Classifieds 263 08-13-2008 08:02 AM
Kaixen HID Kits - Highest Quality HID Kits for NASIOC members. autodoodad.com MAIC Vendor Classifieds 1 07-02-2007 12:49 AM
GB: KAIXEN HID KITS for NASIOC members. High quality HID kits with solid reputation. autodoodad.com Vendor 'Group Buy' Classifieds 432 09-20-2006 11:25 PM
35watt HID kit vs 50watt HID kit jpsimon Electrical & Lighting 19 03-23-2006 09:58 AM


All times are GMT -4. The time now is 07:06 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.