Welcome to the North American Subaru Impreza Owners Club Friday April 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > UTEC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-06-2008, 08:44 PM   #1
xxlostxx
Scooby Newbie
 
Member#: 181190
Join Date: May 2008
Chapter/Region: Tri-State
Location: Long Beach
Vehicle:
2002 WRX
Blue

Default Need UTEC Delta manuals

Sup everyone

Long story short I just bought a bugeye a few days ago with an original utec and this guy had also bought a new utec delta, but when he gave it to me he didnt have the manuals at all so I have no clue how or where to connect it because he told me the delta goes behind the dash and not on top of the ecu. Also I dont have any user manual at all so I have no clue on how to program it and get my maps off the old utec to put on this new delta =(
I have searched everywhere and cant find a damn thing on it wither, I also went to turboXS's site and there no pdf or anything remotely useful to get me started. So does anyone have a link to the manual or and you email it to me? I can then post it on my FTP for others with this same issue.

thanx in advance =)
* Registered users of the site do not see these ads.
xxlostxx is offline   Reply With Quote
Old 06-07-2008, 01:30 AM   #2
Pick9811
Scooby Newbie
 
Member#: 175050
Join Date: Mar 2008
Chapter/Region: MWSOC
Location: Omaha, NE
Vehicle:
2006 Impreza WRX STi
White

Default

Ditto...
Same problem here. I am thinking about contacting TXS. If I get the manuals I will share. If someone gets them on here before I do, please do the same.
Pick
Pick9811 is offline   Reply With Quote
Old 06-07-2008, 02:16 AM   #3
Racer_X_X
Scooby Newbie
 
Member#: 141804
Join Date: Feb 2007
Chapter/Region: SCIC
Location: Orange
Vehicle:
'98 RSTi HTA86 AEM
'02 35R-Nürburgring Cert.

Default


Last edited by Racer_X_X; 06-07-2008 at 02:22 AM.
Racer_X_X is offline   Reply With Quote
Old 06-07-2008, 09:37 AM   #4
xxlostxx
Scooby Newbie
 
Member#: 181190
Join Date: May 2008
Chapter/Region: Tri-State
Location: Long Beach
Vehicle:
2002 WRX
Blue

Default

lmao where the hell did you find it on their site? I looked all over and found nothing =(
thanx for the link =)
xxlostxx is offline   Reply With Quote
Old 06-07-2008, 11:44 AM   #5
Pick9811
Scooby Newbie
 
Member#: 175050
Join Date: Mar 2008
Chapter/Region: MWSOC
Location: Omaha, NE
Vehicle:
2006 Impreza WRX STi
White

Default Same here

I looked everywhere, used their damned search function, everything. You are the man. Thanks Racer!

Also, XXlostxx... I really appreciate you putting this up, so thanks for your help too.

Pick
Pick9811 is offline   Reply With Quote
Old 06-07-2008, 12:37 PM   #6
xxlostxx
Scooby Newbie
 
Member#: 181190
Join Date: May 2008
Chapter/Region: Tri-State
Location: Long Beach
Vehicle:
2002 WRX
Blue

Default

=) now if only I can fix my damn electrical issue =(
xxlostxx is offline   Reply With Quote
Old 06-07-2008, 12:43 PM   #7
Pick9811
Scooby Newbie
 
Member#: 175050
Join Date: Mar 2008
Chapter/Region: MWSOC
Location: Omaha, NE
Vehicle:
2006 Impreza WRX STi
White

Question ????

What electrical issue are you having?
Pick9811 is offline   Reply With Quote
Old 06-07-2008, 12:46 PM   #8
xxlostxx
Scooby Newbie
 
Member#: 181190
Join Date: May 2008
Chapter/Region: Tri-State
Location: Long Beach
Vehicle:
2002 WRX
Blue

Default

Ill post the links to my threads but also follow the links to the other people having the same exact issue, only they didnt post a fix =( and Im goign crazy I have been up for 24 hours trying to pin point it...
http://forums.nasioc.com/forums/show...7#post22559587
I have a link in that thread to the first thread I started and I have also linked the other posts I found with people having the same issue.
and most 1/2 assed comments liek take it to a mechanic... at $95 an hour ill get right on that...
xxlostxx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS : Helix CBE, Utec Delta rmstires Engine/Power/Exhaust 1 06-05-2010 04:59 PM
Need Utec Delta connector layout explanation HOLLYW00D UTEC 4 06-11-2009 01:17 PM
Basic UTEC vs UTEC Delta Unlikely Hero Newbies & FAQs 3 04-25-2008 08:59 PM
UTEC or UTEC Delta : Drivability issues? jblaine UTEC 1 09-19-2007 03:52 AM
Please Help! Utec or UTEC DELTA? 904scooby Engine Management & Tuning 0 06-23-2007 11:08 AM


All times are GMT -4. The time now is 06:39 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.