Welcome to the North American Subaru Impreza Owners Club Sunday August 2, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-16-2008, 08:25 PM   #1
ReubenH
Scooby Specialist
 
Member#: 172522
Join Date: Feb 2008
Chapter/Region: International
Location: Queenstown, New Zealand
Vehicle:
1998 Legacy GTB Ltd.
Black

Default Keep blowing the foglight fuse

This is for a JDM 98 GTB Limited, it has 4 foglights (pic), and a switch to turn the fog lights on, and another to select between the big round ones, and the little projector ones. you can't have both on at once. The ones on the outside of the projector fog lights are turning lights, come on with the indicators (just FYI).

As the title says, i keep blowing the fuse for the foglights. It first happened when i went to put them on after getting back on the road from a rebuild, no luck... Tracked it down to a simple blown fuse, so put another one in. it worked for a while, but later blew that one too. I checked all the plugs, all was in order, then put a 20amp fuse in. It worked for about half an hour, then blew again... So no more replacing fuses, otherwise something is going to catch fire... any ideas what might be causing this? The little fog select switch's light has blown. Could that be it? only thing i can think of...
* Registered users of the site do not see these ads.
ReubenH is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help Perrin PW-1/Aquamist keeps blowing the 15A fuse sutter2k Water/Methanol Injection, Nitrous & Intercooler Cooling 1 06-06-2008 04:52 PM
keep blowing "clock room" fuse in my 02 bxracer69 Electrical & Lighting 1 02-20-2008 07:53 AM
Blowing the main fuse to ECU everytime I turn the key reddevil Electrical & Lighting 2 04-19-2007 09:26 PM
Keep blowing tail light fuse- HELP... MK19 Electrical & Lighting 9 06-23-2003 01:06 AM
I keep blowing my abs fuse DoorKnob Technical Forum Archive 1 06-28-2000 12:32 AM


All times are GMT -4. The time now is 06:40 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.