Welcome to the North American Subaru Impreza Owners Club Monday December 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 06-20-2008, 03:35 PM   #1
2K7WRX
Scooby Newbie
 
Member#: 141988
Join Date: Feb 2007
Chapter/Region: Tri-State
Vehicle:
2012 JKU Sahara
Bright White

Exclamation Stereo installed, no brake lights now...

I really could use some help ASAP. I'm not sure if these 2 things coincide to the same period of time, and if they do then I was driving my car without brake lights for about 2 weeks. I installed an AVIC D-3 in my 2007 WRX about 2 or 3 weeks ago. The other night I realized I have no brake lights. I tried jumping the brake light switch and get nothing, I obviously checked the fuse and tried another. Also new bulbs were tested and still nothing. I dont want to have to take this back to Subaru cause it wont be under warranty. Any help would be great, THANKS!!
* Registered users of the site do not see these ads.
2K7WRX is offline  
Old 06-20-2008, 05:29 PM   #2
Cougar4
Scooby Guru
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

I would first check to see if power is getting to the brake light switch using a test light probe. If that is ok then check the turn signal flasher to see if that is ok since the brake light circuit runs through it.

If you didn't check the fuses under the hood then you need to check those also.
Cougar4 is offline  
Old 06-21-2008, 02:45 PM   #3
2K7WRX
Scooby Newbie
 
Member#: 141988
Join Date: Feb 2007
Chapter/Region: Tri-State
Vehicle:
2012 JKU Sahara
Bright White

Default

so I have power at one of the pins on the plug that connects to the brake light switch and I have power at one of the pins on the connector to the flasher. I don't have power at the stop fuse on the panel inside the car, number 16 I believe. any advice?
2K7WRX is offline  
Old 06-21-2008, 04:41 PM   #4
Cougar4
Scooby Guru
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

If you have power at the switch then the lights should work if the switch is ok and the wiring to the lights is good. Not sure why you don't have power to fuse 16 unless the igniton is OFF or there is a blown fuse under the hood in the power panel.
Cougar4 is offline  
Old 06-21-2008, 04:56 PM   #5
2K7WRX
Scooby Newbie
 
Member#: 141988
Join Date: Feb 2007
Chapter/Region: Tri-State
Vehicle:
2012 JKU Sahara
Bright White

Default

I feel like such an idiot, one of the SBF's under the hood was blown. sorry for wasting your time!!
2K7WRX is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! No brake lights SilverBullet2.5RS Electrical & Lighting 2 08-03-2006 03:30 PM
No brake lights Reason01 Legacy Forum 14 05-12-2005 04:22 PM
No brake lights? flwrx Warranty Issues & SOA Problems 7 10-19-2004 04:17 PM
no brake light = illegal in Ga Y OR N? Blindeye_03 South East Region Forum 3 08-10-2001 09:57 PM
No brake light? adamsrs General Forum Archive 8 03-21-2001 01:18 AM


All times are GMT -4. The time now is 01:50 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.