Welcome to the North American Subaru Impreza Owners Club Saturday August 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-23-2008, 11:53 PM   #1
yakkosmurf
Scooby Newbie
 
Member#: 81931
Join Date: Feb 2005
Chapter/Region: TXIC
Location: League City, TX
Vehicle:
2008 STI (Stage 1)
WR Blue Mica w/ Gold BBS

Default 2008 STI w/ Nav and AP question

I'm looking at pulling the trigger on an '08 STI this week, and I've decided to get the NAV system. I've read that there is a travel computer feature built into the NAV system, and I'm wondering if reflashing the ECU to install an Accessport will prevent this nav system feature from working. Does anyone have experience with an '08 STI with the nav system and running Stage 1 or 2?

Thanks for any words of wisdom.
* Registered users of the site do not see these ads.
yakkosmurf is offline   Reply With Quote
Old 06-24-2008, 05:19 AM   #2
evan_impreza
Scooby Specialist
 
Member#: 115276
Join Date: May 2006
Chapter/Region: MWSOC
Location: Joplin, MO
Vehicle:
04 PSM WRX -sold:(
98 RS- WRX swap complete!

Default

My friends 08 sti with navigation works perfect after going stage 2
evan_impreza is offline   Reply With Quote
Old 06-24-2008, 09:55 AM   #3
yakkosmurf
Scooby Newbie
 
Member#: 81931
Join Date: Feb 2005
Chapter/Region: TXIC
Location: League City, TX
Vehicle:
2008 STI (Stage 1)
WR Blue Mica w/ Gold BBS

Default

Excellent. Thanks. Just one of those things I thought of that I couldn't confirm anywhere.
yakkosmurf is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS 2008+ STI OEM Nav/Headunit Rat^3 Interior/Dressup/Audio & Security 12 07-04-2010 09:52 AM
FS: IL Chicago 2008 STI BBS NAV vactor Private Vehicle 'For Sale' Classifieds 4 03-27-2010 10:11 AM
FS: IL Chicago 2008 STI BBS NAV vactor MWSOC Private Classifieds 5 02-04-2010 09:23 AM
2008 WRX STi - WRB, Nav and Gold BBS CaptainKebab Private Vehicle 'For Sale' Classifieds 2 04-05-2009 04:22 PM
2008 sti w/ nav-add a camera? bwanaaa Car Audio, Video & Security 1 03-20-2008 11:40 PM


All times are GMT -4. The time now is 06:40 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.