Welcome to the North American Subaru Impreza Owners Club Wednesday April 1, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-25-2008, 10:12 AM   #1
BBBsti LTD
Scooby Specialist
 
Member#: 71682
Join Date: Oct 2004
Chapter/Region: SCIC
Location: Socal with BORICUA blood...
Vehicle:
2007 WRX Sti LTD.
SWP

Default Subaru battery is dead after 2 weeks!!!

I hope this is the right forum since seems to be general to all Subarus.

I was not able to drive or warm up my car for 2 weeks and the battery is dead. The car is not even two years old. Are Subaru batteries weak???
* Registered users of the site do not see these ads.
BBBsti LTD is offline   Reply With Quote
Old 06-25-2008, 10:13 AM   #2
Turn in Concepts
NASIOC Vendor
 
Member#: 93646
Join Date: Aug 2005
Chapter/Region: MWSOC
Vehicle:
Many Track Records
Let us help you go fast!

Default

Quote:
Originally Posted by BBBsti LTD View Post
I hope this is the right forum since seems to be general to all Subarus.

I was not able to drive or warm up my car for 2 weeks and the battery is dead. The car is not even two years old. Are Subaru batteries weak???
They aren't great, but they aren't bad either. You've got something going on that's not right.
Turn in Concepts is offline   Reply With Quote
Old 06-25-2008, 10:20 AM   #3
vile
Scooby Specialist
 
Member#: 32371
Join Date: Jan 2003
Location: formerly known as mem. # 10615
Vehicle:
'02 t-rex wagon
platinum

Default

this is a common complaint among '02-'03 owners
vile is offline   Reply With Quote
Old 06-25-2008, 10:25 AM   #4
rkramer
Scooby Guru
 
Member#: 118209
Join Date: Jun 2006
Chapter/Region: MWSOC
Location: North Dakota
Vehicle:
2015 WRX Limitec

Default

has it ever been run completely flat before this? if you left the dome light on or something previously, that seriously hurts the capacity and life of a battery, so 2 weeks certainly isn't unusual then.
rkramer is offline   Reply With Quote
Old 06-25-2008, 10:25 AM   #5
rkramer
Scooby Guru
 
Member#: 118209
Join Date: Jun 2006
Chapter/Region: MWSOC
Location: North Dakota
Vehicle:
2015 WRX Limitec

Default

Quote:
Originally Posted by vile View Post
this is a common complaint among '02-'03 owners
(OP is a '07)
rkramer is offline   Reply With Quote
Old 06-25-2008, 11:17 AM   #6
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

any aftermarket accessories? alarm, remote start, etc?
munkis is offline   Reply With Quote
Old 06-25-2008, 11:20 AM   #7
Mavrik
Scooby Guru
 
Member#: 90347
Join Date: Jul 2005
Chapter/Region: AKIC
Location: Anchorage AK
Vehicle:
2013 BRZ & Imp 2.5RS
Yamaha FZ8

Default

2 weeks without a single start? I'd not be surprised if my battery was dead after two weeks of no activity what so ever. Your alarm and other electronics in the car have a draw which left alone long enough can drain a battery.
Mavrik is offline   Reply With Quote
Old 06-25-2008, 11:30 AM   #8
ronoverdrive
Scooby Newbie
 
Member#: 181743
Join Date: Jun 2008
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2008 Impreza 2.5i
dark M. Gray

Default

I would just replace the battery. Diehards and Optimum batteries are pretty good if you wanna keep to over the counter batteries that use the OEM connection. Some people I see switch out to tractor and wheel chair batteries to save on weight (like 25lbs).
ronoverdrive is offline   Reply With Quote
Old 06-25-2008, 01:51 PM   #9
ciper
Scooby Guru
 
Member#: 15543
Join Date: Feb 2002
Location: san francisco, ca
Vehicle:
90BJ Legacy LS ABS
AWD 946 Rio Red Jpn built

Default

Quote:
Originally Posted by BBBsti LTD View Post
Are Subaru batteries weak???
All the batteries from the Subaru battery factory suck...
ciper is offline   Reply With Quote
Old 06-25-2008, 01:54 PM   #10
BGPKR
Scooby Specialist
 
Member#: 41842
Join Date: Aug 2003
Chapter/Region: MAIC
Location: Morgantown, WV
Vehicle:
2006 LGT LTD 5SM
OBP

Default

Mine lasted for a little over 4 years...
BGPKR is offline   Reply With Quote
Old 06-25-2008, 02:51 PM   #11
BBBsti LTD
Scooby Specialist
 
Member#: 71682
Join Date: Oct 2004
Chapter/Region: SCIC
Location: Socal with BORICUA blood...
Vehicle:
2007 WRX Sti LTD.
SWP

Default

The car is stock, electronic wise.

I remember back in 2004, my friend left his accord park for around 3 months and when he came back the car fired up perfectly.

Also in 2006 i had a 2005 WRX that was like 1 yr and 6 months old. I had to travel for one month and the battery was dead when I tried to start it up.
BBBsti LTD is offline   Reply With Quote
Old 06-25-2008, 04:44 PM   #12
Cougar4
Scooby Guru
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

If the battery is in good shape and the car systems are working as they should then you should be able to park the car for at least 3 weeks without having a starting problem. I have parked my Outback for over a month with no problem. The problem you are having may be because the battery wasn't charged up fully to begin with. I recommend you charge the battery using a 10 amp battery charger and let it charge the battery for about 5 hours. Then see what happens. You could also have the charging system and battery tested to make sure everything is working like it should be.
Cougar4 is offline   Reply With Quote
Old 06-25-2008, 05:33 PM   #13
subaru3169
Scooby Guru
 
Member#: 55252
Join Date: Feb 2004
Chapter/Region: SCIC
Location: i know, i regret it too
Vehicle:
* pullup bar *

Default

wow.. mine lasted 6yrs before crapping out
subaru3169 is offline   Reply With Quote
Old 07-30-2008, 10:32 AM   #14
SubieRon
Scooby Guru
 
Member#: 64485
Join Date: Jun 2004
Chapter/Region: SCIC
Location: Full retard land
Vehicle:
2004 GGA

Default

mine lasted 5 years...time to get a new one
SubieRon is offline   Reply With Quote
Old 07-30-2008, 04:07 PM   #15
WC LATHE WERKS
NASIOC Vendor
 
Member#: 175549
Join Date: Mar 2008
Chapter/Region: Tri-State
Location: 2004 STi, 2006 C6
Vehicle:
Buy my SHIFTKNOBS
www.LatheWerks.com

Default

stock battery couldnt cold-start my car on its 3rd winter. I put in an ACDelco one with 550CCA and it worked great.
I went on vacation this month and the car sat for a full week. It was dead when i came home
After jumping it and driving 30 miles it is now charged and works fine. Maybe my clock and security system drained it over a week but I think theres a draw somewhere else
WC LATHE WERKS is offline   Reply With Quote
Old 07-30-2008, 04:41 PM   #16
dwmoss_68
Scooby Specialist
 
Member#: 6030
Join Date: Apr 2001
Chapter/Region: Tri-State
Location: Northeastern PA , USA
Vehicle:
04 Gold FXT
07 WRB FXT Sport

Default

My original battery lasted 5 years (122,000 miles) in northeastern PA.

Replaced with an optima red top, 2 years and 2 months ago (44,666 miles ago).

Just returned from a 2 week vacation, took the wife's 07 FXT. My old bugeye started up no problem after the two weeks.

dm
dwmoss_68 is offline   Reply With Quote
Old 07-30-2008, 09:23 PM   #17
racerx1/9
Scooby Newbie
 
Member#: 185660
Join Date: Jul 2008
Default

the OEM battery sucks big time!!
racerx1/9 is offline   Reply With Quote
Old 08-03-2008, 11:48 AM   #18
04ImprezaWRX
Scooby Specialist
 
Member#: 120237
Join Date: Jul 2006
Chapter/Region: Tri-State
Location: Livingston Manor NY
Vehicle:
2004 WRX
WRB

Default

Anyone have any reccomendations I need a new battery to handle my electrics i have an 04 wrx with 2 12 subs and 1000 watt amp, navigation, and defi gauges my lights like to flash alot. Thanks in advance
04ImprezaWRX is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
aloha ppls of the brutal OT my phone battery is dead so here I am shaggadelic Off-Topic 37 11-06-2008 04:31 PM
effin battery is dead... PhilDis Off-Topic 18 01-14-2008 11:45 PM
Whoops, factory battery is dead Imprezme05 South West Impreza Club Forum -- SWIC 13 12-18-2006 01:51 PM
Installed Grounding Kit, now battery is dead!! Trin_Starr Legacy Forum 11 05-09-2006 11:41 AM
Battery died after 2 weeks... pico Electrical & Lighting 16 01-10-2005 02:11 AM


All times are GMT -4. The time now is 01:26 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.