Welcome to the North American Subaru Impreza Owners Club Thursday July 10, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-02-2008, 02:10 AM   #1
White 2.5rs
Scooby Guru
 
Member#: 39936
Join Date: Jul 2003
Vehicle:
99RS TWE&SCAT EJ257
Hydra+HMist+PPG+35R=DEATH

Default Cruise control issues: 400 mile trip tomorrow!

1993 Legacy manual trans
150k miles
cruise control essentially stopped working all together about 2 years ago

Diaphram/spring/vac line is all good (checked it w/ my mouth)
put in pump/controller/relay out of a 90 legacy auto

cruise seems to stay on longer now... (by about 5 seconds) but the car bucks, surges, then the cruise turns off

what could be causing this?

ps no ABS

alex
* Registered users of the site do not see these ads.
White 2.5rs is offline   Reply With Quote
Old 07-02-2008, 02:52 AM   #2
ProdriveDreams
Scooby Specialist
 
Member#: 146819
Join Date: Apr 2007
Chapter/Region: NESIC
Location: Boston / Ipswich, MA
Vehicle:
'02 WRB VF-39'd WRX
W/06 STi Drivetrain swap

Default

Have you checked for resistance in the wires? or possibly a bad ground?

also I would borrow or otherwise obtain a hand operated vacuum pump to test the vac lines and diaphram.

It's hard to say without diagrams or the car in front of me what would cause such strange behavior.
ProdriveDreams is offline   Reply With Quote
Old 07-02-2008, 03:19 PM   #3
White 2.5rs
Scooby Guru
 
Member#: 39936
Join Date: Jul 2003
Vehicle:
99RS TWE&SCAT EJ257
Hydra+HMist+PPG+35R=DEATH

Default

the diaphram works fine
i dont know where the grounds are either...
White 2.5rs is offline   Reply With Quote
Old 07-02-2008, 11:17 PM   #4
avk
Scooby Specialist
 
Member#: 17252
Join Date: Apr 2002
Chapter/Region: Tri-State
Location: NJ
Vehicle:
'06 WX8
59E

Default

This is sometimes caused by a faulty or out-of-adjustment clutch switch.
Not sure a controller from an auto model would work right: it may require grounding
one wire as I (vaguely) recall.
avk is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise control not working, 6 hour trip tomorrow, please help badgerbugeye Electrical & Lighting 27 01-07-2010 06:20 PM
easiest way disconnecting cruise control cable from TB, cruise control removal 02-03 fastwrx25 Factory 2.0L Turbo Powertrain 4 09-21-2008 07:30 PM
UTEC: If the cruise light is flashing....cruise control doesn't work? bpwatts Engine Management & Tuning 4 07-10-2006 07:07 PM
Cruise Control Aint Cruising ahawks Service & Maintenance 0 10-21-2005 01:12 PM
Cruise actuator but no cruise control!! Improviser Normally Aspirated Powertrain 14 11-13-2002 04:48 PM


All times are GMT -4. The time now is 03:36 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.