Welcome to the North American Subaru Impreza Owners Club Sunday August 30, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-02-2008, 05:54 PM   #1
idrum2loud
Scooby Newbie
 
Member#: 182912
Join Date: Jun 2008
Chapter/Region: MAIC
Location: Portsmouth Va.
Vehicle:
05 WRX
Black

Default Weird noises when turning, popping noise HELP!

Ok so i just got an 05 wrx and i LOVE IT!

The car runs great and everything is great. One thing i have noticed recently is this. When i turn the car right, i hear a popping noise. Sometimes when i shut the car off, at the point where the engine shifts a little bit after you turn it off, i hear a rattle noise similar to the pop i hear when i turn right. Sometimes when driving slow over a lot of bumps and or dips in the street, i can hear the popping as well. The steering is tight, there are no suspension handling changes, and everything is fine at high speeds. I have been told it could be the spring not seating right, but i jacked up the passenger side of the car ( the side where the noise is) and everything seemed fine. Any help or ideas would be great! thanks guys!!!
* Registered users of the site do not see these ads.
idrum2loud is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-02-2008, 06:51 PM   #2
SlickRick51586
Scooby Newbie
 
Member#: 66735
Join Date: Jul 2004
Chapter/Region: South East
Location: Parkland, Florida.
Vehicle:
2004 WRX
PSM

Default

could be your spring moving around (or not moving) the strut during turns, the steering rack, or the axle.

because you hear the noise when you turn the car off is odd.... would make me think its the axle....

i'm not an expert /shrug take it some place and have um take a look.
SlickRick51586 is offline   Reply With Quote
Old 07-02-2008, 07:00 PM   #3
LuckyNYC
Scooby Newbie
 
Member#: 72812
Join Date: Oct 2004
Chapter/Region: Tri-State
Location: Queens, NY
Vehicle:
2013 Impreza Sport
Ventian Red Pearl

Default

Seems to be a very common problem (I'm find this out myself). I have the same issue. When I turn right I get the popping noise. I've given up and have had it in the shop for 3 days and they are thoroughly stumped so far. I don't get any noises when I shut off the engine though.
LuckyNYC is offline   Reply With Quote
Old 07-02-2008, 07:14 PM   #4
idrum2loud
Scooby Newbie
 
Member#: 182912
Join Date: Jun 2008
Chapter/Region: MAIC
Location: Portsmouth Va.
Vehicle:
05 WRX
Black

Default

I think its the vibration of the motor shaking like they do when there turned off that moves w/e it is just enough to make it rattle. I think its the Axle...cuz that would move with the motor since its all apart of the drivetrain etc. i would guess.
idrum2loud is offline   Reply With Quote
Old 07-02-2008, 09:44 PM   #5
RonJitsu
Scooby Specialist
 
Member#: 132301
Join Date: Nov 2006
Chapter/Region: Tri-State
Location: Central NJ
Vehicle:
07 WRX Limited 6MT
20G - SWP - SOLD

Default

idrum2loud - where are you located?
Fill out your profile.
RonJitsu is offline   Reply With Quote
Old 07-02-2008, 09:57 PM   #6
UkNuck
Scooby Guru
 
Member#: 21808
Join Date: Jul 2002
Chapter/Region: E. Canada
Location: National Capital Region
Vehicle:
02 GroceryGettAr
Nonemore Black

Default

is the suspension stock? if not what aftermarket parts
UkNuck is offline   Reply With Quote
Old 07-02-2008, 10:02 PM   #7
idrum2loud
Scooby Newbie
 
Member#: 182912
Join Date: Jun 2008
Chapter/Region: MAIC
Location: Portsmouth Va.
Vehicle:
05 WRX
Black

Default

Quote:
Originally Posted by UkNuck View Post
is the suspension stock? if not what aftermarket parts
Yes the car is all stock.
idrum2loud is offline   Reply With Quote
Old 07-03-2008, 07:35 PM   #8
IMjustWRXed
Scooby Newbie
 
Member#: 163254
Join Date: Nov 2007
Chapter/Region: TXIC
Location: Austin, Tx
Vehicle:
02 EVO'd WRX 16g
284 whp / MD Mustang

Default

i have the same exact prob...
seems like when turning really sharp,,, or when turning into inclined driveways ect.. that it makes this popping noise...
it also seems to have bad understeer,, much worse than my other wrx
i just got this 02 and my 03 never had these problems,,,
IMjustWRXed is offline   Reply With Quote
Old 07-03-2008, 07:57 PM   #9
seanvetter123
Scooby Specialist
 
Member#: 174476
Join Date: Mar 2008
Chapter/Region: NWIC
Location: B-ham, WA
Vehicle:
2002 Impreza RS
BRP

Default

dunno if this helps but awhile back i had my front swaybar endlink break. and every time i turned i had a popping sound. and the only way to see it was when the suspension was compressed. when the shop put it on the lift to try to find the problem the suspension unloaded and you couldn't tell what was broken.

good luck figuring it out.
seanvetter123 is offline   Reply With Quote
Old 07-04-2008, 12:06 PM   #10
pauli18c
Scooby Specialist
 
Member#: 174553
Join Date: Mar 2008
Chapter/Region: MWSOC
Location: Blackhawks Baby!!
Vehicle:
2005 STi 360whp
345wtq on 93oct @ 20psi

Default

try driving in a circle (to the right) does this popping happen the whole time you are driving in that circle? if so, id bet 90% that its ur axle CV joint
pauli18c is offline   Reply With Quote
Old 07-04-2008, 12:07 PM   #11
idrum2loud
Scooby Newbie
 
Member#: 182912
Join Date: Jun 2008
Chapter/Region: MAIC
Location: Portsmouth Va.
Vehicle:
05 WRX
Black

Default

Quote:
Originally Posted by pauli18c View Post
try driving in a circle (to the right) does this popping happen the whole time you are driving in that circle? if so, id bet 90% that its ur axle CV joint
No it isn't a continuous pop....just happens when the car shifts in the direction it does when turning sharply right...and when the motor shakes on startup or shut down.
idrum2loud is offline   Reply With Quote
Old 07-04-2008, 12:17 PM   #12
pauli18c
Scooby Specialist
 
Member#: 174553
Join Date: Mar 2008
Chapter/Region: MWSOC
Location: Blackhawks Baby!!
Vehicle:
2005 STi 360whp
345wtq on 93oct @ 20psi

Default

Quote:
Originally Posted by idrum2loud View Post
No it isn't a continuous pop....just happens when the car shifts in the direction it does when turning sharply right...and when the motor shakes on startup or shut down.
the turning sharply makes me want to say perhaps a ball joint (lower?), but that shouldnt have to do with when the car is starting/shutting down... that sounds more like a motor mount issue.

if you jack it up, did u pull the tire side to side (9 and 3 oclock positions) and also vertically (12 and 6 oclock positions) and hear nothing? you should be able to hear and see if the ball joint is loose. try having a friend pull on the tire while you inspect all the joints
pauli18c is offline   Reply With Quote
Old 07-06-2008, 03:58 PM   #13
idrum2loud
Scooby Newbie
 
Member#: 182912
Join Date: Jun 2008
Chapter/Region: MAIC
Location: Portsmouth Va.
Vehicle:
05 WRX
Black

Default

UPDATE!!!

Look at the difference in the sway bar end links....the crooked messed up looking on is on the passenger side..where the noise is coming from. Looks as if i need to replace that bad boy!

messed up side


Straight side
idrum2loud is offline   Reply With Quote
Old 07-07-2008, 12:42 AM   #14
pauli18c
Scooby Specialist
 
Member#: 174553
Join Date: Mar 2008
Chapter/Region: MWSOC
Location: Blackhawks Baby!!
Vehicle:
2005 STi 360whp
345wtq on 93oct @ 20psi

Default

i would recommend replacing both of those, it looks as if there is little or no grease at all left inside the rubber boots
pauli18c is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
popping noise when turning right jknakes Brakes, Steering & Suspension 1 07-12-2006 11:29 PM
Weird noise when turning Xtremeridher3 Transmission (AT/MT) & Driveline 3 05-10-2006 06:57 PM
Left front noise when turning hard right, help please! gtwagon941 Legacy Forum 21 01-10-2005 01:58 PM
JIC FLTA2 popping noise when turning wheel samwY Brakes, Steering & Suspension 1 05-27-2004 10:50 PM
flexing/popping noise when turning Moshpit552 Newbies & FAQs 1 11-06-2001 09:12 PM


All times are GMT -4. The time now is 04:42 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.