Welcome to the North American Subaru Impreza Owners Club Saturday July 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 07-16-2008, 02:43 AM   #1
StanDaMan
Scooby Newbie
 
Member#: 167108
Join Date: Dec 2007
Chapter/Region: Tri-State
Location: RoCkLand County, NY
Vehicle:
2007 WRX
SWP

Default Gauge cluster, Hvac, and Radio very dim??

So I start my car after work, turn on my lights and my gauge cluster, Hvac, and Radio lights are very very dim, but they are bright for a second when I turn on my lights, then get very dim. So i know the bulbs are still working, So did i blow a fuse?? if so which fuse would it be, and has anyone else had this problem???

Thanks guys
* Registered users of the site do not see these ads.
StanDaMan is offline  
Old 07-16-2008, 09:03 PM   #2
Cougar4
Scooby Specialist
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

I suggest you check the dimmer control for a bad connection. There may also be a bad power connection to the dimmer control module.
Cougar4 is offline  
Old 07-16-2008, 09:12 PM   #3
novacivic
Scooby Specialist
 
Member#: 117980
Join Date: Jun 2006
Chapter/Region: NESIC
Location: Rochester, NH
Vehicle:
2005 sti
wr blue

Default

yeah you need to turn the dimmer up a bit
novacivic is online now  
Old 07-17-2008, 11:30 AM   #4
StanDaMan
Scooby Newbie
 
Member#: 167108
Join Date: Dec 2007
Chapter/Region: Tri-State
Location: RoCkLand County, NY
Vehicle:
2007 WRX
SWP

Default

lol i feel so stupid, i had to turn the dimmer up, i think my dad touched it with out me knowing.

thanks guys
StanDaMan is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
A how to guide for changing the HVAC and radio to red mixup52 Electrical & Lighting 261 04-21-2014 10:24 AM
WTB: HVAC and radio surround/bezel bluestone Tri-State Area Private Classifieds 5 08-29-2009 11:18 PM
Gauge Cluster, Hvac, key ring bulb change help!! kevin85193 Interior & Exterior Modification 32 11-12-2008 07:51 PM
HVAC and Radio bulb change? unloadmydodads Electrical & Lighting 1 06-12-2004 10:04 PM
HVAC and Radio console WHITE LIGHT Argonaut Electrical & Lighting 6 04-21-2004 01:28 PM


All times are GMT -4. The time now is 11:24 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.