Welcome to the North American Subaru Impreza Owners Club Friday August 26, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 07-16-2008, 02:16 PM   #1
igoeasy
Scooby Newbie
 
Member#: 5690
Join Date: Apr 2001
Location: Let's go Big Blue !!
Vehicle:
02 WRB GDA
WRB

Default Blitz Oil Temp guage problem

I am having issues with my Blitz DC Temperature guage meter. Worked fine for a few years but suddenly now unable to wind up correctly during its startup/test mode. It only winds up once when it should wind up twice during this startup and makes a constant clicking sound.

Please see the video of this problem. ( on left ) http://video.google.com/videoplay?do...08462374229844 guage meter then winds up to other end after about 2 ½ minutes.

I have check the connections several times and tried difference mode settings on the guage. Blitz provided steps for calibrating but did not work in this case. Perhaps there’s a way to “reset” or reconfigure the DC Live unit or guage meter ?

Appreciate any suggestions
* Registered users of the site do not see these ads.
igoeasy is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with oil temp guage, needle goes crazy jaytone Electrical & Lighting 3 08-25-2009 11:53 AM
Blitz Boost and oil temp guages for sale snapperswrx Interior/Dressup/Audio & Security 4 08-19-2007 01:13 AM
Blitz BLM Boost, EGT, Oil temp guages NYC Supreme Private 'For Sale' Classifieds 9 07-11-2006 02:20 AM
Problems with Greddy Electronic Boost and Oil Temp Guages coyote73176 Electrical & Lighting 0 04-29-2004 08:14 AM

All times are GMT -4. The time now is 02:07 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.