Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
View Poll Results: How many items have you had serviced
No items in 36,000 miles 22 36.07%
One item in 36,000 miles 9 14.75%
Two items in 36,000 miles 4 6.56%
Three items in 36,000 miles 8 13.11%
Four items in 36,000 miles 1 1.64%
Five or more items in 36,000 miles 17 27.87%
Voters: 61. You may not vote on this poll

Reply
 
Thread Tools Display Modes
Old 03-06-2002, 04:57 PM   #1
Apisatrox
Scooby Newbie
 
Member#: 9523
Join Date: Aug 2001
Location: Olympia
Vehicle:
2005 WRX STi
Rally Ridge Blue

Question How many items have you had your Sub Serviced for?

In the standard period of 36,000 miles, how many items have you had repaired under warrenty?
* Registered users of the site do not see these ads.
Apisatrox is offline   Reply With Quote
Old 03-06-2002, 05:17 PM   #2
CosmoTheCat
Scooby Newbie
 
Member#: 3409
Join Date: Jan 2001
Chapter/Region: NWIC
Location: Woolley
Vehicle:
1998 Ram 2500
Green.

Default

My HVAC fan made a squeaking noise on the low settings. They replaced it, and it now makes a knocking noise. So far it's one item replaced for free... but it needs to be one item replaced twice.

On my '98 L I had the same squeak, but Kirkland Subaru told me it was leaves in the vent system () and they'd have to charge me to fix it. But they did flush the tranny/diff when the grease melted and ran out the splines onto the exhaust.

All in all... two cars, three "problems", 60k miles... not bad I'd say.
CosmoTheCat is offline   Reply With Quote
Old 03-06-2002, 05:19 PM   #3
Julian
Scooby Specialist
 
Member#: 1182
Join Date: Mar 2000
Location: Ventura, CA
Vehicle:
MY00 RS
BRP

Default

0 in ~26K miles. I had the O2 sensor recall, but that's the only time it has been into the dealer's service bay.
Julian is offline   Reply With Quote
Old 03-06-2002, 05:26 PM   #4
Apisatrox
Scooby Newbie
 
Member#: 9523
Join Date: Aug 2001
Location: Olympia
Vehicle:
2005 WRX STi
Rally Ridge Blue

Default

I just ask because in 26,000 miles I had:
Indicator light for fog lights (fuse), O2 Sensor, Trim on passenger and driver side door not put on properly (window was catching on anti-theft peice), when car was cold RPMS @ 3000.. way too high - fixed, power locks stopped working..


just wonder what i have instore for me for the next 10k miles.. glad I got the 0 decutable 100,000 warrent right now
Apisatrox is offline   Reply With Quote
Old 03-06-2002, 07:49 PM   #5
GRWRX
Scooby Specialist
 
Member#: 4129
Join Date: Feb 2001
Location: Suffolk County
Vehicle:
2002 WRX sedan
Blue

Default

They replaced the seat cover after my massive butt wore through the material.
GRWRX is offline   Reply With Quote
Old 03-06-2002, 10:07 PM   #6
Subie Gal
GC84Ever
Super Moderator
 
Member#: 301
Join Date: Sep 1999
Chapter/Region: NWIC
Location: WA
Vehicle:
1970 FF-1 & '70 Van
02 WRX/01 RS

Default

my 2001 RS has had:
inner axle seal gone bad
new clutch
new wiper blades
fix squeak/loose spring near firewall
CE light which was a bad coil (#3)

i think that's it... in one year... 32k miles...

hey, no car is perfect!!!

Jamie
www.subiegal.com
Subie Gal is offline   Reply With Quote
Old 03-07-2002, 01:49 AM   #7
dannyboy7
Scooby Newbie
 
Member#: 5432
Join Date: Apr 2001
Chapter/Region: NWIC
Location: Way Out in the Frikkin Boonies
Vehicle:
2006 Spec Beezie

Default

Had the WRX for almost one year, and just took it in to have the "performance gauge pack" replace cause the turbo gauge isnt calibrated and the volt gauge sticks. 27000 miles.
dannyboy7 is offline   Reply With Quote
Old 03-12-2002, 01:54 PM   #8
Apisatrox
Scooby Newbie
 
Member#: 9523
Join Date: Aug 2001
Location: Olympia
Vehicle:
2005 WRX STi
Rally Ridge Blue

Default

Only 21 votes?

We can do better than that
Apisatrox is offline   Reply With Quote
Old 03-15-2002, 08:31 AM   #9
rlarose
Scooby Newbie
 
Member#: 7550
Join Date: Jun 2001
Location: Derry, NH
Vehicle:
2002 WRX Sedan
was PS, is now WRB

Default

Here is a run-down from my spread-sheet I keep in my 8,000 miles of car ownership:

Problem Days @ Suabru Mileage
Purchase 0 148
Rear Differential 7 150
O2 Sensor 1 2301
Transmission 30 7214
Clutch Problem 0 7321
Clutch Problem 0 7380
Clutch Problem 0 7412
Clutch Problem 6 7650
Clutch Attempt 1 8 8000
Clutch Attempt 2 6 8016

Everything has been deemed "defective" and replaced under warranty. They are in the process of replacing my car or refunding my money now.

UPDATE: After 54 down days, getting my old car back. BUT, Subaru is looking to replace it with a spanking new one.

Last edited by rlarose; 03-20-2002 at 02:55 PM.
rlarose is offline   Reply With Quote
Old 03-15-2002, 09:25 AM   #10
gtguy
Scooby Guru
 
Member#: 2184
Join Date: Aug 2000
Location: Highland Park, Ill., USA
Vehicle:
2005 Legacy GT wagon
Platinum Silver Metallic

Default

1) that weird flap rattle in the wagon
2) an ECU reflash to rectify the false code glitch

The end. I might suggest that the low number of responses means that (horrors!) these cars are actually reliable.

Kevin
gtguy is offline   Reply With Quote
Old 03-20-2002, 02:49 PM   #11
Apisatrox
Scooby Newbie
 
Member#: 9523
Join Date: Aug 2001
Location: Olympia
Vehicle:
2005 WRX STi
Rally Ridge Blue

Default

^
Apisatrox is offline   Reply With Quote
Old 03-20-2002, 04:56 PM   #12
WRXDude
Scooby Newbie
 
Member#: 3576
Join Date: Jan 2001
Chapter/Region: TXIC
Location: South Texas, Ya'll!
Vehicle:
2012 GTI

Default

Let me see-
4 visits before 300 miles - CE lights. The cause? A hose had fallen off (it was too short), causing a false PO457. Guess who finally fixed it - me!
1 visit to ECU reflash due to false CE's (not related to above)
1 visit to fix glovebox door broken by the dealer
1 visit to finally fix the glovebox door broken by the dealer

7 Visits in 10k miles. Groan. But the last 5k have been trouble-free, so lets hope that the earlier issues were out of the ordinary.
WRXDude is offline   Reply With Quote
Old 03-20-2002, 07:19 PM   #13
gertman
Scooby Newbie
 
Member#: 16530
Join Date: Mar 2002
Vehicle:
2004 WRX STI
WR Blue

Default

I have an 02 WRX with 2,300 miles. I have been to the dealer once, but it was only a SMALL problem:

Fresh from the factory to my greedy little hands the light for the rear license plate was not working.

Has anyone else had this problem? Has anyone thought to check? Anyway, it only took took the friendly Subaru 3hrs to fix it.......but hey I got a free wash!!!

The culprit, a loose connector fixed under warrenty!!!
gertman is offline   Reply With Quote
Old 03-20-2002, 07:36 PM   #14
Gumpy
Scooby Newbie
 
Member#: 15722
Join Date: Feb 2002
Location: Mount Joy, Pennsylvania
Vehicle:
2003 EVO
Silver

Default Number of items replaced

Items fixed or replaced in 11,000 miles

Door and trunk latch adjustments

2Check engine lights for cylinder 1 and 3 misfires

CPU re-flashed

2 visits to dealer for drivetrain deceleration noise.

Dealer currently working on replacing drivetrain components, after I showed them some i-club members fixes.
Gumpy is offline   Reply With Quote
Old 03-20-2002, 09:07 PM   #15
kaboom
Scooby Specialist
 
Member#: 6160
Join Date: Apr 2001
Location: Houston
Vehicle:
2009 Legacy
Gray

Default

1. air conditioner
2. check engine light
3. brakes
kaboom is offline   Reply With Quote
Old 03-21-2002, 08:15 AM   #16
jamz
Scooby Guru
 
Member#: 8725
Join Date: Jul 2001
Chapter/Region: NESIC
Location: Portland MAINE
Vehicle:
2013 Black Company
Annalist

Default

Nothing until this morning, when most of my power steering fluid gushed out onto the ground for some reason. :-/

I have the decel noise, but it is pretty faint, not sure if I'm going to have them look at it. I'd want to take the kartboy out before doing that.
jamz is offline   Reply With Quote
Old 03-22-2002, 01:15 PM   #17
Apisatrox
Scooby Newbie
 
Member#: 9523
Join Date: Aug 2001
Location: Olympia
Vehicle:
2005 WRX STi
Rally Ridge Blue

Default

Does the 26% for 5+ times in 36,000 miles seem REALLY high to anyone else?
Apisatrox is offline   Reply With Quote
Old 03-22-2002, 11:27 PM   #18
armand1
Scooby Guru
 
Member#: 10309
Join Date: Sep 2001
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
'02 OBS 2-tone!
'95 Montego Miata

Default

Quote:
Does the 26% for 5+ times in 36,000 miles seem REALLY high to anyone else?
No, because this is light-years away from being at all a random and scientifically valid survey.
armand1 is offline   Reply With Quote
Old 03-31-2002, 01:46 AM   #19
IMPREZive 02 WRX
Scooby Specialist
 
Member#: 11436
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NJ
Vehicle:
1999 Impreza RS
eBay racing edition!

Default

5 in 8,700 miles
IMPREZive 02 WRX is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How many times have you had sex with no form of contraceptive? Christoff Off-Topic 67 09-22-2007 10:18 AM
Have you had your H6 upgrade for a while? If so how has the rotor held up? Drew888 Brakes, Steering & Suspension 7 04-04-2005 06:37 PM
How many "partners" have you had? incorporeal Off-Topic 176 08-19-2004 02:00 AM
Women: how many orgasms have you had in a row? Orson Off-Topic 4 10-16-2003 09:45 AM
Poll- How many nails have YOU had in your tires? fuzzbox General Forum Archive 21 10-20-2000 08:54 AM


All times are GMT -4. The time now is 04:48 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.