Welcome to the North American Subaru Impreza Owners Club Wednesday April 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Built Motor Discussion

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-19-2008, 12:43 AM   #1
bigmike25rs
Scooby Newbie
 
Member#: 83924
Join Date: Mar 2005
Chapter/Region: MWSOC
Location: Avon Lake, OH
Vehicle:
2005 HTA 86 STi
10.66 @ 136 mph

Default XD-1 Still available?

I'll put this here because most of us with built motors are running widebands.. I'm running the Innovate LC1/LM1 with the XD1 digital gauge.. Well, the gauge just flat out quit working.. I tested the wires and everything's hot.. It's just acting like it isn't turned on.. I figured the gauge must be fried.. Now, I can't seem to find a replacement.. Anyone know if you can still get these? The only one I can find is the XD16 (16 in 1 deal) and it's like $220.. I don't need all that, just the AFR readout like I had before..
* Registered users of the site do not see these ads.
bigmike25rs is offline   Reply With Quote
Old 07-19-2008, 02:50 AM   #2
ec2k1gt
Scooby Specialist
 
Member#: 129631
Join Date: Oct 2006
Chapter/Region: MWSOC
Location: Plainfield, IL
Vehicle:
06 Obp Sti
back to slow lolz

Default

Send it in to innovate, same thing happend to my XD-16 and they repaired it free of charge. Just call them up and explain your situation.

-Vic
ec2k1gt is offline   Reply With Quote
Old 07-19-2008, 11:08 AM   #3
bigmike25rs
Scooby Newbie
 
Member#: 83924
Join Date: Mar 2005
Chapter/Region: MWSOC
Location: Avon Lake, OH
Vehicle:
2005 HTA 86 STi
10.66 @ 136 mph

Default

Cool.. Thanks alot!!
bigmike25rs is offline   Reply With Quote
Old 07-19-2008, 02:45 PM   #4
Storm
Scooby Guru
 
Member#: 5218
Join Date: Mar 2001
Chapter/Region: MWSOC
Location: SAUL'S Motorsports
Vehicle:
96L Most Over-
Developed Beater

Default

I haven't used the XD1 gauge, but I did pick up a wideband gauge from egauges.com. You can get yourself a backup, in case it happens again.

Jay
Storm is offline   Reply With Quote
Old 07-21-2008, 11:12 PM   #5
bigmike25rs
Scooby Newbie
 
Member#: 83924
Join Date: Mar 2005
Chapter/Region: MWSOC
Location: Avon Lake, OH
Vehicle:
2005 HTA 86 STi
10.66 @ 136 mph

Default

Well, couldn't get ahold of Innovate by phone, but they did respond to my email.. Looks like they will take the gauge back.. No mention of cost or being free, but this is a good start.. Anyone know what gauges are compatable with the LM1 setup? Will other brands just plug in? Looks like a standard 1/8" male plug..

Last edited by bigmike25rs; 07-22-2008 at 10:50 AM.
bigmike25rs is offline   Reply With Quote
Old 07-22-2008, 10:13 AM   #6
bluescoobywagon
Scooby Specialist
 
Member#: 14911
Join Date: Feb 2002
Chapter/Region: MWSOC
Location: The land of E85
Vehicle:
Not A Wagon!
2011 WRX - 285s on 18x10s

Default

Any gauge should work with the programmable output.
bluescoobywagon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
STi competition parts still available for BC Legacys Shik Legacy Forum 3 02-25-2002 02:01 PM
(OT) -- AC still available (and other stuff too) Necromancer Bay Area Impreza Club Forum -- BAIC 6 07-26-2001 02:29 AM
Any first Allocation WRX's still availible at dealers? Kostamojen Bay Area Impreza Club Forum -- BAIC 7 02-26-2001 09:03 AM
Is the Rimmer S/C still available? If so, where? >>> KaZ General Forum Archive 4 02-19-2001 08:14 PM


All times are GMT -4. The time now is 07:46 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.