Welcome to the North American Subaru Impreza Owners Club Thursday March 26, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-21-2008, 01:49 PM   #1
sxcobraz249
Scooby Newbie
 
Member#: 123770
Join Date: Aug 2006
Chapter/Region: Tri-State
Location: NY
Vehicle:
2006 WRX
WRB

Default Headlights no work!?!?!?....

I have had an H.I.D kit in my car for the last two years yesterday I went to turn on my headlights and they wont go on Everything else works my highbeams, city lights etc except my regular headlights what could it be. Because i know most of the symptoms to a bad ballast but that never happend and that wouldnt make both not turn on any help would be awesome...

p.s. could it be a relay and how could i find out??
* Registered users of the site do not see these ads.
sxcobraz249 is offline   Reply With Quote
Old 07-22-2008, 04:22 PM   #2
iFwrx
Scooby Newbie
 
Member#: 180249
Join Date: May 2008
Chapter/Region: Tri-State
Location: Bergen County, NJ
Vehicle:
00 GC8
BRP

Default

i have the same exact problem with my hids.. but only my right headlight doesn't work in low beams.. did u figure out what was wrong?
iFwrx is offline   Reply With Quote
Old 07-22-2008, 05:34 PM   #3
skingfreak
Scooby Specialist
 
Member#: 152591
Join Date: Jun 2007
Chapter/Region: MWSOC
Location: Wisconsin
Vehicle:
2010 Jetta TDI Cup
Jet Black

Default

Quote:
Originally Posted by sxcobraz249 View Post
I have had an H.I.D kit in my car for the last two years yesterday I went to turn on my headlights and they wont go on Everything else works my highbeams, city lights etc except my regular headlights what could it be. Because i know most of the symptoms to a bad ballast but that never happend and that wouldnt make both not turn on any help would be awesome...

p.s. could it be a relay and how could i find out??
Did you check the fuse in your wire harness? and to check the relay you could take a positive wire directly from the battery to the positive on the ballast..(do at your own risk)
skingfreak is offline   Reply With Quote
Old 07-23-2008, 12:22 PM   #4
crasyboy412
Scooby Specialist
 
Member#: 70840
Join Date: Sep 2004
Chapter/Region: South East
Location: Fayetteville, NC
Vehicle:
2008 Subaru WRX STi
Aspen White

Default

1. Check fuse
2. Check HID buld with another car
3. Check Ballast, it could that there water in there somehow, if it does,
them just bake it in the oven, and shake dry.

*3, was what happen to my HID, it work great now,
but I also order a 55K 5000K hid kit from lightwerkz,
hahahah

but good luck on your.




T
crasyboy412 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
02 wrx driver side headlight dont work,only works on high beam>>help! password:ej20 Electrical & Lighting 10 08-07-2008 02:33 PM
headlights no worky slickrex Electrical & Lighting 10 12-05-2006 06:21 PM
left turn signal no work when headlights are on Chuck the swimmer Electrical & Lighting 1 07-05-2006 09:19 AM
No days off left and no work to do makes Cole something something Cole Off-Topic 7 12-29-2005 07:05 PM
I have officially done no work at work today... RATyson Off-Topic 17 05-20-2004 09:23 PM


All times are GMT -4. The time now is 07:15 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.