Welcome to the North American Subaru Impreza Owners Club Monday September 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
New England Subaru Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > New England Impreza Club Forum -- NESIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-01-2001, 08:28 AM   #1
jjameson
Scooby Specialist
 
Member#: 4986
Join Date: Mar 2001
Chapter/Region: NESIC
Location: Back frm Ireland Fallbrook, Ca
Vehicle:
2002 BlzYel JDMSTiv7
GRP 08 FXT

Post Blitz Dual TT questions?

I posted some of these questions in my post in the Turbo forum but I havn't gotten many good answers. I was hoping some of you local guru's could help. I don't think its working right even though its brand new.

I installed my Blitz dual TT in my WRX last weekend. I tapped into a boost line (you can see the pictures in the Turbo forum post) and I don't think I tapped the right place because I am only seeing 0.7 Kg/cm2 of boost max (10psi) when I think I should be seeing 14psi max for the WRX.

The other thing is I have been watching the automitic timer add time to the idle set. It seems to add time once the car starts moving no matter how I am driving and max out at 5min. Any ride longer than 5 min sets the timer to 5 min. It doesnt seem to matter how hard i am driving the car. If I sit at a stop light the timer continues to add time. I thought the auto feature of the blitz determines how hard the car has been driven and sets the timer appropriately. All the timer is doing now is any ride I take of 5 min long it sets it to 5min? So I have just been using the manual feature but that defeats the point of purchsing the Dual TT.

Anyone have insight, how does your Blitz dual TT work for you?

* Registered users of the site do not see these ads.
jjameson is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Blitz dual TT with keyless entry? YaZahX General Community 12 07-07-2005 03:12 PM
Blitz Dual TT question jacklock Factory 2.0L Turbo Powertrain 3 11-08-2001 09:21 AM
Help...mouting that damn Blitz Dual TT w/ boost gauge!!! Jimmy S. Factory 2.0L Turbo Powertrain 6 11-02-2001 01:21 AM
Blitz Dual TT install questions WRX Power Factory 2.0L Turbo Powertrain 5 07-06-2001 06:34 PM
Blitz Dual TT or MSTT? dug-e-fresh Factory 2.0L Turbo Powertrain 2 05-22-2001 11:49 AM


All times are GMT -4. The time now is 08:54 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.