Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-10-2008, 01:51 PM   #1
islandboy78
Scooby Specialist
 
Member#: 96163
Join Date: Sep 2005
Location: IN
Vehicle:
2009 IMPREZA
WRB

Default Help White Smoke

Ok so the car sits for a week, I start it up very light white colored smoke appears from the exhaust and then as the car idles and coming out of the muffler looks like blackish water, I am thinking it's condensation and couple shops think it is and as far as the smoke it clears when the car is warmed up. What could be the problem and what shall I do. I just rebuilt the engine.

My second problem is Ok here is the situation I rebuilt my engine, after the engine built the car will idle and run sluggish when i clear the mis fire codes P301, 302, 303, 304 misfire detected code, but the minute the codes come back the car is running back to normal. I broke in the car at 1500 miles and got a conservative tune. After the break in process i bought new spark plug but just used the gap that it came with. I am running a blow through set-up with tgv deletes. I am using the okada boots with the stock coil pack. The radiator has like a powder looking on the cap, will be doing a flush soon. Any help or advice will help.

Mods below:
Utec EM
Okada Boot
TBE
Fp Green
turbxs FMIC

All in all with the check engine lights on and the car warmed up, she runs like a champ. Some guidance and advice would help....
* Registered users of the site do not see these ads.
islandboy78 is offline   Reply With Quote
Old 08-10-2008, 05:25 PM   #2
islandboy78
Scooby Specialist
 
Member#: 96163
Join Date: Sep 2005
Location: IN
Vehicle:
2009 IMPREZA
WRB

Default

Did compression testing all compression numbers came out fine...
islandboy78 is offline   Reply With Quote
Old 08-10-2008, 05:46 PM   #3
jigga
Scooby Guru
 
Member#: 9960
Join Date: Sep 2001
Location: in bed...
Vehicle:
2002 Impreza WRX
WRBlue Perl

Default

Have you tried using stock coil packs in case the okada units are not working as they should?
jigga is offline   Reply With Quote
Old 08-10-2008, 05:48 PM   #4
islandboy78
Scooby Specialist
 
Member#: 96163
Join Date: Sep 2005
Location: IN
Vehicle:
2009 IMPREZA
WRB

Default

Quote:
Originally Posted by jigga View Post
Have you tried using stock coil packs in case the okada units are not working as they should?
doing that as we speak. Thanks for the advice...
islandboy78 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! White smoke still coming from exhaust. ChronicPoe Service & Maintenance 8 05-15-2009 12:28 PM
HELP! white smoke shemp321 Built Motor Discussion 9 02-19-2009 01:07 PM
help! white smoke!! please! RIRENTER Factory 2.5L Turbo Powertrain 2 05-31-2006 01:37 PM
Help!!! White smoke after resinstallation of stock injectors calib17a Factory 2.5L Turbo Powertrain 3 10-24-2005 02:54 AM
HELP! White Smoke Problem...Experts needed blkwag Normally Aspirated Powertrain 7 08-30-2002 02:57 AM


All times are GMT -4. The time now is 05:43 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.