Welcome to the North American Subaru Impreza Owners Club Tuesday June 2, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Tire & Wheel Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Tire & Wheel

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-19-2008, 03:15 PM   #1
subRman
Scooby Newbie
 
Member#: 118931
Join Date: Jun 2006
Chapter/Region: SCIC
Location: Glendale, CA
Vehicle:
2006 sti
silver

Default Hub bore question...

I recently purchased some wheels from a vendor on this forum and I was given a wheel with a different center bore. 3 of the wheels have a center bore of 73.1 and one is 56.1 (<--should fit perfectly on my 06 STI). The vendor provided me with 3 hub rings to size it down to 56.1 . My question is, Should I run the wheels like this or should I request that all the wheels be the same center bore? I would like to know what you guys would do in my situation? In the past I have always used wheels that fit to the "T" on my vehicles and this is the first time I have encountered this. Are any of you running wheels with different hub bores? and if so, Have you had any issues?
* Registered users of the site do not see these ads.
subRman is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 09-19-2008, 03:29 PM   #2
waktasz
Scooby Guru
 
Member#: 86356
Join Date: May 2005
Chapter/Region: Tri-State
Default

Won't make a lick of difference.

I've run larger hub bores and no rings and that didn't matter either.

If you are worried, get aluminum rings for the 3 that aren't right instead of plastic ones.
waktasz is offline   Reply With Quote
Old 09-19-2008, 03:42 PM   #3
subRman
Scooby Newbie
 
Member#: 118931
Join Date: Jun 2006
Chapter/Region: SCIC
Location: Glendale, CA
Vehicle:
2006 sti
silver

Default

I am glad to hear that. I did get the plastic and will look for the aluminum. I guess I can contact Tire Rack for the rings..
subRman is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hub bore for a 2002 WRX? Siclike7 Newbies & FAQs 1 04-24-2009 12:56 PM
Advan RZ Hub/bore size?? JM530 Tire & Wheel 0 03-26-2009 09:03 PM
Rusty centre hub/bore skittle Vancouver Impreza Club Forum -- VIC 1 08-14-2007 06:59 AM
06 WRX hub bore turbo_h4 Tire & Wheel 2 03-04-2007 10:18 PM
trying to find 05 sti hub bore size deisolsl Tire & Wheel 1 09-15-2004 09:15 AM


All times are GMT -4. The time now is 06:19 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.