Welcome to the North American Subaru Impreza Owners Club Thursday July 10, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-21-2008, 11:09 AM   #1
hitadeercivic
Scooby Newbie
 
Member#: 179842
Join Date: May 2008
Default 05, with 07 motor with immobilizer problem.

I just had ECS do my harness for my 05 wrx with a 07 wrx motor swap. When i got the motor i unfortunately did not recieve the immobilizer and keys. The dealership by my house had no problem with reprogramming them for me as a legal issue. The problem is when they load the program to talk to the ECU it will not accept the security code. They called tech line and he said i also need the guage cluster, true or false? what i think im going to end up doing is sending everything straight to Subaru and have then sync everything as one for me. If this will not work whats the best and easiest plug and play stand alone i can buy?
* Registered users of the site do not see these ads.
hitadeercivic is offline   Reply With Quote
Old 09-21-2008, 08:59 PM   #2
breathinez
Scooby Specialist
 
Member#: 79859
Join Date: Jan 2005
Chapter/Region: South East
Location: Greensboro, N.C.
Vehicle:
2002 06 STi lb, meth
3" 8cm Green Hydra

Default

I was told the gauge cluster was not needed. I have an 06 sti LB going into my 02 aqnd I will be running the 02 cluster for now.
breathinez is offline   Reply With Quote
Old 09-22-2008, 02:23 PM   #3
camaroz1985
Scooby Newbie
 
Member#: 155906
Join Date: Aug 2007
Chapter/Region: MAIC
Location: Bressler, PA
Vehicle:
1998 Impreza 2.5RS
Rally Blue

Default

Gauge cluster is not needed. I have 07 WRX in my 98RS.
camaroz1985 is offline   Reply With Quote
Old 09-22-2008, 03:06 PM   #4
bebesito21
Scooby Specialist
 
Member#: 176128
Join Date: Mar 2008
Chapter/Region: South East
Location: I <3 E85
Vehicle:
5862 ...baby boosted

Default

did you use the entire 07 motor or just the long block?
bebesito21 is offline   Reply With Quote
Old 09-22-2008, 04:04 PM   #5
camaroz1985
Scooby Newbie
 
Member#: 155906
Join Date: Aug 2007
Chapter/Region: MAIC
Location: Bressler, PA
Vehicle:
1998 Impreza 2.5RS
Rally Blue

Default

Entire motor
camaroz1985 is offline   Reply With Quote
Old 09-22-2008, 04:47 PM   #6
bebesito21
Scooby Specialist
 
Member#: 176128
Join Date: Mar 2008
Chapter/Region: South East
Location: I <3 E85
Vehicle:
5862 ...baby boosted

Default

then you might need all the parts they are telling you.....alternatively, you can strip it down to a long block and put all of your 05 stuff on it and use your wiring harness and ecu...then you'll need a tune
bebesito21 is offline   Reply With Quote
Old 09-23-2008, 08:56 AM   #7
camaroz1985
Scooby Newbie
 
Member#: 155906
Join Date: Aug 2007
Chapter/Region: MAIC
Location: Bressler, PA
Vehicle:
1998 Impreza 2.5RS
Rally Blue

Default

I assure you I didn't use the intrument cluster. You do need the key and the ecu matching. The immobilizer antenna can be from anything, as well as the module. It just reads it does not have anything encoded.
camaroz1985 is offline   Reply With Quote
Old 09-23-2008, 10:05 AM   #8
bebesito21
Scooby Specialist
 
Member#: 176128
Join Date: Mar 2008
Chapter/Region: South East
Location: I <3 E85
Vehicle:
5862 ...baby boosted

Default

oh wait, i was asking hitadeercivic if he used the entire motor
bebesito21 is offline   Reply With Quote
Old 09-23-2008, 11:39 AM   #9
camaroz1985
Scooby Newbie
 
Member#: 155906
Join Date: Aug 2007
Chapter/Region: MAIC
Location: Bressler, PA
Vehicle:
1998 Impreza 2.5RS
Rally Blue

Default

haha i just realized that too. I thought you were the OP until I looked back up. Sorry disregard my comment.
camaroz1985 is offline   Reply With Quote
Old 09-23-2008, 11:46 AM   #10
bebesito21
Scooby Specialist
 
Member#: 176128
Join Date: Mar 2008
Chapter/Region: South East
Location: I <3 E85
Vehicle:
5862 ...baby boosted

Default

yeah my mistake too...lol no worries
bebesito21 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
05 USDM STI Motor with full wiring harness and ECU mpj_becks Engine/Power/Exhaust 2 12-30-2008 03:05 PM
05 wrx with 07 motor swap problems.? hitadeercivic Subaru Conversions 3 09-06-2008 02:52 AM
Anyone with 07 UGM with 06 tails? Urban07STI Interior & Exterior Modification 9 10-12-2007 08:31 AM
Immobilizer problems? STirocket Car Audio, Video & Security 0 06-03-2005 11:44 PM
Immobilizer problem Please HELP! imprezaboi Electrical & Lighting 2 06-20-2004 12:32 PM


All times are GMT -4. The time now is 09:19 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.