Welcome to the North American Subaru Impreza Owners Club Friday August 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Vancouver Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Vancouver Impreza Club Forum -- VIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-16-2002, 04:18 PM   #1
pro2cer604
Scooby Newbie
 
Member#: 6191
Join Date: Apr 2001
Location: Abbotsford
Vehicle:
2002 wrx
Aspen

Default Air Filter and Check Engine Light

I've got a Blitz Air Filter, and every couple of months it would turn on my Check Engine light for some strange reason...

The dealership is telling me that its the Air filter and I should change it back to the original.....

Anybody with an aftermarket airfilter have this problem? anyway around it?
* Registered users of the site do not see these ads.
pro2cer604 is offline   Reply With Quote
Old 03-16-2002, 05:28 PM   #2
Orbiter
Scooby Specialist
 
Member#: 66
Join Date: Jul 1999
Location: Vancouver, British Columbia, C
Vehicle:
2002 Impreza WRX
Britney Edition

Cool

Everyone I know with the blitz intake has the same problem =|
Orbiter is offline   Reply With Quote
Old 03-16-2002, 05:41 PM   #3
Keiho
Sea to Sky - OWNED
Moderator
 
Member#: 610
Join Date: Dec 1999
Chapter/Region: VIC
Location: Vancouver, BC, Canada
Vehicle:
2003 Lexus IS300
Graphite Gray Pearl

Default

I don't.
Keiho is offline   Reply With Quote
Old 03-16-2002, 08:54 PM   #4
Necromancer
Scooby Specialist
 
Member#: 477
Join Date: Oct 1999
Location: Vancouver
Vehicle:
GC4 -> GGA -> GM6
Yeah, that's about right.

Default

probably too much turbulence around the MAF
(it is mounted just above the filter after all) ... damn cost-saving...

what code did it throw?
Necromancer is offline   Reply With Quote
Old 03-17-2002, 01:00 AM   #5
pro2cer604
Scooby Newbie
 
Member#: 6191
Join Date: Apr 2001
Location: Abbotsford
Vehicle:
2002 wrx
Aspen

Default

anybody with an Injen intake with this problem?


PS. Blitz intake for sale! $150
pro2cer604 is offline   Reply With Quote
Old 03-17-2002, 05:51 AM   #6
PrinceWRX
Scooby Newbie
 
Member#: 9463
Join Date: Aug 2001
Location: Vancouver B.C Canada
Vehicle:
02 Impreza WRX
white (SOLD)

Default

same here.......but i dont find it annoying anymore....
PrinceWRX is offline   Reply With Quote
Old 03-17-2002, 06:00 PM   #7
fukamoto
Scooby Guru
 
Member#: 13339
Join Date: Dec 2001
Chapter/Region: Tri-State
Location: Albany, NY
Vehicle:
2014 SWP WRX Wagon
White

Default

Quote:
Originally posted by pro2cer604
anybody with an Injen intake with this problem?


PS. Blitz intake for sale! $150
Your selling your intake just because of the CEL? Or are you just selling it b/c of ditchmond popo?

Derek
fukamoto is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
injector connectors and check engine light Barticus Electrical & Lighting 1 08-19-2004 12:18 PM
Cruise Control and Check Engine Light.. i need help!! PhatAsiankid03 Electrical & Lighting 9 04-02-2004 03:07 PM
Engine Hesitation and Check Engine Light Bricoleur Outback Forum 2 03-22-2004 08:09 AM
Need help turbo now sputers and check engine light is on! AWJunkies Normally Aspirated with bolt-on Forced Induction Powertrain 2 07-18-2003 01:21 AM


All times are GMT -4. The time now is 08:36 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.