Welcome to the North American Subaru Impreza Owners Club Thursday November 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-24-2008, 12:59 PM   #1
thugzlife
Scooby Newbie
 
Member#: 167895
Join Date: Dec 2007
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2005 Impreza 2.5 RS
Silver

Default 2005 2.5rs - Floor the gas and Car stops responding

So Iíve been having a problem recently where if i floor the gas pedal in certain situations the car will stop responding until restarted.
  • Iíll be lightly tapping the gas going around 35 mph
  • I then decide to push the gas pedal completely down.
  • The engine rev doesn't rev the car up in response to me flooring the gas, as soon as the pedal is floored the check engine and cruise control light will blink. The engine immediate starts to idle higher in every gear except neutral.
  • The car is put in some sort of mode where no matter how hard I push the gas down it moves one speed, but just barley (10 mph at tops). And the rev will never go high.
  • Once I restart the car everything is fine except the check engine light which doesn't go away for a few days.
* Registered users of the site do not see these ads.
thugzlife is offline   Reply With Quote
Old 09-24-2008, 01:15 PM   #2
fastenova
Scooby Specialist
 
Member#: 38829
Join Date: Jun 2003
Chapter/Region: NWIC
Location: Tigard, OR
Vehicle:
Not your usual 1997
Legacy GT

Default

It sounds like "limp mode" is being activated. This prevents the car from revving over a certain RPM and limits fuel delivery. I think it's a failsafe for if the ECU isn't getting readings from certain sensors (or they have failed).

But I thought it was closer to ~30MPH that people had found was the maximum speed...
fastenova is offline   Reply With Quote
Old 09-24-2008, 01:28 PM   #3
thugzlife
Scooby Newbie
 
Member#: 167895
Join Date: Dec 2007
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2005 Impreza 2.5 RS
Silver

Default

Yea my speedo was broken at the time it was prob 25 or 30
thugzlife is offline   Reply With Quote
Old 09-24-2008, 02:54 PM   #4
sniper1rfa
Scooby Specialist
 
Member#: 141040
Join Date: Feb 2007
Chapter/Region: NESIC
Location: Designing things
Vehicle:
07 2.5i wagon
UGM

Default

My guess is that your TPS or pedal sensor is reading high when you floor it, throwing a code and activating limp mode.

There are a couple redundancies that make up a "health check" for your DBW system. If the system stops responding correctly, it will go into limp mode to prevent the car from running away to WOT.


EDIT: have somebody pull the code, it will tell you which sensor is acting weird.


EDIT again: Actually, if the engine doesn't respond BEFORE the CEL gets thrown, it could be the throttle plate sticking, also. Regardless, pull the code.
sniper1rfa is offline   Reply With Quote
Old 09-24-2008, 05:25 PM   #5
Gr3en
Scooby Specialist
 
Member#: 160991
Join Date: Oct 2007
Chapter/Region: MWSOC
Location: Gorillaoffroadcompany.com
Vehicle:
05 Corn Burner
Dirt Silver?

Default

Do you have the snorkus delete done to your car?
Gr3en is offline   Reply With Quote
Old 09-24-2008, 07:30 PM   #6
thugzlife
Scooby Newbie
 
Member#: 167895
Join Date: Dec 2007
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2005 Impreza 2.5 RS
Silver

Default

^^No, everything is completly stock.


Also forgot to add That I can floor the gas in other situations. I first thought it was the intake problem with the MAF sensor, but it has happened too many times.
thugzlife is offline   Reply With Quote
Old 09-25-2008, 01:54 AM   #7
williaty
Scooby Guru
 
Member#: 71092
Join Date: Sep 2004
Chapter/Region: MWSOC
Location: Delaware County, Ohio
Vehicle:
2005 2.5RS Wagon
Regal Blue Pearl

Default

Read the CEL. All this is just pissing in the wind until you get the code read.
williaty is offline   Reply With Quote
Old 09-29-2008, 03:53 PM   #8
thugzlife
Scooby Newbie
 
Member#: 167895
Join Date: Dec 2007
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2005 Impreza 2.5 RS
Silver

Default

I got the codes p2123, p2128 and p2123 pb, p2128 pb

Last edited by thugzlife; 09-29-2008 at 04:04 PM.
thugzlife is offline   Reply With Quote
Old 09-29-2008, 03:56 PM   #9
williaty
Scooby Guru
 
Member#: 71092
Join Date: Sep 2004
Chapter/Region: MWSOC
Location: Delaware County, Ohio
Vehicle:
2005 2.5RS Wagon
Regal Blue Pearl

Default

Your DBW system is pissed the frak off. Specifically, it's bitching about the pedal position sensor. However, it doesn't always bitch about what's actually wrong. Could be the pedal position sensor, could be the place position sensor, could be the plate actuator, could be the wiring. Honestly, something that complex and safety-critical should just be taken to an SAE certified mechanic with experience with Subaru DBW.
williaty is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone have a 2.5rs? Hows the gas mileage? Touge86 General Community 15 04-16-2008 06:00 PM
2.5RS Floor Mats and seat covers Andursun0013 Private 'For Sale' Classifieds 3 06-20-2006 12:42 PM
2005 2.5RS, Do they make headers for this car? ImprezaRS05 Normally Aspirated Powertrain 27 02-14-2006 01:07 PM
Does the Apex'i cat-back from a GC body fit the 2005 2.5RS? awdlifestyles Vancouver Impreza Club Forum -- VIC 6 09-26-2005 11:03 PM
Well, my 2005 2.5RS is wrecked and in the shop... (details inside) 3DF General Community 81 02-24-2005 03:35 AM


All times are GMT -4. The time now is 01:33 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.