Welcome to the North American Subaru Impreza Owners Club Thursday April 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-08-2008, 09:56 AM   #1
SubaruShortie05
Scooby Newbie
 
Member#: 189650
Join Date: Sep 2008
Location: CT
Vehicle:
2005 2.5RS
CGM

Default I need advice! Dropped my car off at Colonial this morning...

and i don't know what is wrong with it!!

ok, sorry to make this so long but i need advice! (hope i am posting in the right area)

i'm starting to worry, the car is an 05 with 58,xxx miles. the day i got it the horn was broken (everytime you turned the wheel to take a sharp turn it would go off REALLY LOUD). At first i thought i hit the horn by accident and then when it happened a few more times i realized that wasn't the case. I guess i shoud of test drivin it more but wtv's. My dad knows the guy at the dealership who sold it to us and i just kinda had the attitude of "okay lets just buy it" lol. So i take it home and i went to back into my driveway and it popped out of reverse (granted i was giving it a bit of gas but nothing too to crazy). i asked a friend about it and they said thy heard subarus have wierd a 1st and reverse because there is no sychros or wtv. so in turn i just ignored that issue too. (stupid me)...THEN i start to notice a when the rpm's get to 2.5k-3k in 1st-3rd the engine gets a wierd rev to it (almost like ticking and louder then normal i guess) so then i shift and in between shifts i get a metallicy sound that stops when i put it into the next gear. almost like metal rubbing (not a grinding sound or anything tho).
I don't know maybe it's just something small and it's normal for subarus cause of the tough engines or maybe someone really beat on the car. Maybe i am just used to my SI and its a much smoother ride. Don't get me wrong I LOVE THIS CAR and have always wanted one, i am just not familiar with them and want to ask you pro's lol

Sorry to bother you guys but i really don't know much and i dont want to get screwed by the dealership before my used car warrenty is up. Anyone have any experience with this? Any advice is much appreciated. Thanks in advance!

OH and also!!! it's missing a few screws on the drivers side where the plastic molding or wtv meets the drivers side door frame. like WTF!
* Registered users of the site do not see these ads.
SubaruShortie05 is offline   Reply With Quote
Old 10-08-2008, 10:47 AM   #2
Kean
Scooby Guru
 
Member#: 25187
Join Date: Sep 2002
Location: So. CA
Vehicle:
'08 Foz Prem TGM
'10 Challenger R/T Blk

Default

....personally, I would take it to a trusted Subaru mechanic for an inspection. They will know what pieces are missing, what's been tampered with, which sounds are normal/abnormal, etc. Check the regional forums and ask fellow members for a reputable shop/mechanic in your area. Who knows.... perhaps one of the locals who respond will also be a certified Subaru tech willing to help you out.
Kean is offline   Reply With Quote
Old 10-08-2008, 10:57 AM   #3
SubaruShortie05
Scooby Newbie
 
Member#: 189650
Join Date: Sep 2008
Location: CT
Vehicle:
2005 2.5RS
CGM

Default

i posted this up in the 8thgen civic website and got this responce...do you guys agree?

"Ouch man, sounds like the previous owner thrashed the hell out of it.

Are there any signs under the hood that the car has been modified and returned to stock? Exhaust looks newer than it should, airbox looks like it's been re installed, wires not in their stock place, wheels, radio, etc? All areas someone would commonly modify and return to stock upon trade in.

If screws are missing on the door panel it sounds to me like the previous owner took it apart to get aftermarket speakers out of it then 1/2 assed it back togeather.

The trans should NOT be popping out of gear. Most cars don't have a synchro on reverse, that won't make it pop out, just grind going in if you are still moving.

The Horn is going off because the contact reel or whatever you call it behind the steering wheel is damaged, possibly from someone putting an aftermerket steering wheel on it, but who knows.

How long have you had it? This thing really sounds like someone abused the f*ck out of it. I'd bring it back and demand that it be repaired or bought back. I would not keep that thing if it where me, if it was indeed thrashed it's going to be nothing but trouble.

Good luck, hope my assumptions are wrong and it's just a few quirks.

Oh and FYI, buying from a "friend" at a dealership is usually not a good idea. Friends don't do buisness well, if you go in with problems they usually give you that "oh man, you're killing me, I thought we where better friends than that????" attitude. I've known a few people (including my mother) that got absolutely f*cked buying from friends. My Mothers "friend" sold her a BEATER 03 Altima in 06 and it was nothing but trouble, someone treated that thing like ***** and her "friend" ignored her issues every time it was brought back. "
SubaruShortie05 is offline   Reply With Quote
Old 10-08-2008, 11:03 AM   #4
2fas4u
Scooby Specialist
 
Member#: 90691
Join Date: Jul 2005
Chapter/Region: MAIC
Location: Manchester, Maryland
Vehicle:
2005 STI / 2009 STI
Blue

Default

I agree with what was said. Sounds like the steering wheel is grounding itself out when you turn that hard and that is setting the horn off. Definately was played with for some reason. Tranny should not pop out of any gear while you are sitting there....
2fas4u is offline   Reply With Quote
Old 10-08-2008, 11:10 AM   #5
Kean
Scooby Guru
 
Member#: 25187
Join Date: Sep 2002
Location: So. CA
Vehicle:
'08 Foz Prem TGM
'10 Challenger R/T Blk

Default

Quote:
Originally Posted by SubaruShortie05 View Post
i posted this up in the 8thgen civic website and got this responce...do you guys agree?
....makes sense but do you know what to look for? As I mentioned earlier, you'll still need someone with experience to examine/diagnose the car for you. ....something you can't do properly through a forum.
Kean is offline   Reply With Quote
Old 10-08-2008, 11:17 AM   #6
SubaruShortie05
Scooby Newbie
 
Member#: 189650
Join Date: Sep 2008
Location: CT
Vehicle:
2005 2.5RS
CGM

Default

Quote:
Originally Posted by Kean View Post
....makes sense but do you know what to look for? As I mentioned earlier, you'll still need someone with experience to examine/diagnose the car for you. ....something you can't do properly through a forum.
yeah, i agree...im am going to look into getting someone to REALLY take a look at it. thanks for the response
SubaruShortie05 is offline   Reply With Quote
Old 10-08-2008, 11:32 AM   #7
Kean
Scooby Guru
 
Member#: 25187
Join Date: Sep 2002
Location: So. CA
Vehicle:
'08 Foz Prem TGM
'10 Challenger R/T Blk

Default

...good luck.
Kean is offline   Reply With Quote
Old 10-08-2008, 11:37 AM   #8
SubaruShortie05
Scooby Newbie
 
Member#: 189650
Join Date: Sep 2008
Location: CT
Vehicle:
2005 2.5RS
CGM

Default

Quote:
Originally Posted by Kean View Post
...good luck.

thank you very much, i think i am going to need it
SubaruShortie05 is offline   Reply With Quote
Old 10-08-2008, 12:01 PM   #9
MasterKwan
Scooby Guru
 
Member#: 98961
Join Date: Oct 2005
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2003 WRX
Black

Default

Did you carfax the car?

What the chance it might have been in a wreck? When they put the airbags back in they didn't replace the clickspring/wire spool which sometimes melts when the airbags deploy. If the horn comes on when turning the wheel, you have an exposed wire somewhere that's grounding out when you turn the wheel.

Popping out of reverse suggests you need transmission work too.
MasterKwan is offline   Reply With Quote
Old 10-08-2008, 12:28 PM   #10
SubaruShortie05
Scooby Newbie
 
Member#: 189650
Join Date: Sep 2008
Location: CT
Vehicle:
2005 2.5RS
CGM

Default

--------------------------------------------------------------------------------

i just got off the phone with subaru...the guy i spoke with said that reverse popping out sounds like a transmission problem (Duh!) and that the metaliccy noise was probably a loose shield or something. They told me to bring the car there on monday and that they need it for a few days to take the transmission out and whatnot. Do you guys think they will fix it and things will be okay?
SubaruShortie05 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Finally, just dropped my car off @ Car Medics!! Foo_Blyat Mid West Subaru Owners Club Forum -- MWSOC 21 01-11-2006 04:28 PM
So I just dropped my car off at Norwood Subaru for clutch judder TSB SiOrange New England Impreza Club Forum -- NESIC 10 06-23-2004 04:48 PM
So I just got from dropping my sister off at the airport (Forester XT test drive) rhdude Mid Atlantic Impreza Club -- MAIC 3 05-27-2004 12:34 PM
Dropped my car off for a windshield xtheviperx New England Impreza Club Forum -- NESIC 11 03-22-2003 12:28 AM
Dropped my car off today AaronB South West Impreza Club Forum -- SWIC 10 01-10-2001 02:19 AM


All times are GMT -4. The time now is 10:02 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.