Welcome to the North American Subaru Impreza Owners Club Wednesday July 29, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-26-2015, 01:23 AM   #1
n00b on demand
Scooby Newbie
 
Member#: 158355
Join Date: Sep 2007
Chapter/Region: Tri-State
Location: White Plains NY
Vehicle:
2012 Sport 5MT
DGM

Default Oil pressure light faintly on?! Help!!

So as I was driving home tonight I noticed the oil pressure red light was very faintly on in the dashboard. It wasn't fully on and bright but it was very very faint. Enough to notice it. I am very concerned...this is just 500 miles after I last checked the oil to make sure it was fully. I didn't get a low oil level warning light or anything else. Why would the light be on so faintly? If something was wrong wouldn't it be fully lit? It's too dark to check the oil level...I will have to check in the morning.
* Registered users of the site do not see these ads.
n00b on demand is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-26-2015, 01:44 AM   #2
Commander Keen
Scooby Specialist
 
Member#: 319157
Join Date: May 2012
Chapter/Region: MAIC
Vehicle:
2012 Impreza 4DR 5MT

Default

Does the faint illumination go away when you rev the engine?

What about on a cold start?
Commander Keen is offline   Reply With Quote
Old 07-26-2015, 01:45 AM   #3
CosmoTheCat
Scooby Newbie
 
Member#: 3409
Join Date: Jan 2001
Chapter/Region: NWIC
Location: Woolley
Vehicle:
1998 Ram 2500
Green.

Default

Check for chewed wires? Sounds like a possible short.
CosmoTheCat is offline   Reply With Quote
Old 07-26-2015, 06:56 AM   #4
n00b on demand
Scooby Newbie
 
Member#: 158355
Join Date: Sep 2007
Chapter/Region: Tri-State
Location: White Plains NY
Vehicle:
2012 Sport 5MT
DGM

Default

Quote:
Originally Posted by Commander Keen View Post
Does the faint illumination go away when you rev the engine?

What about on a cold start?

If i turn the engine off and let it sit for a few mins and then start it again it stays off but then comes back on after a min. Light doesn't change brightness with revving. It's very dimly lit. Doesn't go off with headlight switch either in off position. I'm gonna run out to check the oil level.
n00b on demand is offline   Reply With Quote
Old 07-26-2015, 07:41 AM   #5
n00b on demand
Scooby Newbie
 
Member#: 158355
Join Date: Sep 2007
Chapter/Region: Tri-State
Location: White Plains NY
Vehicle:
2012 Sport 5MT
DGM

Default

Ok so I checked the oil level and it is still full. Turned the car on and there were no lights on in the dash this time. Took it out for a 15 min drive and nothing happened. I have to go out for a 2 hr drive in a bit. We will see what happens.
n00b on demand is offline   Reply With Quote
Old 07-26-2015, 09:15 AM   #6
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Sounds like a wiring problem and not a mechanical one. Idiot lights are either on or off, there is no in between
flyboy1100 is online now   Reply With Quote
Old 07-26-2015, 09:49 AM   #7
n00b on demand
Scooby Newbie
 
Member#: 158355
Join Date: Sep 2007
Chapter/Region: Tri-State
Location: White Plains NY
Vehicle:
2012 Sport 5MT
DGM

Default

Yeah I know! That's why it was so weird. Thankfully everything is ok....for now. Lol
n00b on demand is offline   Reply With Quote
Old 07-26-2015, 10:01 AM   #8
drpoop
Scooby Newbie
 
Member#: 421858
Join Date: May 2015
Default

Well, it could be that it's supposed to be lit up, but a short is taking some of the voltage away and making it dim... so no, it's not OK until you fix it and know whether the light is supposed to be on or not.
drpoop is offline   Reply With Quote
Old 07-26-2015, 01:10 PM   #9
n00b on demand
Scooby Newbie
 
Member#: 158355
Join Date: Sep 2007
Chapter/Region: Tri-State
Location: White Plains NY
Vehicle:
2012 Sport 5MT
DGM

Default

I just took a two hour drive with absolutely no issues. No warning lights or engine issues.
n00b on demand is offline   Reply With Quote
Old 07-26-2015, 09:25 PM   #10
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

Quote:
Originally Posted by drpoop View Post
Well, it could be that it's supposed to be lit up, but a short is taking some of the voltage away and making it dim... so no, it's not OK until you fix it and know whether the light is supposed to be on or not.
He checked his oil level and knows the crankcase is full. Isn't that enough evidence that the oil level light should not be lit?
sgoldste01 is offline   Reply With Quote
Old 07-27-2015, 04:40 PM   #11
n00b on demand
Scooby Newbie
 
Member#: 158355
Join Date: Sep 2007
Chapter/Region: Tri-State
Location: White Plains NY
Vehicle:
2012 Sport 5MT
DGM

Default

The light came back on last night after driving for a little while. It was even more dim than the last time. Not sure how to explain this to subaru since it doesn't happen all the time.
n00b on demand is offline   Reply With Quote
Old 07-27-2015, 04:40 PM   #12
n00b on demand
Scooby Newbie
 
Member#: 158355
Join Date: Sep 2007
Chapter/Region: Tri-State
Location: White Plains NY
Vehicle:
2012 Sport 5MT
DGM

Default

Of course it had to be the most vital warning light in the dashboard LOL
n00b on demand is offline   Reply With Quote
Old 07-27-2015, 11:24 PM   #13
Tha Chakal
Scooby Specialist
 
Member#: 372100
Join Date: Oct 2013
Location: D.C.
Vehicle:
2013 Premium 5dr CVT
DGM

Default

Quote:
Originally Posted by sgoldste01 View Post
He checked his oil level and knows the crankcase is full. Isn't that enough evidence that the oil level light should not be lit?
He said it was the oil pressure light. If it's THAT idiot light malfunctioning, I'd be spooked too!

Noob, I'd get it to the dealer or mechanic ASAP, especially if it's under warranty (5yr/60k).
Tha Chakal is online now   Reply With Quote
Old Yesterday, 08:25 AM   #14
n00b on demand
Scooby Newbie
 
Member#: 158355
Join Date: Sep 2007
Chapter/Region: Tri-State
Location: White Plains NY
Vehicle:
2012 Sport 5MT
DGM

Default

Quote:
Originally Posted by Tha Chakal View Post
He said it was the oil pressure light. If it's THAT idiot light malfunctioning, I'd be spooked too!

Noob, I'd get it to the dealer or mechanic ASAP, especially if it's under warranty (5yr/60k).
The issue only happens when the headlights are turned on. The warning light is so dim you can barely notice it. The car drives perfectly fine and the oil is still at the full mark. I'm not worried about it but will get it to the dealer next week when i am going to be back in town.
n00b on demand is offline   Reply With Quote
Old Yesterday, 08:26 AM   #15
n00b on demand
Scooby Newbie
 
Member#: 158355
Join Date: Sep 2007
Chapter/Region: Tri-State
Location: White Plains NY
Vehicle:
2012 Sport 5MT
DGM

Default

Any good ways to explain this to them? I would hate to bring it there and have it not happen and then come back home with no fix.
n00b on demand is offline   Reply With Quote
Old Yesterday, 10:05 AM   #16
Tha Chakal
Scooby Specialist
 
Member#: 372100
Join Date: Oct 2013
Location: D.C.
Vehicle:
2013 Premium 5dr CVT
DGM

Default

Well, I'd tell them what you are witnessing and at least have them check the oil pressure and make sure the light isn't supposed to be on. You can always check the wiring later if that is the problem.
Tha Chakal is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:55 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.