Welcome to the North American Subaru Impreza Owners Club Tuesday September 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-13-2008, 12:16 AM   #1
traffic80
Scooby Newbie
 
Member#: 159337
Join Date: Sep 2007
Chapter/Region: Tri-State
Vehicle:
02 wrx /2.5 swap
silver

Default bugeye 2.5 swap Misfires

Ok , out of the blue today while going for a cruise my Car popped CEL . It was not flashing so I carfully drove it home . I got misfires in all clyders . I reset it , and it seemed to stay off . Just a bit ago I went to store and the popped on again . I drove it 3 short trips prior . It seems like its driving ok just a little hesitation stutter at idle. It also does not seem to have as much power as it usaly does.

Im still running a base map Im waiting for my finaly tune. We just swapped a 06 engine into my bug eye Heads and all . Plugs are same that were in engine becase I did not change them yet and car only had 20k on it.

My mod are , Perrin lighweight Crank pulley , ACT Street clutch , ACT lightwieght flywheel 13.9 lbs , Injen CAI , Perrin Turbo inlet , Sti TMIC , Blouch 16g , Deathwerks 650cc injectors , TBE , Uppipe , Megan headers , Walboro 255 FP , JDM V7 intake/ tgvless , Coolant bypass , grounding kit , Perrin MBC . I know the tune ias supposed to be for 20lbs but I have MBC set for 15 to be safe until I get tuned .

I put over 800 miles on engine and out of the blue this happened . only thing I did was fix hose for the TB to IC that was leaky. I also have small oil leak from valve cover.

thanks in advance
* Registered users of the site do not see these ads.
traffic80 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Non-STI 2.5 swap vs. 2.0 swap? anon_az Subaru Conversions 6 03-20-2010 12:33 PM
2.5 Swapped Bugeye Slyte Member's Car Gallery 15 06-02-2007 03:22 PM
help needed, Cobb 2.5, CEL misfire 1&4 sfjohnson Factory 2.0L Turbo Powertrain 11 02-21-2007 02:29 PM
2.2 - 2.5 swap 97 impreza wagon MC Racing Normally Aspirated Powertrain 7 04-24-2002 06:55 PM
97 2.5 GT Misfire cylinder 2 nightmare?!! jsnspence Legacy Forum 8 02-15-2002 10:32 AM


All times are GMT -4. The time now is 06:08 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.