Welcome to the North American Subaru Impreza Owners Club Friday April 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Proven Power Bragging

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-15-2008, 10:41 PM   #1
rexblake
Scooby Specialist
 
Member#: 178426
Join Date: Apr 2008
Location: FoCo
Vehicle:
2010 Audi S4
Black

Default TD04 with bolt ons

I can't seem to make any more power out of my car, so, it looks like the stock turbo is just going to have to go. The relevant mods:

Grimmspeed intake manifold
Grimmspeed TGV deletes
Grimmspeed exhaust manifold
Grimmspeed uppipe with Tial 38mm EWG
Grimmspeed Throttle body

Everything is ported and polished as well as ceramic coated. Exhaust headers and uppipe are wrapped as well.

Grimmspeed internal wastegate bracket
Grimmspeed phenolic spacers
Cobb short ram air intake
Samco Turbo inlet hose
STi intercooler
Walbro 255
DW 750
Perrin BCS

This is a Dyno Dynamics Dyno. Stock 2.0's make 150ish wheel, stock STi's make 200ish wheel.







* Registered users of the site do not see these ads.

Last edited by rexblake; 10-16-2008 at 12:56 AM.
rexblake is offline   Reply With Quote
Old 10-15-2008, 10:57 PM   #2
rexblake
Scooby Specialist
 
Member#: 178426
Join Date: Apr 2008
Location: FoCo
Vehicle:
2010 Audi S4
Black

Default

Here's a video. Somehow, it's not nearly as loud on the video as it is in person. Its absolutely screaming loud with that ewg.

[IMG][/IMG]

I would also like to thank Grimmspeed for all their help. I have called a couple times late at night and they were more than happy to help, not to mention my whoa's where I simply took my car to them and picked their brain for as much knowledge as possible. Best customer service in the business bar none!
rexblake is offline   Reply With Quote
Old 10-15-2008, 11:05 PM   #3
jmlaser
Scooby Specialist
 
Member#: 125529
Join Date: Sep 2006
Chapter/Region: MWSOC
Location: Central Ohio
Vehicle:
02 WRX 18G EJ205
1/4 mi stock block record

Default

Grimmspeed ROCKS! I have alot of thier products on my car. Actually a very similar modlist to yours,... Here is my most recent thread. My question is this,... Do you like the tune? Does it satisfy you?
I dont want to second guess but it does seem to spool a little slow... about 500rpm it seems
And I am not trying to knock you or anything. The TD04 is soo much fun on the 2.0! Congrats!
jmlaser is offline   Reply With Quote
Old 10-15-2008, 11:49 PM   #4
GrimmSpeed
NASIOC Vendor
 
Member#: 136396
Join Date: Jan 2007
Chapter/Region: MWSOC
Location: Minneapolis, MN
Vehicle:
2013 BRZ
SWP

Default

peter....yeah i'm thinking something is definitely wrong with your car. youre only looking at stage 2 numbers there and you should be way over that with your mods.

i believe you said your turbo has 130k+ on it right? it may very well be the turbo is shot.


oh, and look at jmlaser's numbers with our stuff on it....you should be more around that.

Justin
GrimmSpeed is offline   Reply With Quote
Old 10-16-2008, 12:52 AM   #5
rexblake
Scooby Specialist
 
Member#: 178426
Join Date: Apr 2008
Location: FoCo
Vehicle:
2010 Audi S4
Black

Default

yeah, something is different, but I really wonder if it isn't something to do with the dyno. I know the Cobb AP runs high, but I Jjust did a run now and it said 304hp and 348tq at the wheels! I think I try and make it up to the MA Performance dyno day, see what theirs says. It sure drives different, I can't shift fast enough in first.

But then again, he is also spooling a hell of a lot quicker!
rexblake is offline   Reply With Quote
Old 10-16-2008, 09:06 AM   #6
jmlaser
Scooby Specialist
 
Member#: 125529
Join Date: Sep 2006
Chapter/Region: MWSOC
Location: Central Ohio
Vehicle:
02 WRX 18G EJ205
1/4 mi stock block record

Default

Best bet is to go to the track and see what it traps.

Last edited by jmlaser; 10-16-2008 at 09:58 PM.
jmlaser is offline   Reply With Quote
Old 10-16-2008, 02:16 PM   #7
tux121
Scooby Specialist
 
Member#: 162942
Join Date: Oct 2007
Location: MN
Vehicle:
2006 STi Black&Gold
Stage 2

Default

I bet it's fast at the track, but yeah that's as far as you can go with the TD04.
tux121 is offline   Reply With Quote
Old 10-16-2008, 02:32 PM   #8
SonicYeller
Scooby Specialist
 
Member#: 147755
Join Date: May 2007
Location: Cheyenne, WY
Vehicle:
2003 SonicYellow WRX
2009 Cobalt SS Turbo

Default

I think the numbers seem a little low too. Definitely take it to the track and run it.

Just for reference, I had my 03 WRX Protuned in @ Revolutions Performance in Colorado Springs, CO (6100ft alt) and made 197AWHP/195AWTQ @15psi peak using a 1.15 CF on a Dyno Dynamics.

Mods were:
-SPT Intake
-Invidia V2 Catless BellMouth DP
-ERZ 3" Catback
-DC Sports U/P
-Cobb AP V2 on 93 oct
-Perrin LW Crank pulley
-Turbo XS I/C Y-Pipe
SonicYeller is offline   Reply With Quote
Old 10-16-2008, 07:01 PM   #9
TDagen
Scooby Specialist
 
Member#: 163648
Join Date: Nov 2007
Chapter/Region: MWSOC
Location: Minnesota, mpls
Vehicle:
2002 Wrx,2.5L,HTA86
E85,2007 6mt,No traction

Default

Looks like its time for something bigger your maxxing that thing out. Its probably blowing hot air. Bigger turbo run it conservative even if you wanna, but it will probably be more efficient.
TDagen is offline   Reply With Quote
Old 10-16-2008, 07:18 PM   #10
All4bSpinnin
Scooby Guru
 
Member#: 99102
Join Date: Oct 2005
Chapter/Region: South East
Location: Jax, FL
Vehicle:
08 Corvette Z06
problem Traction?

Default

i think the power is ok... its making about 240 whp on other dynos... but i agree... something is wrong... its spooling pretty late... normally td04's are fully online/peak tq by 3k

i have seen td05 16G's spool that fast... you might want to check for a boost leak... something is going on... also, in the video, it sounded like you have wastegate flutter... i think it was the video though... check for exhaust leaks too
All4bSpinnin is offline   Reply With Quote
Old 10-16-2008, 07:23 PM   #11
All4bSpinnin
Scooby Guru
 
Member#: 99102
Join Date: Oct 2005
Chapter/Region: South East
Location: Jax, FL
Vehicle:
08 Corvette Z06
problem Traction?

Default

here's what a i mean... your dyno:


and a td06 20G w/meth


something is up with your car
All4bSpinnin is offline   Reply With Quote
Old 10-16-2008, 07:42 PM   #12
bmw50021
Scooby Specialist
 
Member#: 122393
Join Date: Aug 2006
Chapter/Region: Tri-State
Location: Wayne, NJ
Vehicle:
02 WRX
WRB

Default

Quote:
Originally Posted by All4bSpinnin View Post
something is up with your car
+82385232345723

thats pretty much how my vf39 spools on a stock 2.0 with none of those pnp goodies. cept i have about +70whp/wtq more.
bmw50021 is offline   Reply With Quote
Old 10-16-2008, 07:45 PM   #13
amazonparrot
Scooby Specialist
 
Member#: 57070
Join Date: Mar 2004
Chapter/Region: MAIC
Location: Arlington, VA
Vehicle:
2003 Impreza WRX
Hybrid 2.5 / Aspen White

Default

I can't comment on whether the max power is a little low or not, but for a td04 with an external wastegate...that is some seriously late peak boost....im hitting near that with an internally gated vf34...might want to look into it
amazonparrot is offline   Reply With Quote
Old 10-16-2008, 08:24 PM   #14
bmw50021
Scooby Specialist
 
Member#: 122393
Join Date: Aug 2006
Chapter/Region: Tri-State
Location: Wayne, NJ
Vehicle:
02 WRX
WRB

Default

bmw50021 is offline   Reply With Quote
Old 10-17-2008, 01:58 AM   #15
rexblake
Scooby Specialist
 
Member#: 178426
Join Date: Apr 2008
Location: FoCo
Vehicle:
2010 Audi S4
Black

Default

I saw JMLaser's post, his has almost the exact same set up, with out E85, and pulls more power and better spool. I think I am going to have to bite the bullet and take the manifold out, put in new gaskets, and see what happens.

DB Performance did a leak down test when I had it up there the first time and things seemed to be fixed (ie, we didn't hear anything). Just tightened a few bolts and let her rip. But perhaps there is still something leaking.

All4bSpinnin: What cause's wastegate flutter? I agree that it sounds like it is fluttering, I was surprised it was opening so early, but it still holds boost well (another reason the we thought there were no more boost leaks). This is my first experience with a EWG, so I don't really know what to listen/look for.
rexblake is offline   Reply With Quote
Old 10-17-2008, 10:55 AM   #16
jmlaser
Scooby Specialist
 
Member#: 125529
Join Date: Sep 2006
Chapter/Region: MWSOC
Location: Central Ohio
Vehicle:
02 WRX 18G EJ205
1/4 mi stock block record

Default

It always seemed like my EWG opened alot sooner than I would have thought with my TD04 setup also. I think it is such a small housing that it has all the gasses it needs to provide the boost it is being called to produce, hence it dumps the additional gases.
jmlaser is offline   Reply With Quote
Old 10-17-2008, 11:54 AM   #17
tmarcel
Scooby Specialist
 
Member#: 7555
Join Date: Jun 2001
Chapter/Region: South East
Location: Charlotte NC
Default

A few notes/comments here.

1.) That's about 250whp on a DynoJet (DJ).
2.) Comparing the inertia style of the DJ to a low inertia, electromagnetic loading dyno isn't a fair comparison. Take a look at the same car (any car), one on the DJ and one on the Dyno Dynamics (DD) and the DJ will always show higher torque and it comes on considerably sooner.
3.) All of the IHI VF3x turbo Subarus I've seen and/or tuned (and it's been many) on the local AWD DD to me make in the 255-280whp range on 93 octane (the proof is in the data logs)
4.) To the OP, do you recall what DD correction factor was? Leaving it on default it will show up as 1.xx/CF. It may have even been turned completely off showing 1:1/CF
5.) And lastly, your proof lies in a data log, primarily MAF g/s. Do you have or are you able to log? This will better give you an idea rather than everyone trying to compare dyno-to-dyno, which nevers works very well.
tmarcel is offline   Reply With Quote
Old 10-17-2008, 01:12 PM   #18
rexblake
Scooby Specialist
 
Member#: 178426
Join Date: Apr 2008
Location: FoCo
Vehicle:
2010 Audi S4
Black

Default

I do have the Cobb street tuner software on my computer, however, I haven't ever used it, nor do I know how. Is that capable of saving logged data? Anyone know how to do it or a link as to how to do it?
rexblake is offline   Reply With Quote
Old 10-17-2008, 01:39 PM   #19
All4bSpinnin
Scooby Guru
 
Member#: 99102
Join Date: Oct 2005
Chapter/Region: South East
Location: Jax, FL
Vehicle:
08 Corvette Z06
problem Traction?

Default

Quote:
Originally Posted by rexblake View Post

All4bSpinnin: What cause's wastegate flutter? I agree that it sounds like it is fluttering, I was surprised it was opening so early, but it still holds boost well (another reason the we thought there were no more boost leaks). This is my first experience with a EWG, so I don't really know what to listen/look for.
What spring are you running in your EWG? Id be willing to bet that your EWG spring is too small and its opening up early

Last edited by All4bSpinnin; 10-17-2008 at 01:51 PM.
All4bSpinnin is offline   Reply With Quote
Old 10-17-2008, 01:44 PM   #20
tmarcel
Scooby Specialist
 
Member#: 7555
Join Date: Jun 2001
Chapter/Region: South East
Location: Charlotte NC
Default

rexblake,

I don't know much about the Cobb product but you should be able to I would think. Alternatively, I believe that you can also use your cable with open source (OpenEcu) software though. IF it'll connect up then you can download RomRaider and use the logger feature. Simply check off the data that you'd like to log.
tmarcel is offline   Reply With Quote
Old 10-17-2008, 04:38 PM   #21
rexblake
Scooby Specialist
 
Member#: 178426
Join Date: Apr 2008
Location: FoCo
Vehicle:
2010 Audi S4
Black

Default

It's the .9 spring.
rexblake is offline   Reply With Quote
Old 10-17-2008, 04:52 PM   #22
All4bSpinnin
Scooby Guru
 
Member#: 99102
Join Date: Oct 2005
Chapter/Region: South East
Location: Jax, FL
Vehicle:
08 Corvette Z06
problem Traction?

Default

that should be enough.... hmmm.... let me think a bit
All4bSpinnin is offline   Reply With Quote
Old 10-17-2008, 06:22 PM   #23
slowwrx02
Scooby Newbie
 
Member#: 117548
Join Date: Jun 2006
Location: BEAVERTON OR
Vehicle:
02 WRX
WRB

Default

wow those are low number my 02 stage 2 dyno not tuned with bad turbo. nut in turbo hot side. and made 200whp and 187tq at pdxtuning in portland
slowwrx02 is offline   Reply With Quote
Old 10-17-2008, 06:38 PM   #24
Ctracer911
Scooby Specialist
 
Member#: 73405
Join Date: Oct 2004
Default

"I can't seem to make any more power out of my car, so, it looks like the stock turbo is just going to have to go. The relevant mods:

Grimmspeed intake manifold
Grimmspeed TGV deletes
Grimmspeed exhaust manifold
Grimmspeed uppipe with Tial 38mm EWG
Grimmspeed Throttle body

Everything is ported and polished as well as ceramic coated. Exhaust headers and uppipe are wrapped as well.

Grimmspeed internal wastegate bracket
Grimmspeed phenolic spacers
Cobb short ram air intake
Samco Turbo inlet hose
STi intercooler
Walbro 255
DW 750
Perrin BCS
"

NO EXHAUST??
Ctracer911 is offline   Reply With Quote
Old 10-18-2008, 12:07 AM   #25
rexblake
Scooby Specialist
 
Member#: 178426
Join Date: Apr 2008
Location: FoCo
Vehicle:
2010 Audi S4
Black

Default

Quote:
Originally Posted by Ctracer911 View Post
"I can't seem to make any more power out of my car, so, it looks like the stock turbo is just going to have to go. The relevant mods:

Grimmspeed intake manifold
Grimmspeed TGV deletes
Grimmspeed exhaust manifold
Grimmspeed uppipe with Tial 38mm EWG
Grimmspeed Throttle body

Everything is ported and polished as well as ceramic coated. Exhaust headers and uppipe are wrapped as well.

Grimmspeed internal wastegate bracket
Grimmspeed phenolic spacers
Cobb short ram air intake
Samco Turbo inlet hose
STi intercooler
Walbro 255
DW 750
Perrin BCS
"

NO EXHAUST??
Ividia V3 downpipe, full 3in custom exhaust with magnaflow muffler.
rexblake is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
02 wrx td04 with bolt ons hard2kill Proven Power Bragging 41 08-07-2009 05:09 PM
What's a Ford F150 with Bolt-ons Good For? f4phantomii Off-Topic 16 06-13-2007 10:17 AM
My car with bolt-ons just as fast as a stock RS? NFJ79 Normally Aspirated Powertrain 12 03-05-2006 03:53 AM
gas mileage with bolt ons? busaru25 Mid West Subaru Owners Club Forum -- MWSOC 19 01-21-2006 07:45 AM
('93-'01) Horse Power claims with bolt-ons of MY93-00 subby00 Impreza Forum 6 12-11-2004 12:50 AM


All times are GMT -4. The time now is 09:50 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.