Welcome to the North American Subaru Impreza Owners Club Wednesday May 6, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
North West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > North West Impreza Club Forum -- NWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-19-2008, 03:43 PM   #1
Kraziken
Scooby Specialist
 
Member#: 38629
Join Date: Jun 2003
Chapter/Region: NWIC
Location: Northwest
Vehicle:
1999 Legacy GT (STI)
White

Default Dangerous EGT temps -folks at the track what have you seen?

I took my car to Pacific Raceways last week.
My car and another owner with an 04 WRX had EGT temps in the 1650 range. I think I hit 1680 once.

Is this normal? What have other seen? Both of us are running one high flow cat I believe. What can we do to lower temps?
* Registered users of the site do not see these ads.
Kraziken is offline   Reply With Quote
Old 10-19-2008, 04:18 PM   #2
Solar Reflections
Vendor
 
Member#: 88346
Join Date: Jun 2005
Location: SRP
Vehicle:
3108 A St SE Auburn
WA 98002

Default

That seems normal for a lapping day doing 150+ down the straight.

Add fuel to lower the temp.
Solar Reflections is offline   Reply With Quote
Old 10-19-2008, 05:02 PM   #3
Cone Klr
Scooby Newbie
 
Member#: 73072
Join Date: Oct 2004
Chapter/Region: NWIC
Location: Eugene/portland
Vehicle:
02 wrx, 04sti
WRB squared!

Default egt

It really depends on where in the exhaust your egt sensor is located. 1650 is a normal temp to read if your sensor is located in the header manifold. you should read around 1400 if it is in the up pipe. much more than that and you could be running a lean.
Cone Klr is offline   Reply With Quote
Old 10-19-2008, 06:11 PM   #4
TCSTi
Scooby Newbie
 
Member#: 164362
Join Date: Nov 2007
Chapter/Region: NWIC
Location: Portland, OR
Vehicle:
2004 STi
Black

Default

1650 is okay as long as the sensor is within 6 inches of the exhaust port. I had mine hit almost 2000 when my fuel pressure dropped off running 30psi on a Red. Thank goodness for forged pistons!
TCSTi is offline   Reply With Quote
Old 10-19-2008, 08:30 PM   #5
Airborne Guy
Scooby Specialist
 
Member#: 68516
Join Date: Aug 2004
Chapter/Region: NWIC
Location: NC
Vehicle:
2002 325i 2005 R6
R.I.P. MasterTuned©

Default

When I was at my last lapping day at Bremerton I hit 1700 a couple of times. Mostly only got 1650. Probe in manifold

Everything felt normal, no knock or stutter or anything (per log data from UTEC)
Airborne Guy is offline   Reply With Quote
Old 10-19-2008, 10:31 PM   #6
tazswing
Scooby Specialist
 
Member#: 63767
Join Date: Jun 2004
Chapter/Region: NWIC
Location: PDX
Vehicle:
2009 OXT 5-spd
2011 STi hatch

Default

I have got close to 1700 before during laping days. The last two I did was with a track map Tim Bailey built for me. I saw about 200 degree lower EGT temps with this map.

Last edited by tazswing; 10-19-2008 at 11:29 PM.
tazswing is offline   Reply With Quote
Old 10-19-2008, 10:37 PM   #7
06subienubie
Scooby Specialist
 
Member#: 132286
Join Date: Nov 2006
Chapter/Region: NWIC
Location: Auburn
Vehicle:
2006 STI
sgm

Subaru Stars

My sensor is welded in the header collector, I set my EGT alarm for 1650 and it went off once climbing the pass on the cascade loop run.
06subienubie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The " DUDE have you seen the OHLINS sales at Racecomp?.." sale !! RaceComp Engineering MAIC Vendor Classifieds 49 01-24-2009 05:18 PM
Hey middle of the country people... Have you seen any Cicadas yet? Drink Off-Topic 30 06-03-2007 01:07 AM
Bleed brakes at the track - what do you do with it? chimchimm5 Motorsports 17 10-05-2006 06:28 PM
What have you seen a WRX scoupe on? nomadtw Off-Topic 17 12-19-2004 10:46 PM
sad day at the track...Whats my problem. beobe99 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 4 11-09-2002 03:20 AM


All times are GMT -4. The time now is 01:57 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.