Welcome to the North American Subaru Impreza Owners Club Thursday August 27, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-21-2008, 09:17 PM   #1
racer_x
Scooby Newbie
 
Member#: 175722
Join Date: Mar 2008
Default Cooling system problem - car idles at 3k

Hey folks,

Sorry to make a post, but after reading through different threads, my answers are still unclear.

First off, this is a 2002 wrx with a JDM version 8 STi 2.0L swap.

Basically, my friend was driving when his lower radiator hose popped off, causing the car to (very) briefly overheat. He saw the steam, shut the car off, and we've been unable to burp the coolant system by any method and get the RPMs down below 3000.

I am reluctant to let the car idle for 15-20 minutes at a time because of the fact that the idle is so high.

Suggestions?

I'm guessing it's the air in the system that's making it idle so high, but we can't get it out for crap. Help!

Thanks guys
* Registered users of the site do not see these ads.
racer_x is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-21-2008, 09:29 PM   #2
racer_x
Scooby Newbie
 
Member#: 175722
Join Date: Mar 2008
Default

BTW, temperature gauge reads low when car is cold, heats up to normal temp.
racer_x is offline   Reply With Quote
Old 10-21-2008, 09:29 PM   #3
racer_x
Scooby Newbie
 
Member#: 175722
Join Date: Mar 2008
Default

is it possible that this caused an issue with the IACV?
racer_x is offline   Reply With Quote
Old 10-22-2008, 12:17 PM   #4
racer_x
Scooby Newbie
 
Member#: 175722
Join Date: Mar 2008
Default

bump, thanks for looking
racer_x is offline   Reply With Quote
Old 10-22-2008, 12:23 PM   #5
yarrgh
Scooby Specialist
 
Member#: 80465
Join Date: Jan 2005
Chapter/Region: RMIC
Location: Aurora, CO
Vehicle:
2001 2.5RS
Black Diamond Pearl

Default

did you take off the upper radiator hose to fill it? Doesn't coolant run thru the TB? could that throw off your idle? It may take a couple of cycles to get all the air out.
yarrgh is offline   Reply With Quote
Old 10-22-2008, 01:28 PM   #6
racer_x
Scooby Newbie
 
Member#: 175722
Join Date: Mar 2008
Default

I bypassed the TB coolant because we're in FL
racer_x is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cooling system problem gakusya Service & Maintenance 15 02-11-2011 09:00 PM
"Burping" Cooling System Problems.. STI_KLR Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 31 11-03-2008 03:16 PM
i have a big cooling system problem! TheBryman Service & Maintenance 11 06-12-2007 02:21 PM
Cooling system problem? taphonomist Service & Maintenance 0 04-17-2005 04:40 PM
I'm confused. Cooling system problems... fastenova Legacy Forum 10 04-16-2005 10:15 PM


All times are GMT -4. The time now is 04:19 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.